linuxforen.de -- User helfen Usern

Zurück   linuxforen.de -- User helfen Usern > Netzwerk > Linux als Server
Registrieren Hilfe Benutzerliste Kalender Alle Foren als gelesen markieren

Linux als Server Web, Mail, FTP, DNS, SAN, NAS und Andere

Antwort
 
Themen-Optionen Thema bewerten Ansicht
Alt 04.05.12, 10:31   #1
bigblue2010
Registrierter Benutzer
 
Registriert seit: May 2010
Beiträge: 59
modrewrite Lösungsansatz

Hallo Zusammen,

auf einem meiner vhosts habe ich folgede Rewrite-Regel eingetragen, damit alle Zugriffe auf den Port 443 Umgeleitet werden:

Code:
RewriteCond %{SERVER_PORT} !^443$
RewriteRule ^.*$ https://%{SERVER_NAME}%{REQUEST_URI} [L,R]
Jetzt gibt es aber ein paar Seiten die nicht über 443 laufen sollten sondern unter Port 80. Wie greife ich diese Seiten auf und leite sie an Port 80 weiter?

Beispiel:

www.example.com --> 443
www.example.com/keine/verschluesselung/ --> 80


EDIT:
Ich hab es nun wie folgt vesucht, aber leider klappt das nicht: Die aufgerufene Website leitet die Anfrage so um, dass sie nie beendet werden kann:

Code:
RewriteCond %{REQUEST_URI} keine/verschluesselung
RewriteRule ^.*$ http://%{SERVER_NAME}%{REQUEST_URI} [L,R]


Danke im Voraus für Eure hilfe.

Marcus

Geändert von bigblue2010 (04.05.12 um 10:42 Uhr)
bigblue2010 ist offline   Mit Zitat antworten
Alt 04.05.12, 21:14   #2
nopes
Registrierter Benutzer
 
Registriert seit: Apr 2009
Beiträge: 862
Ich verstehe nicht warum das R-Flag ([R]) auch bei nicht verschlüsselten Seiten verwendet wird.

Naja ich denke sogar das ist dein Problem, schließlich leitest du den auf sich selber um - was ansich schon ein bisschen crank ist
Vermutlich wirkt das wie ein neuer Request, der dann wieder umgeleitet wird und wieder und wieder und wieder und das Icon dreht und dreht und dreht und dreht und der Indianer2 kotzt

Also [R] für Port 80 weg (ersetzen würde ich mit $&, das rewrite VOR das für Port 443 und alles dürfte gut sein:
Code:
RewriteCond %{REQUEST_URI} keine/verschluesselung
RewriteRule ^.*$ $& [L]

RewriteCond %{SERVER_PORT} !^443$
RewriteRule ^.*$ https://%{SERVER_NAME}%{REQUEST_URI} [L,R]
Natürlich kannst du auch die Kondition für die Umleitung auf 443 korrigieren (die ich ehrlich gesagt ziemlich gewagt finde) und das Problem so lösen, dass gewollte 80er gar nicht erst befummelt werden (wäre sauberer!) - s.a. http://httpd.apache.org/docs/current/rewrite/
__________________
Gruß nopes
(,,,)---(^.^)---(,,,) /var/log/messages | grep cat

Geändert von nopes (04.05.12 um 21:22 Uhr)
nopes ist offline   Mit Zitat antworten
Antwort

Lesezeichen

Themen-Optionen
Ansicht Thema bewerten
Thema bewerten:

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Lösungsansatz DNS privates Subnet nach öffentlichem Netz minimike Linux als Server 4 03.11.10 22:52
Lösungsansatz für Benutzerlogin per Server ReaTh Linux als Server 0 23.05.04 14:25
DVB kein Ton...evtl Lösungsansatz gefunden BugB Fernsehen 2 27.04.03 10:28
ATI-TV-OUT Lösungsansatz?!? maxxle Fernsehen 8 09.03.03 13:23


Alle Zeitangaben in WEZ +1. Es ist jetzt 01:38 Uhr.


Powered by vBulletin® Version 3.8.6 (Deutsch)
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
linuxforen.de -- sponsored by Kemm IT