linuxforen.de -- User helfen Usern

Zurück   linuxforen.de -- User helfen Usern > Multimedia > Musik
Registrieren Hilfe Benutzerliste Kalender Alle Foren als gelesen markieren

Musik Soundkarten, Musikmachen, Harddiskrecording, MP3

Antwort
 
Themen-Optionen Thema bewerten Ansicht
Alt 28.04.12, 09:30   #1
f_m
Registrierter Benutzer
 
Registriert seit: May 2004
Beiträge: 1.543
Tonqualität mit Alsa und Pulseaudio?

Kurzum, ich bin mit der Qualität unter Alsa (mit der openSUSE Standardkonfiguration) unzufrieden - da ich mich bisher auch nicht intensiv bzw. kaum mit dem Soundsystem auseinandergesetzt habe weiß ich auch nicht so recht wo man da am Besten ansetzt.

Die verwendete Hardware ist eher aus dem billigen Bereich (ALC 892 onboard Sound und ältere Logitech 5.1 Boxen) aber das ist im Grunde nicht das Thema da ich weiß daß auf genau dem System wesentlich bessere Qualität möglich ist indem ich den OSS4 Treiber von 4Front statt Alsa installiere.
Damit bekomme ich deutlich reineren Klang raus, unter Alsa wirkt das alles etwas verwaschen, Bässe dröhnen mehr, einzelne Instrumente sind schlechter oder gar nicht herauszuhören. Dasselbe Ergebnis hab ich auch auf anderen Systemen (alter PC und Laptop) bemerkt.

Stellt sich natürlich die Frage warum ich nicht einfach weitermache mit dem OSS 4 ...
das Umkonfigurieren aller Anwendungsprogramme die nur noch auf Alsa ausgelegt sind ist einfach mühsam, zudem hab ich unter OSS nie das MIkrofon zum Laufen gebracht und mit Flash & Co gibt es auch nur Ärger.

Daher würd ich gern das Alsa mit der Qualität die OSS auch schafft zum Laufen bekommen.. bin für Alle >Vorschläge dankbar
f_m ist offline   Mit Zitat antworten
Alt 28.04.12, 10:39   #2
Newbie314
Newbie and practicing
 
Benutzerbild von Newbie314
 
Registriert seit: Mar 2007
Beiträge: 5.522
Es gibt Alsa Konfigurationsdateien. Dummerweise bin ich da nie richtig durchgestiegen (die Doku die ich gefunden habe war einfach schlecht erklärt).

Eventuell und wenn du wirklich bereit bist stundenlang zu experimentieren könntest du versuchen die Spezialitäten (Abtastfrequenzen etc. ) deiner Hardware mit diesen Treibern genau zu konfigurieren, was die Klangqualität erhöhen würde.

Ich muss ehrlich sagen dass mir das zu viel Aufwand wäre, ich würde in dem Fall einfach andere Hardware anschaffen.


Solltest du das tun und Erfolg haben wäre ein Tutorial hier nicht schlecht, wie gesagt: die Info die ich ergoogelte reichte für meine Intelligenz nicht aus um das Ganze zum Laufen zu bringen.
__________________
PC: Intel Dual Core, OpenSuse 12.3 64 Bit, 3GB Ram, Laptop: Dell, 2 Gb Ram, OpenSuse 11.4.
Bei Konsolenausgaben / Fehlermeldungen bitte immer Code Tags verwenden: [code] -Text- [/code]
Newbie314 ist offline   Mit Zitat antworten
Alt 28.04.12, 10:44   #3
ThorstenHirsch
alias bauerbob
 
Benutzerbild von ThorstenHirsch
 
Registriert seit: Nov 2002
Beiträge: 5.920
Die on/off-switches im alsamixer ("IEC958" und so'n Kram) hast du wahrscheinlich schon ausprobiert, oder? Damit kann man bspw. den upmix von 2 auf 4 Kanäle aktivieren/deaktivieren und ich kann mir vorstellen, dass diese ganzen Spielereien die Tonqualität verschlechtern...
__________________
Dieses Gechatte, dieses Facegebooke und das Getwittere heutzutage - dabei gibt's im Leben so viel mehr zu entdecken. So viel - da musst du nur mal googeln. (Olaf Schubert)
ThorstenHirsch ist offline   Mit Zitat antworten
Alt 28.04.12, 14:17   #4
simpleminds
Registrierter Benutzer
 
Registriert seit: Aug 2005
Beiträge: 126
http://www.google.com/search?hl=en&s...=Google+Search
Alsaequal, oder ähnliches vielleicht? Gut für den mplayer.
Andere mediaplayer haben ihre eigenen equalizer.
simpleminds ist offline   Mit Zitat antworten
Alt 28.04.12, 16:21   #5
f_m
Registrierter Benutzer
 
Registriert seit: May 2004
Beiträge: 1.543
Danke schon mal für die Tipps, IEC958 gibt es bei mir im alsamixer nicht.. habe dort auch ansonsten außer mal das Mikro an und auszumachen nicht groß rumgeschraubt.

Im Moment probier ich gerade mit audacious (ein simpler audioplayer wie der alte xmms); standardmäßig gibt der wie Alles bei SuSE über pulseaudio aus mit fürchterlichen Nebengeräuschen, ständiges Knistern und einem insgesamt verwaschenen Klangbild. Wenn ich das umstelle auf Ausgabe direkt über ALSA ist das um Welten besser.
Leider ist damit auch die SOundkarte blockiert und nicht mehr für andere Anwendungen verfügbar

Kann das sein, daß pulseaudio dermaßen schlecht mixt? Kennt da wer bessere Alternativen? Seltsamerweise verwurstet pulse den Ton sogar dann wenn eh nur ein Programm Ton ausgibt also gar nichts zusammengemischt werden muß...

Geändert von f_m (28.04.12 um 16:34 Uhr)
f_m ist offline   Mit Zitat antworten
Alt 28.04.12, 17:07   #6
Newbie314
Newbie and practicing
 
Benutzerbild von Newbie314
 
Registriert seit: Mar 2007
Beiträge: 5.522
Bei mir funktioniert es eigentlich.. Qualität entspricht meiner Hardware.

Nur meine Wünsche zur individuellen Konfiguration von drei Soundkarten konnte ich nicht so einfach verwirklichen...

Oder solche Spielchen wie ein Micro an eine Virtual-Box VM durchzureichen etc... habe einfach weder die Zeit noch den Nerv da ewig rumzufrickeln...
__________________
PC: Intel Dual Core, OpenSuse 12.3 64 Bit, 3GB Ram, Laptop: Dell, 2 Gb Ram, OpenSuse 11.4.
Bei Konsolenausgaben / Fehlermeldungen bitte immer Code Tags verwenden: [code] -Text- [/code]
Newbie314 ist offline   Mit Zitat antworten
Alt 28.04.12, 17:20   #7
undefined
Registrierter Benutzer
 
Benutzerbild von undefined
 
Registriert seit: Feb 2004
Beiträge: 1.531
Zitat:
Zitat von f_m Beitrag anzeigen
Kurzum, ich bin mit der Qualität unter Alsa (mit der openSUSE Standardkonfiguration) unzufrieden - da ich mich bisher auch nicht intensiv bzw. kaum mit dem Soundsystem auseinandergesetzt habe weiß ich auch nicht so recht wo man da am Besten ansetzt.
..........
Da bist du nicht der Einzige...
Als ich mit meinem Betriebssystem auf ein neue HW umgestiegen bin hatte ich mit HDA Azali Ehemals (via8235) auch so meine Problemchen gehabt. Die HDA Karten sind nicht dmix Tauglich was das Problem um so ernster macht.

Früher hatte ich mit dmix eine Pulse Spur und zwei pcm.*equalizer Spuren. Damit konnte man mal so richtig tricksen und Qualität heraus kitzeln.

Es gibt Natürlich die Möglichkeit auch mit Pulse einen Vernünftigen Sound hin zu bekommen. Aber lass dir gesagt sein das macht ne Menge Testen und ein bisschen Sachverstand von C Sollte man haben. Es wird Dir nämlich auch das gleiche Passieren wie mir. Loops und Speicherzugriffs Fehler.

Lange rede kurzer Sinn...
Gehe wie folgt vor...
  1. Pulse abschalten und erst mal Alsa richtig Konfigurieren
  2. Bei SuSE die /etc/profile.d/pulseaudio.*sh Löschen oder Leeren
  3. Eine Neue /etc/profile.d/asound.sh Erstellen Damit sie nicht von Yast Überschrieben wird!
  4. Die Verwendung von pulesaudio in kmix verhindern! export KMIX_PULSEAUDIO_DISABLE=1
  5. Wir benötigen ladspa also export LADSPA_PATH=/usr/lib/ladspa
  6. systemd's Alsa Config Überschreiben export ALSA_CONFIG_PATH=/etc/asound.conf
  7. Das Verzeichnis /etc/alsa erstellen und Konfiguration für jede Karte hier ablegen. (Damit wird ein Überschreiben verhindert!)
Zuerst eine eigene /etc/modprobe.d/50-sound.conf und die Karten mit index (Das ist WICHTIG) erstellen.
Bei mehreren hda Karten muss grub mit ins Spiel kommen
grub CMD Eintrag
Code:
snd.slots=snd-hda-intel,snd-hda-intel
/etc/modprobe.d/50-sound.conf Beispiel
Code:
# Mainboard Soundkarte VT1818S (Intel HDA)
alias sound-slot-0 snd-card-0
alias snd-card-0 snd-hda-intel

# HDMI Ausgang der NVidia Karte
alias sound-slot-1 snd-card-1
alias snd-card-1 snd-hda-intel

options snd-hda-intel index=0,1 id=Karte0,Karte1
Wenn die Karten Sauber geladen werden und die Indexes Stimmen.
Siehe aplay -l dann eine Neue /etc/asound.conf erstellen
Ein Beispiel Inhalt!
Code:
####################################
## Hook
####################################
@hooks [
  {
    func load
    files [
      "/etc/alsa/00-card0.conf"
      "/etc/alsa/01-sound.conf"
      "/etc/alsa/04_lavcrate_plugin.conf"
      "/etc/alsa/04_samplerate_plugin.conf"
      "/etc/alsa/04_speexrate_plugin.conf"
      "~/.asoundrc"
    ]
    errors false
  }
]

pcm.!default {
  type plug
  slave.pcm "audioausgabe"
}

<confdir:alsa.conf>

## EOF
Jetzt kommt der Trick
Du kannst mit Alsa ladspa verwenden. Das geht zwar auch mit Pulse aber ist so Schei... umgesetzt das ich es direkt wieder verworfen habe. Man kann keine Zeilenumbrüche verwenden
Wichtig - Vergiss die Konfiguration
Code:
pcm.pulse {type pulse}
ctl.pulse {type pulse }
Das wird mit der neuen Konfiguration einen Loop erzeugen der dein ganzes System aufhängt! - Warum wirst du Später verstehen

Erstelle eine Karten Konfiguration.
z.B.: /etc/alsa/00-card0.conf
Zur Erinnerung - der index wurde in der modprobe Konfiguration vergeben
Code:
pcm.Karte0 {
	type      hw
	card      0
	device    0
	subdevice -1
}

ctl.Karte0 {
	type      hw
	card      0
}
testen z.b: mit aplay -v -Dplug:Karte0 /usr/share/sounds/alsa/test.wav

Danach ein DMIX Plugin erstellen une einen Equalizer einbauen!
Code:
###################################################################
# Audio ueber Equalizer Ausgeben
###################################################################
## aplay -vv /usr/share/sounds/test/ibanez.wav

pcm.audiodmix {
  type dmix
  ipc_key       2009094 ## Muss Unique sein!
  slave {
    pcm         Karte0 ## Auch wieder index
    period_time 0
    period_size 1024
    buffer_size 8192
    format      S16_LE
    rate        48000  ## Kann meine Karte 48000?
  }
  bindings {
    0 0
    1 1
  }
  slowptr true
}

ctl.audiodmix {
  type hw
  card 0
}

pcm.audioequalizer {
  type ladspa
  slave.pcm  plug:audiodmix
  path       "/usr/lib/ladspa/"
  playback_plugins {
    0 {
      id       2594
      name     "Equalizer"
      label    "Eq2x2"
      filename "/usr/lib/ladspa/caps.so"
      policy   none
      input {
        controls {
          0 -24 #  31 Hz  @modified(2011/01/05) 48 > 24
          1 -16 #  63 Hz  @modified(2011/01/05) 24 > 16
          2 -4  # 125 Hz  @modified(2011/01/05)  8 > 4
          3 -2  # 250 Hz 
          4  1  # 500 Hz  @modified(2009/06/22)  0 > 1
          5  2  #   1 kHz @modified(2009/06/22)  0 > 2
          6  1  #   2 kHz @modified(2009/06/22)  0 > 1
          7  0  #   4 kHz
          8  0  #   8 kHz
          9  0  #  16 kHz
        }
      }
    }
  }
}

## aplay -vDplug:audioausgabe /usr/share/sounds/test/ibanez.wav
pcm.audioausgabe { ## Siehe /etc/asound.conf
  type asym
  playback.pcm "audioequalizer"
}
Du kannst so viele Filter und Plugins Hintereinander hauen wie du Lust und Laune hast. Es gibt bei ladspa so um die 1000 Stück
Siehe /usr/bin/listplugins und /usr/bin/analyseplugin
z.B.:
Code:
analyseplugin  caps.so Eq2x2
Wennn das alles funktioniert geht zu pulse!

Jetzt geht das Pulse Geraffel los
Pulse hat die Zwanghafte Eigenschaft dem Benutzer die Konfiguration ab zu nehmen.
Das kann einen zu Wutausbrüchen bringen! (Am besten vorher mal Tief einatmen)

Ziel ist es Pulse bei zu bringen nicht Direkt auf die Hardware zu zugreifen sondern die alsa:default zu verwenden!

Dafür müssen erst mal die pulse module entfernt werden die das ganze von vorn herein verhindern.
Dazu zählen die udev und hal Module etc. also Einträge wie "load-module module-udev-detect" .... Auskommentieren.

Auch unter pulse muss man jetzt einen index erstellen!
Dazu verwenden wir module-alsa-card
Ein "pacmd list-modules | grep alsa" wird zu diesem Zeitpunkt nicht Funktionieren. Deshalb hier die Infos:
Code:
argumente fuer module-alsa-card:
  device_id="0"
  name="PulseStandard"
  card_name="default"
  ignore_dB=no
  deferred_volume=yes
Default setzen z.B.
Code:
set-default-sink PulseStandard
set-default-source PulseStandard
Es gibt so ein nettes Script namens start-pulseaudio-x11 was leider auch heftig in diese Konfiguration herein semmelt!
Abhilfe Mit dem gleichen Namen im eigenen bin Verzeichnis ablegen und darauf achten das die Variable PATH die richtige Reihenfolge aufweist!
PHP-Code:
#!/bin/sh
#
# Startscript fuer den pulse daemon
#
set -e

## Nur mit laufenden X-Server verwenden!
test -"$DISPLAY" || exit 0

## Wenn vorhanden nicht starten!
test -f $HOME/.pulse/disabled && {
  echo 
"pulseaudio server disabled by user configuration"
  
exit 0
}

## pactl
test -/usr/bin/pactl || exit 1
test 
-/etc/pulse/x11_publish.conf || exit 1
test 
-/usr/bin/pulseaudio || exit 1

/usr/bin/pulseaudio --start "$@"

. /etc/pulse/x11_publish.conf

ctlbin
=/usr/bin/pactl

${ctlbinload-module module-x11-publish "display=$DISPLAY sink=$sink source=$source" > /dev/null || true

${ctlbinload-module module-x11-cork-request "display=$DISPLAY" > /dev/null || true

## X-*-Greeter
test -"$SESSION_MANAGER" || exit 0

${ctlbinload-module module-x11-xsmp "display=$DISPLAY session_manager=$SESSION_MANAGER" > /dev/null || true

##eof 
Die Variablen $sink und $source lege ich hier in /etc/pulse/x11_publish.conf ab. Die verweisen auf die Standards siehe set-default-sink und set-default-source.

Pulse und das Shared Memory Problem
Wenn man unter pulse Shared Memory aktivieren möchte wird es sehr Wahrscheinlich daran scheitern das die Gruppe audio keinen Schreibenden Zugriff auf /dev/shm hat.
Ein udev acl Script oder ein init Script kann helfen ...
Code:
## [PULSEAUDIO/JACK]
## FIXME Pulseaudio und jack können nicht auf Shared Memory zugreifen!
if [ -x /usr/bin/setfacl ] && [ -d /dev/shm ] ; then
	echo -n "Setze Shared Memory Berechtigungen fuer pulseaudio und jackd..."
	/usr/bin/setfacl -m group:audio:rwx /dev/shm
	rc_status -v
fi
Es müssen zusätzlich noch die Limits verändert werden!
Weitere Infos zu Realtime http://www.linuxmusicians.com/viewtopic.php?f=10&t=2193

So das war es auf die Schnelle hoffe es hilft etwas.
Jedoch lass dir gesagt sein - Diese info ist nur Grob angekratzt. Es wird einiges an testen Kosten bist du deine gewünschte Qualität erreicht hast.
__________________
mfg undefined
--
Undefined Behavior (undefiniertes Verhalten) bedeutet meistens etwas ungültiges.
Speichenrechner - .htpasswd - qx11grab - MX-1000 Treiber - QTidy
undefined ist offline   Mit Zitat antworten
Alt 29.04.12, 09:58   #8
f_m
Registrierter Benutzer
 
Registriert seit: May 2004
Beiträge: 1.543
Ok, das is ja noch schlimmer als befürchtet... ich warte dann mal auf das nächste verregnete Wochenende
f_m ist offline   Mit Zitat antworten
Alt 29.04.12, 10:51   #9
ThorstenHirsch
alias bauerbob
 
Benutzerbild von ThorstenHirsch
 
Registriert seit: Nov 2002
Beiträge: 5.920
Aber schöne Zusammenfassung, undefined. Vielen Dank!
__________________
Dieses Gechatte, dieses Facegebooke und das Getwittere heutzutage - dabei gibt's im Leben so viel mehr zu entdecken. So viel - da musst du nur mal googeln. (Olaf Schubert)
ThorstenHirsch ist offline   Mit Zitat antworten
Alt 01.05.12, 11:54   #10
spychodelics
Premium Mitglied
 
Registriert seit: Nov 2002
Ort: Offenbach
Beiträge: 418
spychodelics eine Nachricht über ICQ schicken
Nur kurz von meiner Seite aus, ich installiere unter archlinux

pulseaudio
libpulse
paprefs
pavucontrol
pulseaudio-alsa

Starte paprefs und pavucontrol und mache meine Einstellungen fertig, meine Audigy2ZS
läuft. Noch meine Anwendungen smplayer / vlc / mpd auf pulse umgestellt und basta.

Einziges was ich noch geaendert habe weil ich lfe haben wollte 2 einstellungen in der Konfig gemacht.

Bombensound kann ich nur sagen.


Hier fand ich alle für mich nötigen Informationen


https://wiki.archlinux.org/index.php/Pulseaudio
http://www.freedesktop.org/wiki/Soft...r/PerfectSetup
http://wiki.ubuntuusers.de/PulseAudio
spychodelics ist offline   Mit Zitat antworten
Alt 16.05.12, 23:32   #11
Rain_maker
Gast
 
Beiträge: n/a
Zitat:
Zitat von simpleminds Beitrag anzeigen
..... Gut für den mplayer.
Andere mediaplayer haben ihre eigenen equalizer.
MPlayer hat auch "seinen eigenen" Audio-Equalizer (siehe "man mplayer"), mit einer Zeile

Code:
af=equalizer=Wert1:Wert2:......Wert9:Wert10
in ~/.mplayer/config auch persistent zu bekommen.

Greetz,

RM
  Mit Zitat antworten
Antwort

Lesezeichen

Themen-Optionen
Ansicht Thema bewerten
Thema bewerten:

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Probleme mit Sound bei Creative Soundkarte Siegl Musik 9 26.09.07 19:50
DVD-Laufwerk wird nicht angezeigt tesbihat Linux Allgemein 23 19.08.07 01:28
Audigy 2 gibt keinen Ton von sich Aruhn Musik 9 10.04.06 16:47
Suse 9.2 fährt nicht mehr runter ignisfatuus System installieren und konfigurieren 9 08.08.05 09:22
SuSE 9.1 - Konfiguration der Netzwerkkarte beim nächsten Boot nicht mehr gültig user9999 Router und Netzaufbau 17 14.07.04 11:25


Alle Zeitangaben in WEZ +1. Es ist jetzt 05:19 Uhr.


Powered by vBulletin® Version 3.8.6 (Deutsch)
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
linuxforen.de -- sponsored by Kemm IT