linuxforen.de -- User helfen Usern

Zurück   linuxforen.de -- User helfen Usern > Hardware > Mobiles Linux, Notebook, PDA
Registrieren Hilfe Benutzerliste Kalender Alle Foren als gelesen markieren

Mobiles Linux, Notebook, PDA PCMCIA, WIFI, ACPI/APM, Suspend, Hibernation, Infrarot, usw.

Antwort
 
Themen-Optionen Thema bewerten Ansicht
Alt 01.03.12, 09:36   #1
pibi
nobody.nogroup
 
Benutzerbild von pibi
 
Registriert seit: Jul 2002
Ort: Winterthur (CH)
Beiträge: 2.020
Dell Vostro 3750 - HDMI?

Hallo zusammen

Ich habe mir ein neues Notebook gegoennt (Bezeichnung siehe Titel mit Core i7, 8GB RAM) und mit openSuSI 12.1 64-bit bestueckt. Die wichtigen Sachen funktionieren alle.

Nun moechte ich an die vorhandene HDMI-Buchse einen externen TV anschliessen, ebenfalls HDMI. Aber ich bekomme kein Bild auf den TV. Irgendwie scheint aber doch eine Verbindung zu bestehen, denn wenn ich am Laptop das Kabel rausziehe, wird der TV einheitlich blau ("bluescreen"). Wenn ich den Laptop wieder verbinde, wird der Monitor schwarz.

Frage 1:
Im Internet habe ich eine Mail gefunden, die Dell darum bittet, den HDMI-Anschluss auch OUTPUT-faehig zu machen. Anscheinend ist er nur fuer INPUT gedacht (als ext. Signalquelle). Dies betrifft allerdings ein anderes (aelteres) Modell. Hat das jemand hier schon geschafft?

Frage 2:
Der Vostro hat eine Hybrid-Grafikkarte.
Code:
lappit:~ # lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: nVidia Corporation Device 0df5 (rev a1)
lappit:~ #
Weiss jemand, welche der beiden den HDMI-Output bedient, sofern er als Output brauchbar ist.

Geladene Module sind sowohl i915 als auch nouveau.
Code:
lappit:~ # lsmod | grep nou
nouveau               778193  0 
ttm                    80953  1 nouveau
mxm_wmi                12979  1 nouveau
drm_kms_helper         42489  2 nouveau,i915
drm                   252927  4 nouveau,ttm,i915,drm_kms_helper
i2c_algo_bit           13423  2 nouveau,i915
video                  19653  2 nouveau,i915
button                 13949  2 nouveau,i915
Einen NVidia-Treiber habe ich zwar installieren koennen, aber funktioniert hat er nie.

Gruss Pit.

PS: Ueber den VGA-Ausgang bekomme ich das Bild auf den TV.
pibi ist offline   Mit Zitat antworten
Alt 01.03.12, 11:28   #2
Luzi P
Registrierter Benutzer
 
Registriert seit: Oct 2003
Ort: Leipzig
Beiträge: 434
Hallo,

die Grafik von nvidia ist vermutlich ein Optimus-Chip.
Der wird von nvidia offiziell nicht unter Linux unterstützt, aber vielleicht hilft Dir das weiter: http://www.martin-juhl.dk/2011/05/op...roblem-solved/

Der Chip ist, glaub ich, auch für den HDMI-Ausgang zuständig.
Luzi P ist offline   Mit Zitat antworten
Alt 01.03.12, 13:13   #3
pibi
nobody.nogroup
 
Benutzerbild von pibi
 
Registriert seit: Jul 2002
Ort: Winterthur (CH)
Beiträge: 2.020
Zitat:
Zitat von pibi Beitrag anzeigen
Einen NVidia-Treiber habe ich zwar installieren koennen, aber funktioniert hat er nie.
Ich habe es gerade mit NVIDIA-Linux-x86_64-295.20.run nochmal probiert: Die Fehlermeldung bei "startx" lautet "no screens found." Ansonsten waehrend der Installation alles ohne jegliche Fehlermeldung.

@Luzi P:
Das Stichwort "Optimus" habe ich auch schon gehoert. Angeblich ist eine Unterstuetzung fuer Linux vorerst nicht geplant.

Gruss Pit.
pibi ist offline   Mit Zitat antworten
Alt 01.03.12, 13:18   #4
Luzi P
Registrierter Benutzer
 
Registriert seit: Oct 2003
Ort: Leipzig
Beiträge: 434
Na es anscheinend das Bumblebee-Projekt, womit es auf dem Vostro 3300 schon funktionieren soll. Damit geht wohl auch HDMI.

Ich hab aber auf meinem 3300 für die Laufzeit die nvidia ohnehin abgeschaltet, nachdem sie nicht auf Anhieb funktioniert hat.
Luzi P ist offline   Mit Zitat antworten
Alt 01.03.12, 18:00   #5
pibi
nobody.nogroup
 
Benutzerbild von pibi
 
Registriert seit: Jul 2002
Ort: Winterthur (CH)
Beiträge: 2.020
Zitat:
Zitat von Luzi P Beitrag anzeigen
Ich hab aber auf meinem 3300 für die Laufzeit die nvidia ohnehin abgeschaltet, nachdem sie nicht auf Anhieb funktioniert hat.
Mit Hilfe dieser Scripts hier oder aehnlich?

Gruss Pit.
pibi ist offline   Mit Zitat antworten
Alt 01.03.12, 18:55   #6
Luzi P
Registrierter Benutzer
 
Registriert seit: Oct 2003
Ort: Leipzig
Beiträge: 434
Genau.

Bei mir klappts mit _SB.PCI0.P0P1.PEGP._OFF.

Bei Bedarf kann ich Dir noch mein init-Skript schicken.
Luzi P ist offline   Mit Zitat antworten
Alt 01.03.12, 19:16   #7
pibi
nobody.nogroup
 
Benutzerbild von pibi
 
Registriert seit: Jul 2002
Ort: Winterthur (CH)
Beiträge: 2.020
Mein Problem ist einfach, dass ich nicht weiss, welcher der zwei VGA-Adapter momentan aktiv ist.

Aber zurueck zum Thema: Wie bekomme ich das Bild auf den externen TV via HDMI-Kabel?

Gruss Pit.
pibi ist offline   Mit Zitat antworten
Antwort

Lesezeichen

Themen-Optionen
Ansicht Thema bewerten
Thema bewerten:

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
HDMI Soundausgabe Nvidia 560 ti flammenflitzer stationäre Hardware 1 29.11.11 18:26
Meine Boot-hänger sind garkeine :-( smartysmart34 System installieren und konfigurieren 20 03.09.07 11:18
Dell Color Printer 725 CUPS 217Kutscher stationäre Hardware 7 06.09.06 12:23
Dell Service/Garantie ghostface1500 Mobiles Linux, Notebook, PDA 2 02.04.05 11:50
Dell PowerEdge 4300/500 mit Dell PERC 2/SC SCSI-RAID - Probleme ActionNews stationäre Hardware 4 16.03.05 15:17


Alle Zeitangaben in WEZ +1. Es ist jetzt 04:59 Uhr.


Powered by vBulletin® Version 3.8.6 (Deutsch)
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
linuxforen.de -- sponsored by Kemm IT