Anzeige:
Ergebnis 1 bis 8 von 8

Thema: postgres 7.3, psql nimmt keine kommandos an

  1. #1
    metal.fan
    Registriert seit
    Dec 2001
    Ort
    bohlsen
    Beiträge
    653

    postgres 7.3, psql nimmt keine kommandos an

    hi
    wenn ich als database superuser mit einer datenbank verbunden bin kann ich keine neuen user/datenbanken erstellen geschweige denn zugriffsrechte ändern
    die programme unter /usr/local/pgsql/bin/ funktionieren, psql zeigt mit dem \l schalter dann auch die neu erstellten datenbanken an, aber die gehören dann alle postgres

    hat jemand eine idee ?

  2. #2
    Java Fanboy Avatar von comrad
    Registriert seit
    Mar 2001
    Ort
    Delmenhorst
    Beiträge
    4.030
    hi


    die benutzerverwaltung der realen files im system und die benutzerverwaltung der daten IN der datenbank sind zwei sachen. die dateien können ruhig postgres gehören, solange die datenbank einem intern-postgresql-benutzer zugeordnet ist.

    comrad

  3. #3
    metal.fan
    Registriert seit
    Dec 2001
    Ort
    bohlsen
    Beiträge
    653
    aber wie einem intern-postgresql-benutzer rechte zuordnen wenn psql keine befehle annimt ?
    GRANT zeigt genausoviel einsatzfeude wie CREATE

  4. #4
    Java Fanboy Avatar von comrad
    Registriert seit
    Mar 2001
    Ort
    Delmenhorst
    Beiträge
    4.030
    ja, aber WAS passiert genau? geb mal fehlermeldungen, outputs usw. deine beschreibungen helfen leider nicht :-(

  5. #5
    Registrierter Benutzer
    Registriert seit
    Jul 2002
    Beiträge
    234

    Question DB Kommandos

    Hi,

    Eigentlich hast Du die Lösung doch schon in der Problemstellung
    selbst gegeben,
    Wenn die erstellten Datenbanken alle dem User Postgres gehören,
    must du wohl Grant usw. als Postgres ausführen oder ?

    mfg Dirk

  6. #6
    metal.fan
    Registriert seit
    Dec 2001
    Ort
    bohlsen
    Beiträge
    653
    1.
    postgres@deathb.lanstrike.de:/usr/local/pgsql/bin$ /usr/local/pgsql/bin/postmaster -D /usr/local/pgsql/data
    LOG: database system shutdown was interrupted at 2003-03-30 23:35:25 CEST
    LOG: checkpoint record is at 0/83D1AC
    LOG: redo record is at 0/83D1AC; undo record is at 0/0; shutdown FALSE
    LOG: next transaction id: 747; next oid: 25169
    LOG: database system was not properly shut down; automatic recovery in progress
    LOG: ReadRecord: record with zero length at 0/83D1EC
    LOG: redo is not required
    LOG: database system is ready

    2.

    /usr/local/pgsql/bin/psql users_db
    Welcome to psql 7.3, the PostgreSQL interactive terminal.

    Type: \copyright for distribution terms
    \h for help with SQL commands
    \? for help on internal slash commands
    \g or terminate with semicolon to execute query
    \q to quit

    users_db=#

    an diesem prompt habe ich zb folgendes probiert :

    users_db=# CREATE USER test
    users_db-#

    sollte eigentlich ein neuer user erstellt worden sein, aber in der userliste "\du" taucht kein neuer user auf
    der server prozess gibt auch keine errors aus
    seltsamerweise funktioniert es kommandos nicht interaktiv auszuführen, also mit dem -c schalter von pgsl.... ein script von iserved konnte so einen user alegen...

  7. #7
    Registrierter Benutzer
    Registriert seit
    Sep 2003
    Ort
    Leipzig
    Beiträge
    226
    Genau das selbe Problem habe ich auch.
    Habe ein SUSE 8.2 System mit PostgreSQL als Datenbank aufgesetzt.

    Datenbank anlegen kein Problem. Aber User für die Datenbank anlegen schon.
    Keine Fehlermeldung kein gar nichts.

    Hmm..

  8. #8
    Registrierter Benutzer
    Registriert seit
    Oct 2003
    Beiträge
    39
    Original geschrieben von ThoKre
    Genau das selbe Problem habe ich auch.
    Habe ein SUSE 8.2 System mit PostgreSQL als Datenbank aufgesetzt.

    Datenbank anlegen kein Problem. Aber User für die Datenbank anlegen schon.
    Keine Fehlermeldung kein gar nichts.

    Hmm..
    Das ist eigenartig, denn bei mir klappt es problemlos unter SuSE 8.2. Allerdings wäre ich mit usernamen wie "test" grundsätzlich vorsichtig. Lieber was anderes wie "taseluser" verwenden.

    Was mich irritiert ist, dass keine Fehlermeldung erscheint. Ist irgend etwas in der log-datei zu finden?

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •