Anzeige:
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 15 von 22

Thema: Kernel Fehler beim starten

  1. #1
    Moderator Avatar von DaGrrr
    Registriert seit
    Jul 2002
    Ort
    Berlin
    Beiträge
    1.882

    Kernel Fehler beim starten

    Hallo,

    ich habe mir bei kernel.org die stable 2.4.20 runtergeladen und kompiliert.

    Es kommt aber beim starten des Systems der folgende Fehler:

    Kernel panic:VFS: Unable to mount root fs on 03:43

    Ich habe das filesystem Ext3 und nutze Debian Woody.

    Die Suchfunktion habe ich genutzt und gelesen, das ich mein Filesystem "fest" einkompilieren muß, was ich im Vorfeld auch getan habe.

    Bei der Auswahl Filesystem habe ich drinstehen:

    Quota Support fest
    Kernel automounter support fest
    Kernel automounter version 4 support (also supports v3) fest
    Ext3 journaling file system support fest
    JSD (ext3) debugging support fest
    DOS FAT fs support Modul
    MSSOS fs support Modul
    VFAT (Windows-95) fs support Modul
    Virtual memory file system support fest
    ISO 9660 CDROM fest
    Microsoft Joliet CDROM extensions fest
    Transparent decompression extensions fest
    Minix fs Modul
    FreeVxFS file system Modul
    NTFS Modul
    /proc file system support fest
    /dev/pts file system for Unix98 PTYs fest
    ROM file system support Modul

    fest bedeutet: fest einkompiliert
    Modul: wird als Modul geladen wenn benötigt.

    Was kann da nicht stimmen ?

    Gruß
    DaGrrr

  2. #2
    Registrierter Benutzer Avatar von Jorge
    Registriert seit
    Aug 2001
    Ort
    Erbach bei Ulm
    Beiträge
    3.330
    Nach der Kernelinstallation /sbin/lilo ausgeführt?

  3. #3
    Registrierter Benutzer Avatar von dauni
    Registriert seit
    Jan 2001
    Ort
    Meran
    Beiträge
    2.260
    Ich würd mal sagen, dir fehlt ext2 Support, da ext3 ja eigentlich nur ext2 mit journal ist ...
    Vielleicht auch eine bootpartition als ext2 formatiert?
    Automounter wirst wohl nicht beide brauchen, wenn der neue quasi den alten ersetzen kann ....

  4. #4
    Moderator Avatar von DaGrrr
    Registriert seit
    Jul 2002
    Ort
    Berlin
    Beiträge
    1.882
    Ja, habe ich gemacht.

    Nach konfiguration und speichern der einstellungen
    habe ich folgenden Befehl ausgeführt:

    fakeroot make-kpkg kernel_image --revision=Konfigurationsname.Version

    Nach fertigem kompilieren habe ich gemacht:

    dpkg -i kernel-image-2.4.20_Konfigname.01_i386.deb

    Dabei wird gefragt, ob ich lili ändern möchte was ich bejaht habe.

    Ich weiß, das es noch anders geht aber für Debian ist dieser Konfigurations- bzw. Installationsweg am komfortabelsten.

    @dauni
    / ist ext3
    swap ist ja swap
    Ist die Swap Partition nicht ext3, wenn nicht, was sollte ich noch auswählen ?
    Eine Bootpartion habe ich bei der Installation von Debian nicht eingerichtet. Ich denke, die wird auch nicht benötigt.
    Allerdings ist noch eine verwaiste Boottpart. von SuSe über geblieben.


    Grüße
    DaGrrr
    Geändert von DaGrrr (27.12.02 um 18:21 Uhr)

  5. #5
    Premium Mitglied Avatar von RapidMax
    Registriert seit
    Aug 2001
    Beiträge
    1.740
    Original geschrieben von DaGrrr
    / ist ext3
    swap ist ja swap
    Ist die Swap Partition nicht ext3, wenn nicht, was sollte ich noch auswählen ?
    Eine Bootpartion habe ich bei der Installation von Debian nicht eingerichtet. Ich denke, die wird auch nicht benötigt.
    Allerdings ist noch eine verwaiste Boottpart. von SuSe über geblieben.
    Wen Debian schon so konfortable Werkzeuge zur Kernel-Kompilierung anbietet, würde ich die auch nutzen.

    Ich hatte bisher nie Probleme mit einer ext2 /boot -Partition (Journal ist bei 20MB wirklich nicht nötig) und der root-Partition mit ext3 bzw. raiserfs.

    Die Swap-Partition ist nicht ext3, sondern hat ein eigenes Filesystem.

    Gruss, Andy
    echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc
    >>> Programmierst Du noch oder patentierst Du schon... ? <<<

  6. #6
    Registrierter Benutzer Avatar von dauni
    Registriert seit
    Jan 2001
    Ort
    Meran
    Beiträge
    2.260
    Scheinbar ist die ext3-Unterstützung komplett so wie sie ist, also müßte man ext2 auch gar nicht einbauen (würd aber sicher nicht schaden ...)

    Zum Automounter:
    If you want to use the newer version of the automounter with more
    features, say N here and say Y to "Kernel automounter v4 support",
    below.
    Swap muß er ja nicht mounten um booten zu können, also darfs daran nicht liegen und nein, es ist nicht ext3

    In der Lilo.conf vielleicht falsche rootpartition angegeben?

  7. #7
    Moderator Avatar von DaGrrr
    Registriert seit
    Jul 2002
    Ort
    Berlin
    Beiträge
    1.882
    Hm,

    Swap Filesystem kann ich nicht auswählen, da ich es nicht gefunden habe.
    Hat es einen anderen Namen ?

    f you want to use the newer version of the automounter with more
    features, say N here and say Y to "Kernel automounter v4 support",
    below.
    Vielleicht beissen sich die beiden.
    Ich probiere das gleich mal aus.

    Danke !

    In der Lilo.conf vielleicht falsche rootpartition angegeben?
    Nein, das stimmt.
    Sonst könnte ich jetzt nicht schreiben, da ich mich in Linux befinde.
    Bei der Installation des Kernel.deb Paketes wurde ein neuer Eintrag erstellt.

    Linux
    LinuxOLD

    LinuxOLD ist mein funktionsfähiges Debian, sozusagen eine Sicherungkopie meines alten Kernels.

    Grüße
    DaGrrr
    Geändert von DaGrrr (27.12.02 um 18:38 Uhr)

  8. #8
    Premium Mitglied Avatar von RapidMax
    Registriert seit
    Aug 2001
    Beiträge
    1.740
    Die Swap-Unterstützung sollte fest im Kernel sein, ich habe noch nie eine Option gefunden, das zu aktivieren/deaktivieren.

    Gruss, Andy
    echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc
    >>> Programmierst Du noch oder patentierst Du schon... ? <<<

  9. #9
    Moderator Avatar von DaGrrr
    Registriert seit
    Jul 2002
    Ort
    Berlin
    Beiträge
    1.882
    Würde es helfen meine config-2.4.20 zu posten ?
    Es sind allerdings 977 Zeilen

    Grüße
    DaGrrr

  10. #10
    Registrierter Benutzer Avatar von dauni
    Registriert seit
    Jan 2001
    Ort
    Meran
    Beiträge
    2.260
    häng die config einfach mal an, dann kann man ja schauen (hab hier den 2.4.20 grad bei der hand )

  11. #11
    Moderator Avatar von DaGrrr
    Registriert seit
    Jul 2002
    Ort
    Berlin
    Beiträge
    1.882
    Wie gewünscht angehängt.

    Grüße
    DaGrrr

  12. #12
    Registrierter Benutzer Avatar von dauni
    Registriert seit
    Jan 2001
    Ort
    Meran
    Beiträge
    2.260
    Hmm ,so auf den ersten Blick stört mich höchstens das Math-emulation und Multiprozessordings, aber daran kanns ja nicht liegen

  13. #13
    Premium Mitglied Avatar von RapidMax
    Registriert seit
    Aug 2001
    Beiträge
    1.740
    Ich habe die config mal mit mener 2.4.20er verglichen - nichts Erwähneswertes.
    Hmm, reiserfs braucht doch eine initrd, ext3 aber nicht. Oder etwa auch?

    Gruss, Andy
    echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc
    >>> Programmierst Du noch oder patentierst Du schon... ? <<<

  14. #14
    Registrierter Benutzer Avatar von dauni
    Registriert seit
    Jan 2001
    Ort
    Meran
    Beiträge
    2.260
    die ramdisk am anfang brauchts nur, wenn etwas grundlegendes als modul eingebunden wird - sonst würds bei mir auch nicht laufen

  15. #15
    Moderator Avatar von DaGrrr
    Registriert seit
    Jul 2002
    Ort
    Berlin
    Beiträge
    1.882
    Der Kernel läuft bei Dir ?
    Mit meiner config ?

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •