Anzeige:
Ergebnis 1 bis 12 von 12

Thema: mknod, insmod usw

  1. #1
    Registrierter Benutzer Avatar von pixel
    Registriert seit
    Dec 2000
    Ort
    Bühl
    Beiträge
    2.723

    mknod, insmod usw

    Hi@all,

    für unsere Software habe ich einen Netwerkdongel an unserem Linux-Server in betrieb genommen (HL-Server). Hat alles geklappt. Ich habe das mit der beiliegenden Readme gemacht. Im Rahmen dieser Installation habe ich verschieden Befehle ausgeführt von denen ich nicht genau weiss ob sie dauerhat sind oder nach dem nächsten Neustart weg sind. Ich werde den Installationsverlauf kurz Aufzeigen:

    The device node is generated with the following command:
    #mknod /dev/Hardlock c 42 0

    Damit wird doch das eigentliche Device angelegt, oder? d.h. dieses Device bleibt dauerhaft im System.

    Allow everyone to access the node:
    #chmod 666 /dev/Hardlock

    Damit werden die Zugriffsrechte auf das Device gesetzt.

    So before loading the aksparlnx driver the parport system must be
    initialized:
    #modprobe parport_pc

    Damit wird überprüft ob das Kernelmodul vorhanden ist oder läd dieser Befehl das Modul?

    Loading the Driver
    Then the aksparlnx driver should be loaded with the command:
    #insmod <path_to_driver>/aksparlnx.o

    dieser fügt das Kernelmodul ein, oder?


    In order for the daemon to access USB keys, the so-called usbdevfs
    must be mounted on /proc/bus/usb.
    On newer distributions it is mounted automatically (e.g SuSe 7.0). It
    can be manually mounted with the command
    mount -t usbdevfs none /proc/bus/usb

    Load the daemon by starting it:
    #<path>/aksusbd

    Ich glaube der läd den Treiber?

    Am Ende lade ich den eigentliche HL-Server mit:
    tux:/data2/hlserver/hlserver -m:29418 -d

    Welche der Befehle muss ich nun in meinem SuSE-8.0 in welche Dateien eintragen damit diese Kofiguration dauerhaft erhalten bleibt. Der letzte Punkt "hlserver" ist mir klar, da schreibe ich einfach ein Skript welches den Befehl incl. diesen Parametern aufruft und das Skript starte ich im Runlevel.

    Beim Rest wäre ich für Tip's dankbar.

    Gruss Pixel
    Das maximale Maß an Flach- und Schwachsinn, das eine »kommunizierende« Menschengruppe zu produzieren in der Lage ist, wird seit Internetzeiten nicht mehr an Stammtischen erreicht, deren Besatzung die 10. Runde intus hat.

  2. #2
    Registrierter Benutzer
    Registriert seit
    Nov 2001
    Beiträge
    469

    Re: mknod, insmod usw

    Hi,

    ich hab weils einfacher ist in das Quote reingeschrieben:
    Original geschrieben von pixel
    Ich werde den Installationsverlauf kurz Aufzeigen:

    The device node is generated with the following command:
    #mknod /dev/Hardlock c 42 0

    Damit wird doch das eigentliche Device angelegt, oder? d.h. dieses Device bleibt dauerhaft im System.

    Ja

    Allow everyone to access the node:
    #chmod 666 /dev/Hardlock

    Damit werden die Zugriffsrechte auf das Device gesetzt.

    Ja

    So before loading the aksparlnx driver the parport system must be
    initialized:
    #modprobe parport_pc

    Damit wird überprüft ob das Kernelmodul vorhanden ist oder läd dieser Befehl das Modul?

    Er lädt das Parallelport Modul

    Loading the Driver
    Then the aksparlnx driver should be loaded with the command:
    #insmod <path_to_driver>/aksparlnx.o

    dieser fügt das Kernelmodul ein, oder?

    Ja das müßte theoretisch auch so gehen (/etc/modules.conf):

    alias char-major-42 aksparlnx
    pre-install aksparlnx parport_pc


    In order for the daemon to access USB keys, the so-called usbdevfs
    must be mounted on /proc/bus/usb.
    On newer distributions it is mounted automatically (e.g SuSe 7.0). It
    can be manually mounted with the command
    mount -t usbdevfs none /proc/bus/usb

    Das mußt Du in /etc/sysconfig/hotplug (HOTPLUG_START_USB=yes) und dem Runlevel-editor starten

    Load the daemon by starting it:
    #<path>/aksusbd

    Ich glaube der läd den Treiber?

    Nein, der Treiber ist aksparlnx.o. Das hier ist der deamon, der die Programmzugriffe auf den Dongle abfängt

    Am Ende lade ich den eigentliche HL-Server mit:
    tux:/data2/hlserver/hlserver -m:29418 -d

    Welche der Befehle muss ich nun in meinem SuSE-8.0 in welche Dateien eintragen damit diese Kofiguration dauerhaft erhalten bleibt. Der letzte Punkt "hlserver" ist mir klar, da schreibe ich einfach ein Skript welches den Befehl incl. diesen Parametern aufruft und das Skript starte ich im Runlevel.
    Exakt, in das Script kannst auch gleich den #<path>/aksusbd mit reinschreiben.
    *g* char-major-42 schönen Gruß von Douglas Adams?? *g*
    Falls das pre-install nicht klappt, kannst die beiden Module auch in die initrd reinpacken
    Geändert von Linrade (18.07.02 um 17:55 Uhr)

  3. #3
    Registrierter Benutzer Avatar von pixel
    Registriert seit
    Dec 2000
    Ort
    Bühl
    Beiträge
    2.723

    Exclamation er läd den Treiber nicht

    Hi@all,

    ich habe also in der /etc/modules.conf

    die beiden Zeilen:

    alias char-major-42 aksparlnx
    pre-install aksparlnx parport_pc

    hinzugefügt. Ist das egal an welcher Stelle ich diese in der Datei eintrage? Muss ich anschliessend noch einen Befehl ausführen?

    Anschliessend habe ich den Rechner neu gestartet, wie hätte ich die Änderung übernehmen können ohne den Rechner neu zu starten?

    Ich habe mir ein Skript geschrieben und ausführbar gemacht:

    #!/bin/sh
    /data2/hlserver/sbin/aksusbd
    /data2/hlserver/hlserver -m:29418 -d

    wenn ich jedoch das Skript ausführe erhalte ich jedoch die Meldung:

    hlserver - Hardlock-Server for Linux, v4.46
    Aladdin Knowledge Systems, Wonderbyte Production Team
    Copyright (c) 2002 Aladdin Knowledge Systems, all rights reserved.

    hlserver error: hardlock driver is not running.
    hlserver error: aksusbd is not running.

    Also hat er den Treiber nicht geladen das Problem muss also an meiner Eintragung in der modules.conf liegen.

    Ach ja, in der sysconfig stand HOTPLUG_START_USB bereits auf 'yes'

    Was ich mir auch noch vorstellen kann ist das es daran liegen könnte dass dass System das Kernelmodul nicht finden. Ich habe es nähmlich in:

    tux:/data2/hlserver/drv/aksparlnx.o

    liegen. Kann ich System irgendwie mitteilen das es hier liegt oder soll ich es besser in ein andres Verzeichniss kopieren?


    Gruss Pixel
    Geändert von pixel (18.07.02 um 21:02 Uhr)
    Das maximale Maß an Flach- und Schwachsinn, das eine »kommunizierende« Menschengruppe zu produzieren in der Lage ist, wird seit Internetzeiten nicht mehr an Stammtischen erreicht, deren Besatzung die 10. Runde intus hat.

  4. #4
    Registrierter Benutzer
    Registriert seit
    Nov 2001
    Beiträge
    469

    Re: er läd den Treiber nicht

    Hi pixel,
    Original geschrieben von pixel
    alias char-major-42 aksparlnx
    pre-install aksparlnx parport_pc

    hinzugefügt. Ist das egal an welcher Stelle ich diese in der Datei eintrage? Muss ich anschliessend noch einen Befehl ausführen?

    Anschliessend habe ich den Rechner neu gestartet, wie hätte ich die Änderung übernehmen können ohne den Rechner neu zu starten?
    Sch.. hatte ich vergessen vorhin. "depmod -a" Mehr braucht es nicht. Neustart muß nicht sein. Es ist auch egal wo Du es einträgst. Ich schreibe sowas immer am Ende der Datei rein, damit ich's leichter wiederfinde. Wenn es aber so nicht geladen wird, kannst Du auch Dein Skript ändern:

    Code:
    #!/bin/sh
    test "lsmod | grep parport_pc" && modprobe parport_pc
    test "lsmod | grep aksparlnx"  && insmod /data2/hlserver/drv/aksparlnx.o
    /data2/hlserver/sbin/aksusbd
    /data2/hlserver/hlserver -m:29418 -d
    In diesem Fall sollte es Root gehören, da sonst insmod/modprobe scheitern. Falls User das Skript starten, mußt du es halt SUID (chmod 4755 ) machen.
    insmod ist es egal wo das Modul liegt, solange Du den kompletten Pfad mit angibst.

  5. #5
    Registrierter Benutzer Avatar von pixel
    Registriert seit
    Dec 2000
    Ort
    Bühl
    Beiträge
    2.723

    trotz depmod -a wird der Treiber nicht geladen

    Hi@all,

    trot dem Eintrag in der modules.conf und depmod -a immer noch der gleiche Fehler:


    hlserver - Hardlock-Server for Linux, v4.46
    Aladdin Knowledge Systems, Wonderbyte Production Team
    Copyright (c) 2002 Aladdin Knowledge Systems, all rights reserved.

    hlserver error: hardlock driver is not running.
    hlserver error: aksusbd is not running.

    Jemand eine Idee?

    Gruss Pixel
    Das maximale Maß an Flach- und Schwachsinn, das eine »kommunizierende« Menschengruppe zu produzieren in der Lage ist, wird seit Internetzeiten nicht mehr an Stammtischen erreicht, deren Besatzung die 10. Runde intus hat.

  6. #6
    Registrierter Benutzer Avatar von pixel
    Registriert seit
    Dec 2000
    Ort
    Bühl
    Beiträge
    2.723

    was bedeuten.....

    Hi@all,

    ...die beiden Eintragungen in der modules.conf?

    alias char-major-42 aksparlnx
    pre-install aksparlnx parport_pc

    die alias-anweisung macht doch das Modul sozusagen bekannt damit es unter dem Namen angesprochen werden kann, oder?

    Die zweite Option verstehe ich gar nicht, was macht pre-install und können dahinter mehrere Module angegeben werden?


    Gruss Pixel
    Das maximale Maß an Flach- und Schwachsinn, das eine »kommunizierende« Menschengruppe zu produzieren in der Lage ist, wird seit Internetzeiten nicht mehr an Stammtischen erreicht, deren Besatzung die 10. Runde intus hat.

  7. #7
    Registrierter Benutzer Avatar von pixel
    Registriert seit
    Dec 2000
    Ort
    Bühl
    Beiträge
    2.723

    Unhappy weiss keiner?

    Hi@all,

    weiss das wirklich keiner??

    Gruss Pixel
    Das maximale Maß an Flach- und Schwachsinn, das eine »kommunizierende« Menschengruppe zu produzieren in der Lage ist, wird seit Internetzeiten nicht mehr an Stammtischen erreicht, deren Besatzung die 10. Runde intus hat.

  8. #8
    Registrierter Benutzer
    Registriert seit
    Aug 2001
    Beiträge
    1.845
    pre-install aksparlnx parport_pc

    Vor dem laden des aksparlnx-Moduls parport_pc-Modul laden? ;o)
    Wirf doch gelegentlich mal nen Blick in die manpage.
    Vor drei Minuten hörten wir Lärm und dachten, es wäre Luftalarm. Ich habe die Gasmaske, die ich immer bei mir trage, gegriffen. Aber dann sagte man mir, das sei die Musik von der Moschee.
    Julie Chen, Reporterin von CBS in Kuwait

  9. #9
    Registrierter Benutzer Avatar von pixel
    Registriert seit
    Dec 2000
    Ort
    Bühl
    Beiträge
    2.723

    Question welche??

    Hi,

    wie rufe ich die dazugehörende Manpage auf? Ich habe man pre-install sowie man modules versucht. Wie rufe ich sie auf?

    Gruss Pixel
    Das maximale Maß an Flach- und Schwachsinn, das eine »kommunizierende« Menschengruppe zu produzieren in der Lage ist, wird seit Internetzeiten nicht mehr an Stammtischen erreicht, deren Besatzung die 10. Runde intus hat.

  10. #10
    Registrierter Benutzer
    Registriert seit
    Aug 2001
    Beiträge
    1.845
    Mit "man man" ;o)










    Wenn Du nicht weisst, wonach Du suchst, oder nur ein Stichwort hast:
    apropos stichwort
    man -k stichwort

    ---
    ach so:
    stichwort wäre hier vielleicht "insmod" "modules.conf" oder sowas in der Art. Falls für "modules" wirklich keine manpage bereit gehalten wird.
    Geändert von melody lee (22.07.02 um 21:45 Uhr)
    Vor drei Minuten hörten wir Lärm und dachten, es wäre Luftalarm. Ich habe die Gasmaske, die ich immer bei mir trage, gegriffen. Aber dann sagte man mir, das sei die Musik von der Moschee.
    Julie Chen, Reporterin von CBS in Kuwait

  11. #11
    Registrierter Benutzer
    Registriert seit
    Nov 2001
    Beiträge
    469

    Re: welche??

    Original geschrieben von pixel
    Hi,

    wie rufe ich die dazugehörende Manpage auf? Ich habe man pre-install sowie man modules versucht. Wie rufe ich sie auf?

    Gruss Pixel
    Hi,
    fast richtig

    man 5 modules.conf

    und Arrgh, es muß heißen:

    alias char-major-42 aksparlnx
    pre-install aksparlnx modprobe parport_pc

    Sch****e, Manpage lesen bildet eben doch

  12. #12
    Registrierter Benutzer Avatar von pixel
    Registriert seit
    Dec 2000
    Ort
    Bühl
    Beiträge
    2.723

    Wink jetzt geht's

    Hi@all,

    es funktioniert *freu*. Was die beiden ersten Zeilen in meinem Skript "test...." machen weiss ich zwar (noch!) nicht aber das bekomme ich schon raus (werd's versuchen). Nun tut sich mir aber auch schon die nächste Frage auf In dem RunLevel nun einen Link auf das Skript anzulegen ist mir klar Sxxhls_start und das Modul wird beim Systemstart im entsprechenden RL gestartet. Und wie entlade ich das Modul beim herunterfahren wieder? Muss ich das? Ich dachte da es in den RL's ja immer noch (oft) die Kxyirgendwas - Link's gibt.

    Kurz Info make me happy.

    Gruss Pixel
    Das maximale Maß an Flach- und Schwachsinn, das eine »kommunizierende« Menschengruppe zu produzieren in der Lage ist, wird seit Internetzeiten nicht mehr an Stammtischen erreicht, deren Besatzung die 10. Runde intus hat.

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •