Anzeige:
Ergebnis 1 bis 8 von 8

Thema: Gelöst: Grafik- Problem nach Einspielen der neuesten Updates für OpenSuse 42.3

  1. #1
    Newbie and practicing Avatar von Newbie314
    Registriert seit
    Mar 2007
    Beiträge
    7.632

    Gelöst: Grafik- Problem nach Einspielen der neuesten Updates für OpenSuse 42.3

    Bei diesem Problem weiß ich wirklich nicht von welcher Seite aus ich es am besten angege, bin weitgehend ratlos:

    - Rechner: Dell Latitude E6410, der Rechner meiner Eltern
    - Phänomene: seit Einspielen der neuesten Updates inklusive Kernel Update und Neustart
    • ist oft die Schrift auf "Rechtsklick Menüs" nicht lesbar sondern zeigt nur Striche
    • Libreoffice zeigt beim Öffnen von Dokumenten schwarze Hintergründe, nur Stellen die man bearbeitet oder "überscrollt" wandeln sich dann zum gewohnten weißen Bild
    • In manchen Situationen (z.B. neues Tab in Firefox öffnen) friert der Rechner für mehrere Sekunden ein
    • Wenn man ein Programm von der verkleinerten Darstellung "auf groß" klickt kann es sein dass das ganze Fenster erstmal nur schwarz gezeigt wird. Nochmal klein und wieder groß klicken behebt dieses Problem meistens

    Meine Eltern sind keine Rechner-Fans und werden bei kleinen Fehlfunktionen sehr schnell verunsichert, d.h. "workarounds" bis OpenSuse den Bug selbst behoben hat sind keine gute Lösung.

    Hardware:
    Grafikkarte:
    Code:
    P: /devices/pci0000:00/0000:00:02.0
      E: DEVPATH=/devices/pci0000:00/0000:00:02.0
      E: DRIVER=i915
      E: ID_MODEL_FROM_DATABASE=Core Processor Integrated Graphics Controller (Latitude E6410)
      E: ID_PCI_CLASS_FROM_DATABASE=Display controller
      E: ID_PCI_INTERFACE_FROM_DATABASE=VGA controller
      E: ID_PCI_SUBCLASS_FROM_DATABASE=VGA compatible controller
      E: ID_VENDOR_FROM_DATABASE=Intel Corporation
      E: MODALIAS=pci:v00008086d00000046sv00001028sd0000040Abc03sc00i00
      E: PCI_CLASS=30000
      E: PCI_ID=8086:0046
      E: PCI_SLOT_NAME=0000:00:02.0
      E: PCI_SUBSYS_ID=1028:040A
      E: SUBSYSTEM=pci
      E: USEC_INITIALIZED=13289212
    und
    Code:
    15: PCI 02.0: 0300 VGA compatible controller (VGA)
      [Created at pci.378]
      Unique ID: _Znp.xgNKnslBcbD
      SysFS ID: /devices/pci0000:00/0000:00:02.0
      SysFS BusID: 0000:00:02.0
      Hardware Class: graphics card
      Model: "Dell Latitude E6410"
      Vendor: pci 0x8086 "Intel Corporation"
      Device: pci 0x0046 "Core Processor Integrated Graphics Controller"
      SubVendor: pci 0x1028 "Dell"
      SubDevice: pci 0x040a "Latitude E6410"
      Revision: 0x02
      Driver: "i915"
      Driver Modules: "i915"
      Memory Range: 0xf0000000-0xf03fffff (rw,non-prefetchable)
      Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
      I/O Ports: 0x7100-0x7107 (rw)
      IRQ: 25 (6796 events)
      I/O Ports: 0x3c0-0x3df (rw)
      Module Alias: "pci:v00008086d00000046sv00001028sd0000040Abc03sc00i00"
      Driver Info #0:
        Driver Status: i915 is active
        Driver Activation Cmd: "modprobe i915"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
    Da man mit Zypper keine einfache Differenzliste der Pakete erstellen kann habe ich mit dem snapper "status" Befehl eine Differenzdatei erstellt, die ist aber riesig wenn man nicht weiß wonach man sucht nützt sie wohl gar nichts. Ich schaue gerade ob ich irgendwas zu Grafikkarten drin finde.

    Es wurden neue I915 Treiber eingespielt:
    Code:
    +..... /lib/modules/4.4.104-39-default/weak-updates/updates/drivers/gpu/drm/i915
    +..... /lib/modules/4.4.104-39-default/weak-updates/updates/drivers/gpu/drm/i915/i915.ko
    und
    Code:
    +..... /lib/modules/4.4.104-39-default/kernel/drivers/gpu/drm/i915
    +..... /lib/modules/4.4.104-39-default/kernel/drivers/gpu/drm/i915/i915.ko
    Tipps und Ideen sind willkommen, per Snapper alles zurückzusetzen finde ich suboptimal. Soweit ich sehe müsste ich den Kernel Update rückgängig machen um das Problem zu beheben?
    Geändert von Newbie314 (22.01.18 um 13:05 Uhr)
    Bei Konsolenausgaben / Fehlermeldungen bitte immer Code Tags verwenden: [code] -Text- [/code]
    "Überzeugungen sind gefährlichere Feinde der Wahrheit als Lügen" (H. Lesch)

  2. #2
    Besen-Wesen Avatar von Ginsengelf
    Registriert seit
    Feb 2003
    Ort
    Mars
    Beiträge
    549
    Moin, der alte Kernel ist doch wahrscheinlich noch auf dem System, oder? Zumindest ist das bei meinem Tumbleweed so. Per Grub evtl. über die erweiterten Optionen erreichbar. Boote doch mal den, und wenn das hilft, müsstest du einfach per zypper den fehlerhaften Kernel deinstallieren können.

    Ginsengelf
    God's in his heaven. All's right with the world.
    System: Phenom II X6 auf Asus M5A97 Pro, Radeon HD 7870, 8 GB DDR3-RAM, openSUSE Tumbleweed

  3. #3
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Ort
    Sauerland
    Beiträge
    1.008

  4. #4
    Newbie and practicing Avatar von Newbie314
    Registriert seit
    Mar 2007
    Beiträge
    7.632
    Danke, ja es handelt sich um einen älteren Chipsatz. Beim experimentellen rollback mit snapper funktionierte alles wieder aber angesichts der neuesten Sicherheitslücken bevorzuge ich auf Dauer einen aktuellen Kernel, d.h. ich werde die Tipps auf Sauerlands Links mal ausprobieren.
    Bei Konsolenausgaben / Fehlermeldungen bitte immer Code Tags verwenden: [code] -Text- [/code]
    "Überzeugungen sind gefährlichere Feinde der Wahrheit als Lügen" (H. Lesch)

  5. #5
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Ort
    Sauerland
    Beiträge
    1.008
    Vorher würde ich noch mal versuchen, ob es hilft, nur drm-kmp-default zu deinstallieren, das kann mit älteren Rechnern Probleme bereiten.

    Das muss man auch deinstallieren (bzw. wird selbständig deinstalliert beim Treiber aus dem Repo), wenn man den Nvidia Treiber installieren möchte.

  6. #6
    Newbie and practicing Avatar von Newbie314
    Registriert seit
    Mar 2007
    Beiträge
    7.632
    Ok. Ich schreibe dann hier wie es lief (bin grad im Krankenhaus, komme daher vorerst nicht zum Ausprobieren).
    Bei Konsolenausgaben / Fehlermeldungen bitte immer Code Tags verwenden: [code] -Text- [/code]
    "Überzeugungen sind gefährlichere Feinde der Wahrheit als Lügen" (H. Lesch)

  7. #7
    Newbie and practicing Avatar von Newbie314
    Registriert seit
    Mar 2007
    Beiträge
    7.632
    Danke, Deinstallation von drm-kmp-default hat das Problem gelöst. Woher wusstest du das?
    Bei Konsolenausgaben / Fehlermeldungen bitte immer Code Tags verwenden: [code] -Text- [/code]
    "Überzeugungen sind gefährlichere Feinde der Wahrheit als Lügen" (H. Lesch)

  8. #8
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Ort
    Sauerland
    Beiträge
    1.008
    Weil es schon mehrmals in Foren erwähnt wurde. Kann helfen, kann aber auch zu schwarzem Bildschirm führen.

Ähnliche Themen

  1. Wichtig: Glibc Updates einspielen!
    Von Newbie314 im Forum Sicherheit
    Antworten: 12
    Letzter Beitrag: 20.02.16, 17:34
  2. Antworten: 16
    Letzter Beitrag: 07.10.13, 08:45
  3. WPA mit Prism54 Fullmac-Karten mit den neuesten git-Patches
    Von Psycho Dad1 im Forum Anbindung an die Aussenwelt
    Antworten: 10
    Letzter Beitrag: 22.12.06, 17:01
  4. SuSE 9.0 Updates einspielen
    Von kraekers im Forum System installieren und konfigurieren
    Antworten: 10
    Letzter Beitrag: 17.12.03, 08:56
  5. RedHat KDE 3 Updates einspielen
    Von obelix im Forum Windowmanager
    Antworten: 0
    Letzter Beitrag: 24.12.02, 14:37

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •