Anzeige:
Ergebnis 1 bis 10 von 10

Thema: openSuSe bootet nur mit Installationsdisc

  1. #1
    eigentlich keine Blondine
    Registriert seit
    Mar 2010
    Beiträge
    897

    openSuSe bootet nur mit Installationsdisc

    Hallo, ich bin gerade über Weihnachten bei meinen Eltern. Meine Mutter hat OpenSuSe Leap 42.3 und es läuft eigentlich alles super. Das System startet aber nur, wenn die Installations-DVD eingelegt ist und man dort dann "boot from Hard Disk" auswählt. Dann kommt die Bootauswahl von Grub, und das System auf der Festplatte startet. Ohne die DVD öffnet sich nach einer Weile das UEFI. Dort haben wir schon versucht, die Bootreihenfolge zu ändern, was aber nicht geholfen hat. Ich habe auch schon mit
    Code:
    # grub2-install /dev/sda
    den Bootloader neu installiert und das hat auch keine dauerhaften Änderungen gebracht. Jetzt weiß ich gar nicht, welche Angaben noch benötigt werden, um dem Problem auf die Spur zu kommen. Im Internet finde ich auch nichts Passendes.
    Von welchen Befehlen soll ich die Ausgabe hier anführen?
    Unter Linux eine .exe-Datei ausführen ist ganz einfach. Man nimmt eine beliebige unter Linux ausführbare Datei, benennt sie um in AusfuehrbareDatei.exe und führt sie aus.

  2. #2
    Premium Mitglied Avatar von spychodelics
    Registriert seit
    Nov 2002
    Ort
    Offenbach
    Beiträge
    587

  3. #3
    eigentlich keine Blondine
    Registriert seit
    Mar 2010
    Beiträge
    897
    Was soll das für Vorteile bringen gegenüber dem Starten mit Unterstützung der Installationsdisc?
    Unter Linux eine .exe-Datei ausführen ist ganz einfach. Man nimmt eine beliebige unter Linux ausführbare Datei, benennt sie um in AusfuehrbareDatei.exe und führt sie aus.

  4. #4
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Ort
    Sauerland
    Beiträge
    985
    Zitat Zitat von rstuby Beitrag anzeigen
    Was soll das für Vorteile bringen gegenüber dem Starten mit Unterstützung der Installationsdisc?
    Evtl. das du den Grub2 so reparieren kannst, um ihn so zu benutzen, wie du möchtest?

  5. #5
    eigentlich keine Blondine
    Registriert seit
    Mar 2010
    Beiträge
    897
    In der Info Helps you to fix your GRUB or GRUB2 steht aber nichts von einem speziellen Reparaturtool, sondern nur die normalen Befehle, die ich schon ausprobiert habe. Die Disc ist offenbar als Hilfe konzipiert, um ein System überhaupt erst booten zu können. Das kann ich aber auch so.
    Unter Linux eine .exe-Datei ausführen ist ganz einfach. Man nimmt eine beliebige unter Linux ausführbare Datei, benennt sie um in AusfuehrbareDatei.exe und führt sie aus.

  6. #6
    Premium Mitglied Avatar von spychodelics
    Registriert seit
    Nov 2002
    Ort
    Offenbach
    Beiträge
    587
    Bios Einstellungen stimmen? MBR i.O.? Bootflag gesetzt? Was passiert wenn du "Boot from Harddisk" auswaehlst?

  7. #7
    eigentlich keine Blondine
    Registriert seit
    Mar 2010
    Beiträge
    897
    Wie kann ich testen, ob der MBR in Ordnung ist, das Bootflag gesetzt ist und auf welche UEFI-Einstellungen muss ich achten?

    Wenn man "boot from Hard Disk" auswählt, kommt die Bootauswahl von Grub2, und das System auf der Festplatte startet ganz normal.

    Die Ausgabe von fdisk -l sieht etwas seltsam aus, zumal meines Wissens niemals etwas von Microsoft auf diesem Rechner war. Aber ich kenne mich zu wenig aus, um wirklich etwas damit anzufangen:
    Code:
    # fdisk -l
    Festplatte /dev/sda: 465,8 GiB, 500107862016 Bytes, 976773168 Sektoren
    Einheiten: Sektoren von 1 * 512 = 512 Bytes
    Sektorgröße (logisch/physikalisch): 512 Bytes / 4096 Bytes
    E/A-Größe (minimal/optimal): 4096 Bytes / 4096 Bytes
    Festplattenbezeichnungstyp: gpt
    Festplattenbezeichner: 0C144C14-6E19-427A-A1CB-FF290E63DDBC
    
    Gerät        Anfang      Ende  Sektoren  Größe Typ
    /dev/sda1      2048    321535    319488   156M BIOS boot
    /dev/sda2    321536   4530175   4208640     2G Microsoft Basisdaten
    /dev/sda3   4530176  88422399  83892224    40G EFI-System
    /dev/sda4  88422400 976773119 888350720 423,6G Microsoft Basisdaten
    
    
    Festplatte /dev/sdc: 14,5 GiB, 15518924800 Bytes, 30310400 Sektoren
    Einheiten: Sektoren von 1 * 512 = 512 Bytes
    Sektorgröße (logisch/physikalisch): 512 Bytes / 512 Bytes
    E/A-Größe (minimal/optimal): 512 Bytes / 512 Bytes
    Festplattenbezeichnungstyp: dos
    Festplattenbezeichner: 0x0813e1cd
    
    Gerät      Boot Anfang     Ende Sektoren Größe Kn Typ
    /dev/sdc1         3112 30310399 30307288 14,5G  b W95 FAT32
    Geändert von rstuby (21.12.17 um 14:09 Uhr)
    Unter Linux eine .exe-Datei ausführen ist ganz einfach. Man nimmt eine beliebige unter Linux ausführbare Datei, benennt sie um in AusfuehrbareDatei.exe und führt sie aus.

  8. #8
    Premium Mitglied Avatar von spychodelics
    Registriert seit
    Nov 2002
    Ort
    Offenbach
    Beiträge
    587
    Code:
    #fdisk -l 
    
    Festplatte /dev/sda: 238,5 GiB, 256060514304 Bytes, 500118192 Sektoren
    Einheiten: Sektoren von 1 * 512 = 512 Bytes
    Sektorgröße (logisch/physikalisch): 512 Bytes / 512 Bytes
    E/A-Größe (minimal/optimal): 512 Bytes / 512 Bytes
    Festplattenbezeichnungstyp: dos
    Festplattenbezeichner: 0xa8b8ef78
    
    Gerät      Boot    Anfang      Ende  Sektoren  Größe Kn Typ
    /dev/sda1  *         2048    206847    204800   100M  7 HPFS/NTFS/exFAT
    /dev/sda2          206848 204799999 204593152  97,6G  7 HPFS/NTFS/exFAT
    /dev/sda3       204800000 500117503 295317504 140,8G 83 Linux
    Ich hab ein Sternchen * in der Spalte Boot

    Du hast du eine EFI Partition, damit habe ich keine Erfahrung bisher gemacht. Ausserdem steht bei dir Festplattenbezeichnungstyp: gpt was bedeutet das du kein mbr mehr hast.

    Das muesste eigentlich anderweitig gefixed werden.

    https://forums.opensuse.org/showthre...nsole-form-DVD
    https://en.opensuse.org/openSUSE:UEFI

    Weiter aber ohne Gewähr weil ich das bis dato noch nicht gemacht habe:

    Code:
    # efibootmgr -v
    eingeben und schauen ob eine Fehlermeldung bzgl efivars kommt, wenn nicht wie bisher per chroot arbeiten:

    mounte dein root system als "/mnt"
    mounte andere dateisystem sofern gesplittet ("/home", "/boot") hinterher.
    mounte die efi partition als "/mnt/boot/efi


    dann noch dev, proc und sys

    Code:
    # mount --bind /dev /mnt/dev
    # mount --bind /proc /mnt/proc
    # mount --bind /sys /mnt/sys
    chroote

    Code:
    # chroot /mnt
    # grub2-install --target=x86_64-efi
    # shim-install    ### only needed for secure-boot
    # grub2-mkconfig -o /boot/grub2/grub.cfg
    Viel Erfolg!

  9. #9
    eigentlich keine Blondine
    Registriert seit
    Mar 2010
    Beiträge
    897
    Du sagtest, ich könnte nach deiner Beschreibung weitermachen, wenn keine Fehlermeldung bezüglich efivars kommt. Es kommt aber eine:
    Code:
    # efibootmgr -v
    EFI variables are not supported on this system.
    Was ist der prinzipielle Unterschied zwischen der Arbeit am gechrooteten und am laufenden System? Kann im laufenden System die Arbeit des Systems dazwischenfunken?
    Unter Linux eine .exe-Datei ausführen ist ganz einfach. Man nimmt eine beliebige unter Linux ausführbare Datei, benennt sie um in AusfuehrbareDatei.exe und führt sie aus.

  10. #10
    Premium Mitglied Avatar von spychodelics
    Registriert seit
    Nov 2002
    Ort
    Offenbach
    Beiträge
    587
    Nein, du kannst auch am laufenden System einfach weiterarbeiten, sollte keinen Unterschied machen. Chroot hat nur immer den Vorteil das man gewiss sein kann das nichts dazwischen funkt.

    Nächsten Ansatz den ich jetzt versuchen würde währe die BIOS Boot Optionen druchzusehen. Du hast GPT und eine EFI Partition aber bootest Legacy / Secure Boot off und das würde ich auf Secure Boot on mal versuchen umzuschalten. Vielleicht meldet sich auch noch jemand der etwas mehr Ahnung hat.

Ähnliche Themen

  1. opensuse bootet nicht mit angeschlossener USB Festplatte
    Von Dono im Forum System installieren und konfigurieren
    Antworten: 23
    Letzter Beitrag: 10.08.10, 16:08
  2. openSuse bootet nicht
    Von Shadow092 im Forum System installieren und konfigurieren
    Antworten: 10
    Letzter Beitrag: 25.08.08, 19:31
  3. OpenSuse 10.3 Bootet nicht?!
    Von Renix im Forum Linux Allgemein
    Antworten: 16
    Letzter Beitrag: 26.05.08, 16:49
  4. openSuse 10.3 bootet nicht auf HP-Notebook
    Von MunichMan im Forum System installieren und konfigurieren
    Antworten: 13
    Letzter Beitrag: 13.03.08, 17:22
  5. OpenSuse 10.3 bootet nicht mehr
    Von jjturbo im Forum Linux Allgemein
    Antworten: 4
    Letzter Beitrag: 14.02.08, 19:43

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •