Anzeige:
Ergebnis 1 bis 13 von 13

Thema: Mediatek MT7610U Treiber (TP LINK Archer T2UH)

  1. #1
    Registrierter Benutzer
    Registriert seit
    Dec 2017
    Beiträge
    5

    Mediatek MT7610U Treiber (TP LINK Archer T2UH)

    Hallo zusammen...
    Es geht um den im Titel genannten Treiber. Weiss jemand hier,ob es mittlerweile einen relativ aktuellen Treiber für aktuelle Kernelversionen gibt?
    Im Netz gibt es etliche Anleitungen,alle schon etwas älter, aber leider gibt jede Treibervariante Fehler beim Kompilieren aus.
    Wäre nett,wenn jemand antwortet, sofern er/sie etwas weiss.

    Danke im Voraus

  2. #2
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Ort
    Sauerland
    Beiträge
    1.008
    Im Netz gibt es etliche Anleitungen,alle schon etwas älter, aber leider gibt jede Treibervariante Fehler beim Kompilieren aus.
    Die du ja einmal in Code-Tags posten könntest......

    Ebenso wie die ID des Wlan-Chips......

  3. #3
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    20.720
    Was verstehst Du denn unter "akuteller Kernel"? Welches OS? Was für Fehler? Evtl. auch - welcher konkret verbaute Chipsatz?

    https://github.com/ulli-kroll/mt7610u sieht eigentlich doch recht aktuell aus...?


    (... fast schnell genug gewesen :-) )
    Ich bin root - ich darf das.

  4. #4
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Ort
    Sauerland
    Beiträge
    1.008
    Uups....

    kann gelöscht werden

  5. #5
    Registrierter Benutzer
    Registriert seit
    Dec 2017
    Beiträge
    5
    Ausgabe von lsusb :
    Bus 001 Device 002 : ID 148f:761a Ralink Technology, Corp.

    Fehlermeldung :

    /usr/src/linux-headers-4.14.0-kali1-common/scripts/Makefile.build:319:
    die Regel für Ziel „/root/Downloads/mt7610u_wifi_sta_v3002_dpo_20130916-master/os/linux/rt_profile.o“ scheiterte

    make[4]: *** [/root/Downloads/mt7610u_wifi_sta_v3002_dpo_20130916-master/os/linux/rt_profile.o]
    Fehler 1
    /usr/src/linux-headers-4.14.0-kali1-common/Makefile:1520:
    die Regel für Ziel „_module_/root/Downloads/mt7610u_wifi_sta_v3002_dpo_20130916-master“ scheiterte

    make[3]: *** [_module_/root/Downloads/mt7610u_wifi_sta_v3002_dpo_20130916-master]
    Fehler 2
    Makefile:146: die Regel für Ziel „sub-make“ scheiterte
    make[2]: *** [sub-make] Fehler 2

    Makefile:8: die Regel für Ziel „all“ scheiterte
    make[1]: *** [all]
    Fehler 2
    make[1]: Verzeichnis „/usr/src/linux-headers-4.14.0-kali1-amd64“ wird verlassen

    Makefile:371: die Regel für Ziel „modules“ scheiterte
    make: *** [modules] Fehler 2


    Sorry,hab das jetzt einfach rüber kopiert, muss mich in die funktionen hier noch eingewöhnen. Man möge es mir verzeihen...

  6. #6
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    20.720
    Ok, und wo hast Du den Treiber her? Der Dateiname deutet für mich zumindest nicht auf die aktuellste Version hin.

    ... und muss es Kali sein? Für andere OS findet mal sicherlich einfacher Hilfe - abgesehen von dem Hinweis unter "https://wiki.ubuntuusers.de/WLAN/Karten/TP-Link/", daß man sich viel Stress erspart, wenn man einen anderen Stick verwendet...
    Ich bin root - ich darf das.

  7. #7
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Ort
    Sauerland
    Beiträge
    1.008
    mt7610u_wifi_sta_v3002_dpo_20130916-master
    Wird der Treiber von Mediatek sein......
    Der wird aber bestimmt ohne Patch nicht bei kernel 4.14 zum laufen zu bewegen sein.

    Da wäre es eher schon mit dem von marce in Post #3 genannten Treiber zu versuchen.....

    Aber auch hier noch einmal:
    Warum Kali?

  8. #8
    Registrierter Benutzer
    Registriert seit
    Dec 2017
    Beiträge
    5
    Der Treiber ist dieser :
    https://github.com/chenhaiq/mt7610u_...2_dpo_20130916

    Kali deshalb,da es "State of the Art" im Bereich Sicherheit/Pentesting ist und ich mich diesbezüglich zwecks CISSP einarbeiten will.
    Ich weiss,dass hier Kali kritisch gesehen wird,grade wenn Anfänger ohne jegliche Linux-Erfahrung fragen.
    Zu denen gehöre ich aber nicht...

  9. #9
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    20.720
    Dann würde ich mir aber auch einen Stick / WLAN-Chipsatz aussuchen, der vom OS 110% unterstützt wird. Ggf. hast Du sonst das Problem, daß die "tieferen Dinge" in Kali gar nicht gehen, wenn der Treiber das ggf. gar nicht kann.

    Ich würde trotzdem ein anderes OS wählen und die gewünschten Tools einfach nachinstallieren. Die Support-Breite ist einfach wesentlich größer.
    Ich bin root - ich darf das.

  10. #10
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Ort
    Sauerland
    Beiträge
    1.008
    Der Treiber ist der originale Mediatek Treiber gepatched für Kernel 4.1 und Rasberry2......

    Wird nicht funktionieren.....

  11. #11
    Registrierter Benutzer
    Registriert seit
    Dec 2017
    Beiträge
    5
    Naja,der Onboard-Chip des Notebooks ist kompatibel, aber dann bin ich gezwungen, mit Live-USB-Stick zu arbeiten.
    Und das ist nicht immer zweckgemäß.
    Ein anderes OS wird wenig bringen. Debian und Ubuntu mögen den Chipsatz ebenso wenig...
    Selbst BackTrack5 will nicht,und das trotz altem Kernel...

  12. #12
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Ort
    Sauerland
    Beiträge
    1.008
    Ein anderes OS wird wenig bringen. Debian und Ubuntu mögen den Chipsatz ebenso wenig...
    Andere bekommen es hin.....

    Warum versuchst du es nicht einmal mit dem von marce angesprochenen Treiber und z.B. Ubuntu?

  13. #13
    Registrierter Benutzer
    Registriert seit
    Dec 2017
    Beiträge
    5
    Okay,dann versuche ich das noch mal.
    Falls es nicht klappt,sag ich Bescheid
    Und danke für die doch sehr schnellen, sachlichen Antworten

Ähnliche Themen

  1. Wie installiere ich diese Treiber für meinen TP-Link Archer T2UH?
    Von Kazuto im Forum System installieren und konfigurieren
    Antworten: 2
    Letzter Beitrag: 25.04.16, 17:03
  2. Treiber für D-Link dsl.260i
    Von Koelnerpaul im Forum Anbindung an die Aussenwelt
    Antworten: 3
    Letzter Beitrag: 25.06.06, 09:32
  3. D-Link DWL-650+ - Treiber?
    Von Djon im Forum Anbindung an die Aussenwelt
    Antworten: 2
    Letzter Beitrag: 04.05.05, 15:46
  4. D-Link 260i Treiber?
    Von MatzeMC im Forum Anbindung an die Aussenwelt
    Antworten: 0
    Letzter Beitrag: 20.05.03, 16:12
  5. D-Link DFE 530 TX Treiber
    Von Andreas.S im Forum Kompilieren von Kernel und Sourcen
    Antworten: 5
    Letzter Beitrag: 22.08.01, 20:06

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •