Anzeige:
Ergebnis 1 bis 3 von 3

Thema: python3 Type str doesn't support the buffer API fuu

  1. #1
    Registrierter Benutzer Avatar von Huhn Hur Tu
    Registriert seit
    Nov 2003
    Ort
    Karlsruhe
    Beiträge
    1.969

    python3 Type str doesn't support the buffer API fuu

    Hi,

    ich haenge mal wieder an python3

    - https://pastebin.com/A9q2X85g

    am Fehler

    - TypeError: Type str doesn't support the buffer API

    Ich versuche die aquivalent zu "grep -c" Zeilen mit Treffern zu zaehlen
    Zwischen anonym sein wollen und seine Daten nicht verkaufen wollen, liegen zwei Welten. Wenn man sich einen kostenpflichtigen Dienst sucht, dann meist, weil man für diese Dienstleistung zahlt und nicht selbst das Produkt sein will.


  2. #2
    Registrierter Benutzer
    Registriert seit
    Apr 2009
    Ort
    Erde
    Beiträge
    2.047
    Die open Anweisung ist nicht gut, du hast vergessen den Mode auf Text zu stellen, daher die Meldung, entweder noch ein decode aufrufen, oder direkt als Text einlesen - https://docs.python.org/3/library/gzip.html#gzip.open
    ...
    The mode argument can be any of 'r', 'rb', 'a', 'ab', 'w', 'wb', 'x' or 'xb' for binary mode, or 'rt', 'at', 'wt', or 'xt' for text mode. The default is 'rb'.
    ...
    Geändert von nopes (11.12.17 um 19:12 Uhr)
    Gruß nopes
    (,,,)---(^.^)---(,,,) /var/log/messages | grep cat

  3. #3
    Registrierter Benutzer Avatar von Huhn Hur Tu
    Registriert seit
    Nov 2003
    Ort
    Karlsruhe
    Beiträge
    1.969
    Danke, das war was mir fehlte
    Zwischen anonym sein wollen und seine Daten nicht verkaufen wollen, liegen zwei Welten. Wenn man sich einen kostenpflichtigen Dienst sucht, dann meist, weil man für diese Dienstleistung zahlt und nicht selbst das Produkt sein will.


Ähnliche Themen

  1. drive doesn't support SMART
    Von kurzschluss im Forum System installieren und konfigurieren
    Antworten: 0
    Letzter Beitrag: 17.11.07, 16:52
  2. X Window System doesn't support locale
    Von waylander im Forum Anwendungen Allgemein, Software
    Antworten: 1
    Letzter Beitrag: 09.06.05, 02:12
  3. This installation doesn't support glibc-2.1 on x86
    Von Discipulus im Forum Spielen Allgemein
    Antworten: 17
    Letzter Beitrag: 29.04.05, 20:59
  4. Kernel doesn't support ppp_generic needed for PPPoE
    Von Nils Lüders im Forum System installieren und konfigurieren
    Antworten: 2
    Letzter Beitrag: 10.03.04, 13:19
  5. kernel doesn't support ppp_generic
    Von kron im Forum System installieren und konfigurieren
    Antworten: 0
    Letzter Beitrag: 23.08.01, 00:49

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •