Anzeige:
Ergebnis 1 bis 3 von 3

Thema: Debian 9 und Samba AD funktioniert nicht richtig

  1. #1
    Registrierter Benutzer
    Registriert seit
    Feb 2016
    Beiträge
    39

    Debian 9 und Samba AD funktioniert nicht richtig

    Guten Abend,

    ich habe damals unter Debian 8 mir mal ein AD erstellt, da ich dafür keinen extra Windows-Server installieren wollte.
    Nun habe ich mein Testsystem einmal neu gemacht und dabei den DC auf Debian 9 gebracht.

    Problem: Nun kann ich zwar weiterhin mit
    Code:
    apt install libkrb53 krb5-user samba winbind ntp libnss-winbind libpam-winbind
    und dem
    Code:
    samba-tool domain provision --use-rfc2307 --interactive
    ein AD-DC einrichten, jedoch startet der eigentliche Dienst bei einem Neustart nicht mit.

    Somit muss ich bei jedem Start erst einmal samba eintippen bzw. das in die rc.local schreiben damit es gestartet wird. Der Dienst samba-ad-dc funktioniert somit scheinbar nicht mehr, unter Debian 8 hatte ich das in Erinnerung, dass dies so ging.
    Gibt es da Abhilfe oder muss das so?

  2. #2
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    20.565
    hab' kein Debian, aber es gibt doch sicherlich ein systemd-service-File zum Starten von Samba...
    Ich bin root - ich darf das.

  3. #3
    Registrierter Benutzer
    Registriert seit
    Nov 2017
    Beiträge
    1
    Samba als ad-dc reicht der Systemd Samba-ad-dc
    Wenn dein debian noch member werden soll, dann benötigt man noch winbindd, smbd und nmbd als systemd.

    Bsp.:
    nano /lib/systemd/system/samba-ad-dc.service

    [Unit]
    Description=Samba ADDC
    After=network.target remote-fs.target nss-lookup.service

    [Service]
    Type=forking
    ExecStart=/usr/sbin/samba -D
    PIDFile=/var/run/samba.pid
    ExecReload=/bin/kill -HUP $MAINPID

    [Install]
    WantedBy=multi-user.target


    Wenn du die Datei hast:
    root@dc# systemctl daemon-reload
    root@dc# systemctl enable samba-ad-dc

Ähnliche Themen

  1. SSL funktioniert nicht richtig
    Von Vagabundo im Forum Linux als Server
    Antworten: 4
    Letzter Beitrag: 07.06.10, 07:43
  2. ssh funktioniert nicht richtig
    Von Icaros im Forum Linux als Server
    Antworten: 6
    Letzter Beitrag: 22.05.07, 14:51
  3. Drucken mit Samba funktioniert nicht richtig
    Von r00tling im Forum Linux in heterogenen Netzen
    Antworten: 2
    Letzter Beitrag: 12.02.07, 07:52
  4. CGI funktioniert nicht (richtig)
    Von verve im Forum Linux als Server
    Antworten: 12
    Letzter Beitrag: 06.10.02, 22:25
  5. ftp funktioniert nicht richtig
    Von lou_ziffer im Forum Linux als Server
    Antworten: 1
    Letzter Beitrag: 27.08.02, 21:35

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •