Anzeige:
Ergebnis 1 bis 7 von 7

Thema: Mailscanner / Spamassassin - Spam wird nicht markiert

  1. #1
    Registrierter Benutzer
    Registriert seit
    Nov 2017
    Beiträge
    4

    Mailscanner / Spamassassin - Spam wird nicht markiert

    Moin,

    in der Firma habe ich mir eine virtuelle Maschine mit Postfix/MailScanner/Spassassin installiert, die unseren Tobit Server mit Mails versorgt.
    Alles läuft problemlos, bis auf das Spam Mails zwar erkannt werden, die Betreffzeile nach der Erkennung aber nicht modifziert wird.

    Als Bespiel habe ich mir eine Mail mit dem Inhalt "XJS*C4JDBQADN1.NSBN3*2IDNEN*GTUBE-STANDARD-ANTI-UBE-TEST-EMAIL*C.34X" gesendet:

    X-MW24MAILGATE-Information: Please contact administrator@domaene.de for more information
    X-MW24MAILGATE-ID: 47028100395.A4673
    X-MailScanner-MW24MAILGATE: Found to be clean
    X-MailScanner-MW24MAILGATE-SpamCheck: not spam (whitelisted),
    SpamAssassin (not cached, score=1004.562, required 6, DCC_CHECK 1.10,
    DIGEST_MULTIPLE 0.00, GTUBE 1000.00, HTML_MESSAGE 0.00,
    KB_WAM_FROM_NAME_SINGLEWORD 0.20, PYZOR_CHECK 1.98,
    RCVD_IN_DNSWL_NONE -0.00, RDNS_NONE 1.27, TVD_SPACE_RATIO 0.00)
    X-MailScanner-MW24MAILGATE-From: user@gmx.de
    X-Spam-Status: Not recognized as Spam by MW24MailGate

    Der Spamassassin zählt zwar den Score hoch - ausgeliefert wird die Mail aber in ihrem Originalzustand.
    Hat einer eine Idee, wo ich in den Konfigurationsfiles noch suchen kann - ich bekomme es leider nicht heraus, warum die Spammail nicht als solche erkannt wird.

    LG
    Frank

  2. #2
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    20.480
    Wie sieht die Konfig denn aktuell aus? ... und zwar bitte den kompletten "Workflow" vom Eingang am SMTP-Port bis zum Ausgang in die Postbox des Users...
    Ich bin root - ich darf das.

  3. #3
    Registrierter Benutzer
    Registriert seit
    Nov 2017
    Beiträge
    4
    Hmmm....

    eigentlich klassisch: fetchmail holt die POP3 Konten ab, postfix schiebt die Mails nachdem sie den MailScanner durchlaufen haben per smtp an unseren Tobit Server.
    Reicht das ? oder muss ich genauer werden ? ;-)

    Ich denke nicht, daß der Workflow das Problem ist :-) - virenverseuchte Mails werden vom MailScanner abgefangen und entsprechend gekennzeichnet.
    Wie man oben sieht, durchlaufen die Spammails ja den MailScanner / Spamassassin, sonst würde der Mailscanner ja nicht den Score vom Spamassassin auflisten.
    Was nicht funktioniert ist, wenn der Spamscore überschritten ist, daß die erkannten Spammails geknnzeichnet werden - was bei virenversuchten Mails funktioniert.

    LG
    Frank

  4. #4
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    20.480
    Daher ja die Frage nach der Konfig. Und damit meine ich die Files, nicht Prosa.

    Google meint übrigens dazu: https://www.lifewire.com/spamassassi...t-spam-1166252

    warum willst Du denn das Subject überhaupt geändert haben? Ein Marker für die Erkennung ist doch drin, reicht das nicht?
    Geändert von marce (12.11.17 um 16:14 Uhr)
    Ich bin root - ich darf das.

  5. #5
    Registrierter Benutzer
    Registriert seit
    Nov 2017
    Beiträge
    4
    Moin,

    das ist es ja: selbst der eingebaute Maker für die Erkennung ändert nicht das Subject. Nachdem ich den heutigen Vormittag damit verbracht habe, die MailScanner / Spammassassin Config Files von dem alten Mailgate gegenzuvergleichen mit dem neuen Mailgate, habe ich das /etc/Mailscanner Verzeichnis mal gepackt:

    DL: http://www.elektro-musswessels.de/do...ailScanner.zip

    Achos: der "alte" Mailgate ist ein OpenSuse 11.3.


    LG
    Frank

  6. #6
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    20.480
    ... auf den ersten Blick ist der Konfig-Eintrag aus dem verlinkten Thread nicht vorhanden.
    Ich bin root - ich darf das.

  7. #7
    Registrierter Benutzer
    Registriert seit
    Nov 2017
    Beiträge
    4
    Moin,

    Problem gelöst: dadurch, daß ich die Mails per fetchmail abgeholt habe, wurden alle Mails als <localhost> zugestellt und somit gewhitelistet (wat für'n Wort)
    Indem ich in der ./fetchmailrc den smtphost zusätzlichen angegeben habe (auf die gleiche Maschine), wurde das verhindert - und alle Mails sind nun nicht mehr "gewhitelistet".

    Danke !
    Frank

Ähnliche Themen

  1. Antworten: 5
    Letzter Beitrag: 18.01.10, 15:59
  2. SPAMASSASSIN: Mails werden markiert, jedoch auch zugestellt
    Von newbie2007 im Forum Linux als Server
    Antworten: 24
    Letzter Beitrag: 04.08.08, 19:21
  3. Spamassassin: Mail werden markiert und trotzdem zugestellt.
    Von TBVAndy im Forum Linux als Server
    Antworten: 7
    Letzter Beitrag: 10.06.07, 17:44
  4. spamassassin beibringen was SPAM ist und was nicht...
    Von semy im Forum Linux als Server
    Antworten: 2
    Letzter Beitrag: 16.03.06, 22:40
  5. Amavis markiert Spam nicht
    Von ludmilla im Forum Linux als Server
    Antworten: 1
    Letzter Beitrag: 24.09.04, 14:33

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •