Anzeige:
Ergebnis 1 bis 5 von 5

Thema: Debian Wlan Konfiguration; verbindung an wlanbox

  1. #1
    Registrierter Benutzer
    Registriert seit
    Jun 2013
    Beiträge
    18

    Debian Wlan Konfiguration; verbindung an wlanbox

    Hallo,

    Ich habe Probleme mein WLan stick mit wpa_supplicant zum laufen zu bekommen.

    Meine wlankarte mit dmesg/lsusb:
    Code:
    dmesg des wlan sticks:
    
    68.192193] eth0: no IPv6 routers present [ 75.858427] usb 4-1: USB disconnect, device number 2 [ 81.752281] usb 1-3: new high-speed USB device number 3 using ehci_hcd [ 81.886275] usb 1-3: New USB device found, idVendor=0bda, idProduct=a811 [ 81.886284] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3 [ 81.886292] usb 1-3: Product: 802.11ac WLAN Adapter [ 81.886297] usb 1-3: Manufacturer: Realtek [ 81.886302] usb 1-3: SerialNumber: 00e04c000001 # lsusb Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 001 Device 003: ID 0bda:a811 Realtek Semiconductor Corp. Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    /etc/wpa_supplikant/wpa_supplikant.conf
    Code:
    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=0
    eapol_version=1
    ap_scan=1
    fast_reauth=1
    
    network={
    id_str="wlan0"
    scan_ssid=1
    key_mgmt=WPA-PSK
    proto=WPA
    pairwise=TKIP
    group=TKIP
    ssid="meine-ssid"
    #psk="abcdefg"
    psk=c37298a418889af819b9f52efe5000989a54c9e5717c06dbcbe48c3292eebdaa
    }
    Die psk wurde wie folgt erstellt (hier mit meine-ssid und abcdefgh:
    Code:
    # wpa_passphrase meine-ssid
    # reading passphrase from stdin
    abcdefgh
    network={
            ssid="meine-ssid"
            #psk="abcdefgh"
            psk=c37298a418889af819b9f52efe5000989a54c9e5717c06dbcbe48c3292eebdaa
    /etc/network/interfaces
    Code:
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    #allow-hotplug eth0
    #iface eth0 inet dhcp
    
    auto eth0
    iface eth0 inet static
            address 192.168.1.254
            netmask 255.255.255.0
            gateway 192.168.1.1
    
    iface wlan0 inet dhcp
            wpa-driver wext
            wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

    Mit einem neustart der Interfaces:
    # /etc/init.d/networking restart
    [warn] Running /etc/init.d/networking restart is deprecated because it may not re-enable some interfaces ... (warning).
    [....] Reconfiguring network interfaces...Stopping Avahi mDNS/DNS-SD Daemon: avahi-daemon.
    done.
    ifconfig sagt:
    Code:
    # ifconfig
    eth0      Link encap:Ethernet  HWaddr 2c:76:8a:ab:d3:9b
              inet addr:192.168.2.254  Bcast:192.168.2.255  Mask:255.255.255.0
              inet6 addr: fe80::2e76:8aff:feab:d39b/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:376 errors:0 dropped:0 overruns:0 frame:0
              TX packets:317 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:35862 (35.0 KiB)  TX bytes:56663 (55.3 KiB)
              Interrupt:18
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    Folgendes bewirkt auch nix:
    Code:
     ifup wlan0, wpa_supplicant
    Ignoring unknown interface wlan0,=wlan0,.
    Ignoring unknown interface wpa_supplicant=wpa_supplicant.
    Code:
    # ifup --force wlan0
    wpa_supplicant: wpa-roam can only be used with the "manual" inet METHOD
    run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
    Internet Systems Consortium DHCP Client 4.2.2
    Copyright 2004-2011 Internet Systems Consortium.
    All rights reserved.
    For info, please visit https://www.isc.org/software/dhcp/
    
    Cannot find device "wlan0"
    Bind socket to interface: No such device
    Failed to bring up wlan0.

  2. #2
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Ort
    Sauerland
    Beiträge
    914
    Treiber ist vorhanden:
    als root:
    Code:
    modprobe -c | grep -i "0bda.*a811"
    sollte dann so etwas herauskommen:
    Code:
    modprobe -c | grep -i "0bda.*a811"
    alias usb:v0BDApA811d*dc*dsc*dp*ic*isc*ip*in* rtl8812au

  3. #3
    Registrierter Benutzer
    Registriert seit
    Jun 2013
    Beiträge
    18
    modprobe sagt dann leider nix in verbindung mit a811

    dmesg sagt:
    Code:
    [  259.536245] usb 1-3: new high-speed USB device number 4 using ehci_hcd
    [  259.670229] usb 1-3: New USB device found, idVendor=0bda, idProduct=a811
    [  259.670239] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [  259.670246] usb 1-3: Product: 802.11ac WLAN Adapter
    [  259.670252] usb 1-3: Manufacturer: Realtek
    [  259.670256] usb 1-3: SerialNumber: 00e04c000001
    Fehlt denn der Treiber im kernel oder ist er nur nicht geladen?

  4. #4
    Registrierter Benutzer
    Registriert seit
    Jun 2013
    Beiträge
    18
    Der Treiber fehlte im Kernel / oder als Modul und musste nachträglich installiert werden:

    Hier gibt es die Treiber:

    Damit das Compilieren des Treibers klappte musste im Makefile EXTRA_CFLAGS += -Werror auskommentiert werden.

    Zusammengefasst:
    Code:
    # git clone https://github.com/abperiasamy/rtl8812AU_8821AU_linux
    # cd rtl8812AU_8821AU_linux
    # make
    # make install
    Irgendwie hab ich nun den Treiber doppelt???
    Code:
    # modprobe -c | grep -i "0bda.*a811"
    alias usb:v0BDApA811d*dc*dsc*dp*ic*isc*ip* rtl8812au
    alias usb:v0BDApA811d*dc*dsc*dp*ic*isc*ip* rtl8812au

    iwconfig sagt:
    Code:
    # iwconfig
    lo        no wireless extensions.
    
    wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
              Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated
              Sensitivity:0/0
              Retry:off   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              Link Quality:0  Signal level:0  Noise level:0
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    
    eth0      no wireless extensions.
    So nun bin ich ein Stück weiter gekommen, doch leider verbindet sich das WLAN nicht mit der WLAN box. Die Konfiguration von /etc/network/interfaces und /etc/wpa_supplicant/supplicant.conf wurden nicht verwendet.

  5. #5
    Registrierter Benutzer
    Registriert seit
    Jan 2008
    Beiträge
    2.469
    Testen, ob der prozess wpa_supplicant mit welchen Optionen läuft:

    Code:
     ps axw | grep wpa
    Den Prozess wpa_supplicant beenden:

    Code:
    # kill -9  "Prozess ID(s) vom obigen Kommando"
    Eine wpa_supplicant.conf von Hand erstellen:

    Code:
    # wpa_passphrase meine-ssid abcdefg > /root/wpa_supplicant.conf
    wpa_supplicant "von Hand" starten, Achtung, dhcp wird so NICHT mit gestartet:

    Code:
    # wpa_supplicant -iwlan0 -c/root/wpa_supplicant.conf -Dnl80211,wext -ddd

Ähnliche Themen

  1. Keine Verbindung? WLan mit WPA verschlüsselung mit ipw2100 unter Debian Etch
    Von BurningDaylight im Forum Anbindung an die Aussenwelt
    Antworten: 2
    Letzter Beitrag: 04.05.08, 21:15
  2. WLAN: ndiswrapper unter Debian - keine Verbindung mit WPA
    Von stefan-tiger im Forum Anbindung an die Aussenwelt
    Antworten: 14
    Letzter Beitrag: 14.01.07, 15:46
  3. WLan konfiguration mit Debian
    Von DerTom25 im Forum Router und Netzaufbau
    Antworten: 3
    Letzter Beitrag: 08.07.05, 17:39
  4. Sporadische Verbindung nach WLAN Konfiguration
    Von koyaanisqatsi im Forum Anbindung an die Aussenwelt
    Antworten: 2
    Letzter Beitrag: 08.06.05, 10:08
  5. Debian: Lan und Wlan-Karte Konfiguration
    Von FB003 im Forum Anbindung an die Aussenwelt
    Antworten: 0
    Letzter Beitrag: 06.03.04, 15:20

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •