Anzeige:
Ergebnis 1 bis 10 von 10

Thema: Apt zeigt Fehler

  1. #1
    Registrierter Benutzer
    Registriert seit
    Jul 2003
    Beiträge
    1.120

    Apt zeigt Fehler

    Hi, bekomme nach einem sudo apt upgrade folgende Fehlermeldung:
    Code:
     sudo apt upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    The following packages were automatically installed and are no longer required:
      acl g++-4.9 libasn1-8-heimdal libasprintf0c2 libbind9-90
      libboost-iostreams1.55.0 libdns-export100 libdns100 libelfg0 libftdi1
      libgif4 libgnutls-deb0-28 libgnutls-openssl27 libhcrypto4-heimdal
      libhdb9-heimdal libheimbase1-heimdal libhogweed2 libhx509-5-heimdal libicu52
      libirs-export91 libisc-export95 libisc95 libisccc90 libisccfg-export90
      libisccfg90 libjasper1 libkrb5-26-heimdal liblinear1 liblircclient0
      liblognorm1 liblua5.1-0 liblwres90 libnettle4 libntdb1
      libperl4-corelibs-perl libprocps3 libpsl0 libroken18-heimdal
      libstdc++-4.9-dev libvpx1 libwind0-heimdal libxtables10 python-ntdb
    Use 'sudo apt autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    2 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Setting up bluez (5.43-2+deb9u1) ...
    Job for bluetooth.service failed because the control process exited with error c                                                                                                                               ode.
    See "systemctl status bluetooth.service" and "journalctl -xe" for details.
    invoke-rc.d: initscript bluetooth, action "restart" failed.
    ● bluetooth.service - Bluetooth service
       Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset                                                                                                                               : enabled)
       Active: failed (Result: exit-code) since Thu 2017-10-19 21:34:56 CEST; 105ms                                                                                                                                ago
         Docs: man:bluetoothd(8)
      Process: 2327 ExecStart=/usr/lib/bluetooth/bluetoothd (code=exited, status=226                                                                                                                               /NAMESPACE)
     Main PID: 2327 (code=exited, status=226/NAMESPACE)
    
    Oct 19 21:34:56 cubie systemd[1]: Starting Bluetooth service...
    Oct 19 21:34:56 cubie systemd[2327]: bluetooth.service: Failed at step NAME…ptor
    Oct 19 21:34:56 cubie systemd[1]: bluetooth.service: Main process exited, c…PACE
    Oct 19 21:34:56 cubie systemd[1]: Failed to start Bluetooth service.
    Oct 19 21:34:56 cubie systemd[1]: bluetooth.service: Unit entered failed state.
    Oct 19 21:34:56 cubie systemd[1]: bluetooth.service: Failed with result 'ex…de'.
    Hint: Some lines were ellipsized, use -l to show in full.
    dpkg: error processing package bluez (--configure):
     subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of bluetooth:
     bluetooth depends on bluez; however:
      Package bluez is not configured yet.
    
    dpkg: error processing package bluetooth (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     bluez
     bluetooth
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    root@cubie:~# sudo apt update
    Hit:1 http://security.debian.org wheezy/updates InRelease
    Ign:2 http://ftp.de.debian.org/debian stable InRelease
    Hit:3 http://ftp.debian.org/debian wheezy-updates InRelease
    Hit:4 http://ftp.de.debian.org/debian stable Release
    Hit:5 http://ftp.us.debian.org/debian wheezy-backports InRelease
    Hit:6 https://deb.nodesource.com/node_4.x jessie InRelease
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    All packages are up to date.
    root@cubie:~# sudo apt upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    The following packages were automatically installed and are no longer required:
      acl g++-4.9 libasn1-8-heimdal libasprintf0c2 libbind9-90 libboost-iostreams1.55.0 libdns-export100 libdns100 libelfg0 libftdi1 libgif4 libgnutls-deb0-28 libgnutls-openssl27 libhcrypto4-heimdal
      libhdb9-heimdal libheimbase1-heimdal libhogweed2 libhx509-5-heimdal libicu52 libirs-export91 libisc-export95 libisc95 libisccc90 libisccfg-export90 libisccfg90 libjasper1 libkrb5-26-heimdal liblinear1
      liblircclient0 liblognorm1 liblua5.1-0 liblwres90 libnettle4 libntdb1 libperl4-corelibs-perl libprocps3 libpsl0 libroken18-heimdal libstdc++-4.9-dev libvpx1 libwind0-heimdal libxtables10 python-ntdb
    Use 'sudo apt autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    2 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Setting up bluez (5.43-2+deb9u1) ...
    Job for bluetooth.service failed because the control process exited with error code.
    See "systemctl status bluetooth.service" and "journalctl -xe" for details.
    invoke-rc.d: initscript bluetooth, action "restart" failed.
    ● bluetooth.service - Bluetooth service
       Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
       Active: failed (Result: exit-code) since Thu 2017-10-19 21:37:43 CEST; 76ms ago
         Docs: man:bluetoothd(8)
      Process: 3477 ExecStart=/usr/lib/bluetooth/bluetoothd (code=exited, status=226/NAMESPACE)
     Main PID: 3477 (code=exited, status=226/NAMESPACE)
    
    Oct 19 21:37:43 cubie systemd[1]: Starting Bluetooth service...
    Oct 19 21:37:43 cubie systemd[3477]: bluetooth.service: Failed at step NAMESPACE spawning /usr/lib/bluetooth/bluetoothd: Bad file descriptor
    Oct 19 21:37:43 cubie systemd[1]: bluetooth.service: Main process exited, code=exited, status=226/NAMESPACE
    Oct 19 21:37:43 cubie systemd[1]: Failed to start Bluetooth service.
    Oct 19 21:37:43 cubie systemd[1]: bluetooth.service: Unit entered failed state.
    Oct 19 21:37:43 cubie systemd[1]: bluetooth.service: Failed with result 'exit-code'.
    dpkg: error processing package bluez (--configure):
     subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of bluetooth:
     bluetooth depends on bluez; however:
      Package bluez is not configured yet.
    
    dpkg: error processing package bluetooth (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     bluez
     bluetooth
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    sudo apt update läuft ohne Probleme durch.

    Das System ist Debian 9.1

    Danke
    Intel Quad Core Q6600
    4 GIGABYTE Arbeitsspeicher
    640 MB NVIDIA 8800GTS PCI-E
    OpenSuse10.3 64Bit

  2. #2
    kleine schwester von root Avatar von corresponder
    Registriert seit
    May 2002
    Ort
    192.67.198.56
    Beiträge
    3.819
    brauchste "bluez"?
    _______________________________________

    www.audio4linux.de - musik machen mit offenen quellen!

  3. #3
    Registrierter Benutzer
    Registriert seit
    Jul 2003
    Beiträge
    1.120
    Hab einen "CUL auf 433MHZ dran", aber BT an sich brauch ich nicht
    Intel Quad Core Q6600
    4 GIGABYTE Arbeitsspeicher
    640 MB NVIDIA 8800GTS PCI-E
    OpenSuse10.3 64Bit

  4. #4
    kleine schwester von root Avatar von corresponder
    Registriert seit
    May 2002
    Ort
    192.67.198.56
    Beiträge
    3.819
    dann schmeiss doch bluez runter....
    _______________________________________

    www.audio4linux.de - musik machen mit offenen quellen!

  5. #5
    Registrierter Benutzer
    Registriert seit
    Jul 2003
    Beiträge
    1.120
    Hab es über ein
    Code:
    sudo service bluetooth stop
    sowie ein
    Code:
     sudo rfkill block bluetooth
    versucht, fehlermeldung bleibt die gleiche
    und auch ein
    Code:
    sudo update-rc.d -f bluetooth remove
    hat nichts gebracht
    Intel Quad Core Q6600
    4 GIGABYTE Arbeitsspeicher
    640 MB NVIDIA 8800GTS PCI-E
    OpenSuse10.3 64Bit

  6. #6
    kleine schwester von root Avatar von corresponder
    Registriert seit
    May 2002
    Ort
    192.67.198.56
    Beiträge
    3.819
    apt-get remove bluetooth
    apt-get purge bluetooth

    ?
    _______________________________________

    www.audio4linux.de - musik machen mit offenen quellen!

  7. #7
    Registrierter Benutzer
    Registriert seit
    Jul 2003
    Beiträge
    1.120
    Zitat Zitat von corresponder Beitrag anzeigen
    apt-get remove bluetooth
    apt-get purge bluetooth

    ?
    bei remove bekomme ich angezeigt
    Package 'bluetooth' is not installed, so not removed
    und anschließend die gleiche Fehlermeldung wie oben, das gleiche bei purge

    Beim anschließenden Versuch einfach mal BT zu installieren kommt aber auch wieder ein Fehler
    Code:
     sudo apt-get install bluetooth
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    bluetooth is already the newest version (5.43-2+deb9u1).
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    2 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Setting up bluez (5.43-2+deb9u1) ...
    Job for bluetooth.service failed because the control process exited with error code.
    See "systemctl status bluetooth.service" and "journalctl -xe" for details.
    invoke-rc.d: initscript bluetooth, action "restart" failed.
    ● bluetooth.service - Bluetooth service
       Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
       Active: failed (Result: exit-code) since Fri 2017-10-20 06:39:10 CEST; 79ms ago
         Docs: man:bluetoothd(8)
      Process: 25432 ExecStart=/usr/lib/bluetooth/bluetoothd (code=exited, status=226/NAMESPACE)
     Main PID: 25432 (code=exited, status=226/NAMESPACE)
    
    Oct 20 06:39:10 cubie systemd[1]: Starting Bluetooth service...
    Oct 20 06:39:10 cubie systemd[1]: bluetooth.service: Main process exited, code=exited, status=226/NAMESPACE
    Oct 20 06:39:10 cubie systemd[1]: Failed to start Bluetooth service.
    Oct 20 06:39:10 cubie systemd[1]: bluetooth.service: Unit entered failed state.
    Oct 20 06:39:10 cubie systemd[1]: bluetooth.service: Failed with result 'exit-code'.
    dpkg: error processing package bluez (--configure):
     subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of bluetooth:
     bluetooth depends on bluez; however:
      Package bluez is not configured yet.
    
    dpkg: error processing package bluetooth (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     bluez
     bluetooth
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Geändert von Coolzero (20.10.17 um 06:40 Uhr)
    Intel Quad Core Q6600
    4 GIGABYTE Arbeitsspeicher
    640 MB NVIDIA 8800GTS PCI-E
    OpenSuse10.3 64Bit

  8. #8
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    20.483
    Versuch mal, den Service über die entsprechenden systemd-Kommandos zu stoppen und zu entfernen.

    ... service (und update-rc) ist AFAIK init - und das gibt's (grob gesagt) nicht mehr. Und ich bin mir nicht sicher, ob Debian den entsprechenden "Dreher" auf systemd darin eingebaut hat...
    Ich bin root - ich darf das.

  9. #9
    Registrierter Benutzer Avatar von drcux
    Registriert seit
    Oct 2003
    Beiträge
    6.878
    "status=226/NAMESPACE" deutet darauf hin, das im bluetooth.service "ProtectHome=true" o.ä. gesetzt ist und du irgendeine Besonderheit bei deinen Homeverzeichnissen hast..?

  10. #10
    Registrierter Benutzer
    Registriert seit
    Jul 2003
    Beiträge
    1.120
    Zitat Zitat von marce Beitrag anzeigen
    Versuch mal, den Service über die entsprechenden systemd-Kommandos zu stoppen und zu entfernen.

    ... service (und update-rc) ist AFAIK init - und das gibt's (grob gesagt) nicht mehr. Und ich bin mir nicht sicher, ob Debian den entsprechenden "Dreher" auf systemd darin eingebaut hat...
    Also ein
    Code:
     systemctl disable bluetooth.service
    bringt dann diese Meldung:

    Code:
    Synchronizing state of bluetooth.service with SysV service script with /lib/systemd/systemd-sysv-install.
    Executing: /lib/systemd/systemd-sysv-install disable bluetooth
    insserv: warning: current start runlevel(s) (empty) of script `bluetooth' overrides LSB defaults (2 3 4 5).
    insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `bluetooth' overrides LSB defaults (0 1 6).
    Removed /etc/systemd/system/dbus-org.bluez.service.
    Danach kommt dann erstmal keine Fehlermeldung mehr.

    Auch nach dem Neustart ist alles OK, sieht also gut aus.

    Danke für die Hilfe
    Intel Quad Core Q6600
    4 GIGABYTE Arbeitsspeicher
    640 MB NVIDIA 8800GTS PCI-E
    OpenSuse10.3 64Bit

Ähnliche Themen

  1. tkantivir zeigt fehler
    Von andykrstn im Forum Sicherheit
    Antworten: 6
    Letzter Beitrag: 14.02.07, 13:16
  2. Paketverwaltung zeigt Fehler an
    Von Christopherus im Forum System installieren und konfigurieren
    Antworten: 11
    Letzter Beitrag: 24.11.06, 06:48
  3. Terminal Programm zeigt fehler
    Von HappytreeFriend im Forum System installieren und konfigurieren
    Antworten: 7
    Letzter Beitrag: 03.03.05, 12:49
  4. ./Configure zeigt undefinierbare Fehler
    Von Crate im Forum Kompilieren von Kernel und Sourcen
    Antworten: 16
    Letzter Beitrag: 21.07.04, 20:44
  5. wine zeigt komischen fehler ??
    Von *LinuxNewbi* im Forum Emulatoren für Spiele
    Antworten: 0
    Letzter Beitrag: 25.03.03, 23:45

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •