Anzeige:
Ergebnis 1 bis 4 von 4

Thema: Hat wer ein BLFS mit KF5 lauffaehig bauen koennen?

Hybrid-Darstellung

Vorheriger Beitrag Vorheriger Beitrag   Nächster Beitrag Nächster Beitrag
  1. #1
    Benutzter Registrierer
    Registriert seit
    Feb 2004
    Beiträge
    2.263

    Hat wer ein BLFS mit KF5 lauffaehig bauen koennen?

    Moin,

    Seit ca. BLFS-7.10 versuch' ich immer mal wieder einen aktuellen KDE auf einem 64bit Linux (CPU: Celeron 867) zu bauen - da hab' ich aber schwer den Eindruck, dass da tierisch der Wurm drinnen ist, was aber wohl keinen wirklich zu kratzen scheint.
    Das Bauen laeuft ohne erkennbaren Fehler nach der Anleitung im BLFS-Book. Beim Startversuch von KDE kommt aber immer die hochsinnvolle Fehlermeldung: "all shell packages missing" im frisch eingeschalteten Graphikmodus (also xorg laeuft). Die kann man wegklicken, dann bleibt der Bildschirm halt schwarz mit Mauszeiger. Bis man ctrl-alt-backspace drueckt...
    Im dmesg ist's etwas ausfuehrlicher:

    [ 116.327004] ksplashqml[2173]: segfault at 0 ip 00007f8703bf9787 sp 00007ffc075180c0 error 4 in libQt5Core.so.5.9.1[7f8703940000+4da000]

    Kein Problem - mal gucken, was Google so ausspuckt... Tja und da siehts imho uebel aus:
    Alleine wenn ich schon ksplashqml in google tipper, schlaegt er mir "crashed" vor. Ansonsten: seit ca. 5 Jahren ziehen sich solche und aehnliche Fehlermeldungen quer durch alle Distributionen. Abhilfen mittlerweile aehnlich unqualifiziert wie bei Windowsfehlern: Irgendwann gings dann wieder, vielleicht nach 5x sudo apt-get gedoens, oder vielleicht wenn man ein Huhn schlachtet und den Rechner mit dem Blut einschmiert, keine Ahnung. Oder halt nen anderen Desktop nimmt...

    Hat irgendwer in letzter Zeit mal geschafft, ein funktionierenden KDE nach dem BLFS Book zu bauen?
    Wenn ja, auf was fuer einem System, wieviel Bit, etc.?


    Gruss
    WK
    Das ist aber zu viel zum Lesen und ich will, dass er einfach kompeliert!

  2. #2
    Elefantenversteher Avatar von florian0285
    Registriert seit
    Jun 2016
    Beiträge
    1.046
    BLFS vom 04.10.2017 beinhaltet qt 5.9.1.

    Google führt mich nach ein paar Duplikaten zu folgendem Bug:

    https://bugs.kde.org/show_bug.cgi?id=373628

    Dort wird das Problem mit 5.9.2-beta (jetzt wohl stable) gefixed.

    Hilfreich ist nebenbei der Stand von BLFS, da es auch eine 7.10 mit älteren Versionen z. B. 5.7.x gibt etc.

    Edith: Bin mit dem Auge abgerutscht. 5.9.1 ist in BLFS 8.1.
    Vielleicht mal das ganze Dokument updaten?
    Geändert von florian0285 (06.10.17 um 11:09 Uhr)
    Matthäus 7:3 Was siehst du aber den Splitter in deines Bruders Auge, und wirst nicht gewahr des Balkens in deinem Auge?

  3. #3
    Benutzter Registrierer
    Registriert seit
    Feb 2004
    Beiträge
    2.263
    Moin,

    Zitat Zitat von florian0285 Beitrag anzeigen
    BLFS vom 04.10.2017 beinhaltet qt 5.9.1.

    Google führt mich nach ein paar Duplikaten zu folgendem Bug:

    https://bugs.kde.org/show_bug.cgi?id=373628

    Dort wird das Problem mit 5.9.2-beta (jetzt wohl stable) gefixed.
    Hm. Sieht fuer mich jetzt nicht direkt nach "meinem" Bug aus. Ich komm ja nicht so weit, dass ich in systemsettings zum lock screen browsen koennte.


    Zitat Zitat von florian0285 Beitrag anzeigen
    Hilfreich ist nebenbei der Stand von BLFS, da es auch eine 7.10 mit älteren Versionen z. B. 5.7.x gibt etc.

    Edith: Bin mit dem Auge abgerutscht. 5.9.1 ist in BLFS 8.1.
    Vielleicht mal das ganze Dokument updaten?
    Was fuer'n Dokument?
    Ich hab' in den letzten Monaten immer mal wieder svn-Versionen von (B)LFS wie auch aktuelle Releases gebaut. Immer bei KDE ungefaehr das selbe Fehlerbild. Mit verschiedenen QT-Versionen; die auch noch mit verschiedenen compileroptionen und GCC 6.x, 7.0 und momentan 7.2.0 gebaut. Ich glaub, sogar einmal ein QT mit lvmm.
    Ich weiss nicht mal, ob's an KDE oder QT liegt. Und wenn ich mir die Menge an Fehlerreports mit diesen oder anderslautenden Meldungen - ja auch distributionsuebergreifend - anguck', dann seh' ich nur, dass diese Entwicklung, die ich seit KDE4 beobacht', immer weiter fortschreitet...das sagt mir nicht besonders zu.

    Der Witz an open-source ist, dass man's ja auch selbst nachbauen kann. Und das haut da einfach lange nicht mehr hin. Das behaupt' ich mal als jemand, der sich durchaus auch selber GNU-Octave oder auch KiCad erfolgreich zusammendengeln kann.

    Gruss
    WK
    Das ist aber zu viel zum Lesen und ich will, dass er einfach kompeliert!

  4. #4
    Elefantenversteher Avatar von florian0285
    Registriert seit
    Jun 2016
    Beiträge
    1.046
    Zitat Zitat von derguteweka Beitrag anzeigen
    Hm. Sieht fuer mich jetzt nicht direkt nach "meinem" Bug aus. Ich komm ja nicht so weit, dass ich in systemsettings zum lock screen browsen koennte.
    Ja wie gesagt ich bin nur ein paar Bug-Duplikaten gefolgt. Da muss die Ursache ja nicht zwangsweise die Selbe sein, wenn das gleiche "segfault" Resultat irgendwo als Duplikat markiert ist wäre es einen Versuch wert. Auf der anderen Seite gäbe es hier einen Patch https://bugs.kde.org/show_bug.cgi?id=376508 hört sich auch nicht "genau" nach deiner Fehlermeldung an. Aber der Bug wird hier verlinkt https://bugzilla.redhat.com/show_bug.cgi?id=1421167 was dann schon ähnlicher aussieht.

    Wenn ich nach "ksplashqml segfault libQt5Core.so.5.9.1" auf Google suche (also nicht die exakte Suche mit " ") bekomme ich 6 Ergebnisse. Darunter die zwei genannten Bugs. Die Ergebnisse sind recht neu und teilweise gerade mal ein Monat alt. Wenn du das Problem seit BLFS 7.10 hast kann es vielleicht sein, dass es andere (jetzt gelöste) Fehler waren und du jetzt nur mit einem neuen Problem konfrontiert wirst?

    Wenn du das nicht selbst debugen und fixen willst, dann bleibt dir eh nur die Wahl bei kde und qt die entsprechenden höheren Versionen zu testen. Oder auch eins runter.

    Was fuer'n Dokument?
    BLFS
    Mir wäre/war z. B. nicht zu 100% klar mit welcher Version du arbeitest.

    Der Witz an open-source ist, dass man's ja auch selbst nachbauen kann. Und das haut da einfach lange nicht mehr hin. Das behaupt' ich mal als jemand, der sich durchaus auch selber GNU-Octave oder auch KiCad erfolgreich zusammendengeln kann.
    Man muss das eben passend zusammenfixen. Dass das genug Arbeit ist zeigen doch die Distributionen, wenn die da Monate/Jahre rumfrickeln bis es stable ist. Man könnte sich das ja bequemer mit den SRC-Paketen bauen.
    Matthäus 7:3 Was siehst du aber den Splitter in deines Bruders Auge, und wirst nicht gewahr des Balkens in deinem Auge?

Ähnliche Themen

  1. MYSQL - Benutzer koennen nicht...
    Von nickelo im Forum Linux als Server
    Antworten: 27
    Letzter Beitrag: 15.07.08, 15:50
  2. BLFS (Installations fragen)
    Von Seleiah im Forum System installieren und konfigurieren
    Antworten: 5
    Letzter Beitrag: 02.05.06, 12:16
  3. BLFS: Problem mit Kerberos
    Von eAnic im Forum Sicherheit
    Antworten: 2
    Letzter Beitrag: 04.11.05, 22:17
  4. pcmcia module koennen nicht geladen werden
    Von cArN4g3 im Forum stationäre Hardware
    Antworten: 2
    Letzter Beitrag: 27.02.03, 08:25
  5. dsl - manche websites koennen nicht angezeigt werden!
    Von aloah_he im Forum Anbindung an die Aussenwelt
    Antworten: 10
    Letzter Beitrag: 13.10.02, 13:03

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •