Anzeige:
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 15 von 20

Thema: virtuelles Win7 nicht mehr mit SAMBA erreichbar

  1. #1
    Registrierter Benutzer
    Registriert seit
    Jan 2017
    Beiträge
    29

    virtuelles Win7 nicht mehr mit SAMBA erreichbar

    Hallo,

    ich habe unter KVM ein virtuelles Win7 pro laufen. Leider schaffe ich es nicht mehr, über Samba eine Netzwerkverbindung dahin aufzubauen. Ich brauche sie um aus dem virtuellen Win7 auf physische Partitionen zuzugreifen.

    Es hat bereits funktioniert, allerdings als Wicked das Netz verwaltet hat. Wegen Laptopbetrieb habe ich aber nun auf Network-Manager umgestellt, seitdem funktioniert auch das WLAN.

    Momentan kann:
    - das virtuelle Win7 auf einen ebenfalls anhängenden PC mit Win7 (auch pro) zugreifen
    - das virtuelle Win7 auf dem Netzwerkdrucker drucken
    - das virtuelle Win7 nicht das hostende Linux finden

    - das externe Win7 auf PC auf das virtuelle Win7 zugreifen
    - das externe Win7 auf Linux zugreifen
    - drucken von extern habe ich nicht probiert, ist denke ich weniger wichtig

    - Linux auf das externe Win7 zugreifen

    das für mich zunächst wichtigste, nämlich daß mein virtuelles Win7 pro über Samba -->Netzlaufwerke Zugriff auf die Festplatte hat und damit dessen Programme laufen bekomme ich einfach nicht hin.
    Da es ja unter Wicked funktionierte und Samba an sich auch funktioniert sollte es doch zu schaffen sein?
    Die beiden Rechner und der Drucker sind über die FritzBox verbunden.
    Dankbar für Hilfe,

    Frank
    Geändert von tryAga (13.05.17 um 20:47 Uhr)
    Dell Latitude 5420 Laptop - 4 x i5@2,5GHz - 8 GB RAM - 500 GB EvoPro SSD (Win7pro, SuSe Leap 42.2 mit KDE Plasma 5) - Intel HD Graphics 3000 GraKa

  2. #2
    Elefantenversteher Avatar von florian0285
    Registriert seit
    Jun 2016
    Beiträge
    1.047
    Wie ist denn das virtuelle Netzwerk konfiguriert?
    Matthäus 7:3 Was siehst du aber den Splitter in deines Bruders Auge, und wirst nicht gewahr des Balkens in deinem Auge?

  3. #3
    Registrierter Benutzer
    Registriert seit
    Jan 2017
    Beiträge
    29
    Hallo,
    hatte gerade einen kundigen Freund hier der mir geholfen hat.
    Es lag wohl daran daß sich beim Wechsel vom Wicked-Service zum Network-Manager die Netzwerkbrücke zerschossen hat.
    Habe in KVM eine Netzwerkbrücke hinzugefügt und sie der Maschine zur Verfügung gestellt, schon konnte man wieder pingen.
    Der Rest war dann Feinarbeit.

    Momentan habe ich die ganzen Partitionen unter Samba für so ziemlich alles und jeden freigegeben. Wollte erst mal nicht daß ein Zugriff daran scheitert.
    Habe mich schon ein wenig eingelesen, muss da aber noch rumprobieren. Nur eine Frage vielleicht hier noch:
    Ich passe das besser in der smb.conf an als über Dolphin-->Eigenschaften-->Freigabe, liege ich da richtig?

    Zunächst aufatmender Gruß,

    Frank
    Dell Latitude 5420 Laptop - 4 x i5@2,5GHz - 8 GB RAM - 500 GB EvoPro SSD (Win7pro, SuSe Leap 42.2 mit KDE Plasma 5) - Intel HD Graphics 3000 GraKa

  4. #4
    Registrierter Benutzer
    Registriert seit
    Jan 2017
    Beiträge
    29
    Es gibt ein "Follow-Up" mit neuer Frage:

    Die Verbindung Linux - Win7-virtuell funktioniert. Allerdings wird sie etwa alle 20s "teilgetrennt". Bedeutet:
    Win kann über die Netzlaufwerke nicht mehr auf die Daten zugreifen.
    Über Direkteingabe der Adresse in der Explorerleiste geht es, aber nur lesend (was möglicherweise der Grund ist daß der Zugriff über Netzlaufwerk nicht mehr funktioniert).
    Mit
    Code:
    dellffin:~ # service smb restart
    funktioniert es dan wieder für ca. 20s.
    Ich poste mal die /etc/samba/smb.conf:
    Code:
    [global]
        workgroup = LEAPSAMBA
        passdb backend = tdbsam
        printing = cups
        printcap name = cups
        printcap cache time = 750
        cups options = raw
        map to guest = Bad User
        logon path = \\%L\profiles\.msprofile
        logon home = \\%L\%U\.9xprofile
        logon drive = P:
        usershare allow guests = Yes
        add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
        domain logons = Yes
        domain master = No
        security = domain
        usershare max shares = 100
        wins support = Yes
        netbios name = SAMBALEAP
        idmap gid = 10000-20000
        idmap uid = 10000-20000
    #   von mir auskommentiert, da es keine /etc/samba/dhcp.conf gibt:
    #    include = /etc/samba/dhcp.conf
    
    [homes]
        comment = Home Directories
        valid users = %S, %D%w%S
        browseable = Yes
        read only = No
        inherit acls = Yes
        guest ok = Yes
    
    [profiles]
        comment = Network Profiles Service
        path = %H
        read only = No
        store dos attributes = Yes
        create mask = 0600
        directory mask = 0700
        guest ok = No
    
    [users]
        comment = All users
        path = /home
        read only = No
        inherit acls = Yes
        veto files = /aquota.user/groups/shares/
        guest ok = Yes
    
    [groups]
        comment = All groups
        path = /home/groups
        read only = No
        inherit acls = Yes
        guest ok = Yes
    
    [printers]
        comment = All Printers
        path = /var/tmp
        printable = Yes
        create mask = 0600
        browseable = No
        guest ok = No
    
    [print$]
        comment = Printer Drivers
        path = /var/lib/samba/drivers
        write list = @ntadmin root
        force group = ntadmin
        create mask = 0664
        directory mask = 0775
        guest ok = No
    
    [netlogon]
        comment = Network Logon Service
        path = /var/lib/samba/netlogon
        write list = root
        guest ok = No
    
    [daten]
        comment = Daten auf .mnt
        inherit acls = Yes
        path = /home/frank/.mnt/daten
        read only = No
        guest ok = Yes
    #    guest account = "\\MOBIDELL\Frank Admin"
    
    [medien]
        comment = Medien auf .mnt
        guest ok = Yes
        inherit acls = Yes
        path = /home/frank/.mnt/medien
        read only = No
    #    guest account = "\\MOBIDELL\Frank Admin"
    
    [Import]
        comment = /home/frank/Import
        guest ok = No
        inherit acls = Yes
        path = /home/frank/Import
        read only = No
    
    [mnt]
        comment = .mnt auf /home/frank
        guest ok = Yes
        inherit acls = Yes
        path = /home/frank/.mnt
        read only = No
    Und noch die ifconfig-Ausgabe:
    Code:
    dellffin:~ # ifconfig                                                                     
    lo        Link encap:Local Loopback                                                       
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:10850 errors:0 dropped:0 overruns:0 frame:0
              TX packets:10850 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1 
              RX bytes:1630334 (1.5 Mb)  TX bytes:1630334 (1.5 Mb)
    
    p6p1      Link encap:Ethernet  HWaddr D0:67:E5:3A:C9:43  
              inet addr:192.168.178.21  Bcast:192.168.178.255  Mask:255.255.255.0
              inet6 addr: fe80::d267:e5ff:fe3a:c943/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:2916 errors:0 dropped:0 overruns:0 frame:0
              TX packets:2246 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:659430 (643.9 Kb)  TX bytes:391768 (382.5 Kb)
              Interrupt:18 
    
    virbr0    Link encap:Ethernet  HWaddr 52:54:00:31:95:C4  
              inet addr:192.168.100.1  Bcast:192.168.100.255  Mask:255.255.255.0
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:238057 errors:0 dropped:0 overruns:0 frame:0
              TX packets:145503 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:56301898 (53.6 Mb)  TX bytes:286970065 (273.6 Mb)
    
    vnet0     Link encap:Ethernet  HWaddr FE:54:00:9E:4E:DC  
              inet6 addr: fe80::fc54:ff:fe9e:4edc/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:210596 errors:0 dropped:0 overruns:0 frame:0
              TX packets:254961 errors:0 dropped:1779 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:56256190 (53.6 Mb)  TX bytes:248643550 (237.1 Mb)
    
    wlan0     Link encap:Ethernet  HWaddr 08:11:96:56:83:A4  
              inet addr:192.168.178.25  Bcast:192.168.178.255  Mask:255.255.255.0
              inet6 addr: fe80::a11:96ff:fe56:83a4/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:5776 errors:0 dropped:0 overruns:0 frame:0
              TX packets:3653 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:1439388 (1.3 Mb)  TX bytes:653419 (638.1 Kb)
    virbr0 ist die Bridge über die die Verbindung zu KVM läuft.

    Freue mich sehr wenn ich das jetzt noch gebacken bekomme, ab dann ist mein neues Linux nämlich vollwertig praxistauglich.
    Dell Latitude 5420 Laptop - 4 x i5@2,5GHz - 8 GB RAM - 500 GB EvoPro SSD (Win7pro, SuSe Leap 42.2 mit KDE Plasma 5) - Intel HD Graphics 3000 GraKa

  5. #5
    Elefantenversteher Avatar von florian0285
    Registriert seit
    Jun 2016
    Beiträge
    1.047
    Was heißt "teilgetrennt" beendet smb die Verbindung oder wird die Brücke getrennt? Was sagen die Logs?
    Matthäus 7:3 Was siehst du aber den Splitter in deines Bruders Auge, und wirst nicht gewahr des Balkens in deinem Auge?

  6. #6
    Registrierter Benutzer
    Registriert seit
    Jan 2017
    Beiträge
    29
    Hallo Florian,

    Teilgetrennt heißt was ich unten sagte:

    Der Zugriff auf die Ordner ist für Win nur noch lesend möglich. Die in Win eingerichteten Netzlaufwerke funktionieren nicht mehr, im Explorer kann ich über -->Netzwerk->>MeinSambaNetBiosName auf Ordner und Dateien zugreifen, bekomme aber beim Öffen z.B. einer Office-Datei den Hinweis daß sie schreibgeschützt ist.
    Das ist für mich der Hinweis daß aus diesem Grund die Netzlaufwerke nicht mehr funktionieren.

    Die Brücke scheint mir nicht getrennt zu werden, denn beide Seiten lassen sich vom jeweils anderen mit Antwort anpingen (und auch lesender Zugriff ist ja noch möglich):
    Code:
    dellffin:~ # ping 192.168.100.193
    PING 192.168.100.193 (192.168.100.193) 56(84) bytes of data.
    64 bytes from 192.168.100.193: icmp_seq=1 ttl=128 time=0.475 ms
    64 bytes from 192.168.100.193: icmp_seq=2 ttl=128 time=0.532 ms
    64 bytes from 192.168.100.193: icmp_seq=3 ttl=128 time=0.453 ms
    ^C
    --- 192.168.100.193 ping statistics ---
    3 packets transmitted, 3 received, 0% packet loss, time 1999ms
    rtt min/avg/max/mdev = 0.453/0.486/0.532/0.041 ms
    Der Ping aus Win zur Brücke mit 192.168.100.1 funktioniert auch.

    Ich bin blutiger Anfänger, deshalb weiß ich nicht welche Logs in Frage kommen und wo sie sind. Stelle ich gerne ein wenn ich einen Hinweis bekomme.
    Ausgeführt habe ich:

    Während die Verbindung voll in Ordnung ist (Netzlaufwerke ok, Schreibzugriff ok):

    Code:
    dellffin:~ # service smb status
    ● smb.service - Samba SMB Daemon
       Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled; vendor preset: disabled)
       Active: active (running) since Tue 2017-05-16 12:12:22 CEST; 2min 38s ago
      Process: 3379 ExecStartPre=/usr/share/samba/update-apparmor-samba-profile (code=exited, status=0/SUCCESS)
     Main PID: 3389 (smbd)
       Status: "smbd: ready to serve connections..."
        Tasks: 5 (limit: 512)
       CGroup: /system.slice/smb.service
               ├─3389 /usr/sbin/smbd -D
               ├─3390 /usr/sbin/smbd -D
               ├─3391 /usr/sbin/smbd -D
               ├─3394 /usr/sbin/smbd -D
               └─3398 /usr/sbin/smbd -D
    
    May 16 12:12:21 dellffin.mobilin systemd[1]: Starting Samba SMB Daemon...
    May 16 12:12:22 dellffin.mobilin systemd[1]: smb.service: Supervising process 3389 which is not our child. We'll most likely not notice when it exits.
    May 16 12:12:22 dellffin.mobilin smbd[3389]: [2017/05/16 12:12:22.152232,  0] ../lib/util/become_daemon.c:124(daemon_ready)
    May 16 12:12:22 dellffin.mobilin smbd[3389]:   STATUS=daemon 'smbd' finished starting up and ready to serve connections
    May 16 12:12:22 dellffin.mobilin systemd[1]: Started Samba SMB Daemon.
    Wenn die Verbindung nur noch auf Lesemodus ist / Netzlaufwerke nicht mehr funktionieren:

    Code:
    dellffin:~ # service smb status
    ● smb.service - Samba SMB Daemon
       Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled; vendor preset: disabled)
       Active: active (running) since Tue 2017-05-16 12:28:11 CEST; 9min ago
      Process: 3818 ExecStartPre=/usr/share/samba/update-apparmor-samba-profile (code=exited, status=0/SUCCESS)
     Main PID: 3826 (smbd)
       Status: "smbd: ready to serve connections..."
        Tasks: 5 (limit: 512)
       CGroup: /system.slice/smb.service
               ├─3826 /usr/sbin/smbd -D
               ├─3827 /usr/sbin/smbd -D
               ├─3828 /usr/sbin/smbd -D
               ├─3832 /usr/sbin/smbd -D
               └─3834 /usr/sbin/smbd -D
    
    May 16 12:37:20 dellffin.mobilin smbd[3834]: [2017/05/16 12:37:20.173422,  0] ../source3/smbd/service.c:723(make_connection_snum)
    May 16 12:37:20 dellffin.mobilin smbd[3834]:   canonicalize_connect_path failed for service groups, path /home/groups
    May 16 12:37:23 dellffin.mobilin smbd[3834]: [2017/05/16 12:37:23.425187,  0] ../source3/smbd/service.c:723(make_connection_snum)
    May 16 12:37:23 dellffin.mobilin smbd[3834]:   canonicalize_connect_path failed for service groups, path /home/groups
    May 16 12:37:23 dellffin.mobilin smbd[3834]: [2017/05/16 12:37:23.426138,  0] ../source3/smbd/service.c:723(make_connection_snum)
    May 16 12:37:23 dellffin.mobilin smbd[3834]:   canonicalize_connect_path failed for service groups, path /home/groups
    May 16 12:37:25 dellffin.mobilin smbd[3834]: [2017/05/16 12:37:25.574724,  0] ../source3/smbd/service.c:723(make_connection_snum)
    May 16 12:37:25 dellffin.mobilin smbd[3834]:   canonicalize_connect_path failed for service groups, path /home/groups
    Wie gesagt, poste gerne weitere Logs wenn das hilft und wenn ich weiß welche.

    Danke, Frank
    Dell Latitude 5420 Laptop - 4 x i5@2,5GHz - 8 GB RAM - 500 GB EvoPro SSD (Win7pro, SuSe Leap 42.2 mit KDE Plasma 5) - Intel HD Graphics 3000 GraKa

  7. #7
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Ort
    Sauerland
    Beiträge
    940

  8. #8
    Registrierter Benutzer
    Registriert seit
    Jan 2017
    Beiträge
    29
    Daran liegt es leider nicht.

    Ich habe den Windows-Nutzernamen (in Windows) jetzt so geändert daß er mit dem Linux-Benutzernamen identisch ist, mit ebenfalls identischem Passwort. Das sollte für Samba schon mal hilfreich sein.

    Dann habe ich die Verzeichnisse, so weit es ging, umberechtigt:

    Code:
    ]dellffin:/home/frank # ls -l | grep ff
    drwxrwxrwx  5 frank ffheimnetz   4096 May  3 03:50 .mnt
    drwxr-xr-x  2 frank users        4096 Apr 24 04:36 Öffentlich
    frank ist auch Mitglied in ffheimnetz.
    Er ist sowohl der angemeldete Linux-user als auch der aktuelle Win7-user.

    Die eigentlichen Mountpunkte lassen sich hinsichtlich Benutzer- / Gruppenzugehörigkeit nicht bearbeiten:

    Code:
    dellffin:/home/frank # cd .mnt
    dellffin:/home/frank/.mnt # ls -l
    total 36
    drwxrwxrwx 1 root root  4096 May 16 15:15 daten
    drwxrwxrwx 1 root root  4096 May  9 16:43 medien
    drwxrwxrwx 1 root root 28672 May  9 16:43 os
    dellffin:/home/frank/.mnt # chown -v frank:ffheimnetz daten
    changed ownership of 'daten' from root:root to frank:ffheimnetz
    dellffin:/home/frank/.mnt # ls -l
    total 36
    drwxrwxrwx 1 root root  4096 May 16 15:15 daten
    drwxrwxrwx 1 root root  4096 May  9 16:43 medien
    drwxrwxrwx 1 root root 28672 May  9 16:43 os
    dellffin:/home/frank/.mnt # chgrp -v ffheimnetz daten
    changed group of 'daten' from root to ffheimnetz
    dellffin:/home/frank/.mnt # ls -l
    total 36
    drwxrwxrwx 1 root root  4096 May 16 15:15 daten
    drwxrwxrwx 1 root root  4096 May  9 16:43 medien
    drwxrwxrwx 1 root root 28672 May  9 16:43 os
    Liegt das daran daß es gemountete Partitionen sind?
    Dell Latitude 5420 Laptop - 4 x i5@2,5GHz - 8 GB RAM - 500 GB EvoPro SSD (Win7pro, SuSe Leap 42.2 mit KDE Plasma 5) - Intel HD Graphics 3000 GraKa

  9. #9
    Elefantenversteher Avatar von florian0285
    Registriert seit
    Jun 2016
    Beiträge
    1.047
    poste mal

    Code:
    ls -l /home
    mount

    Die entsprechenden Anmeldedaten kannst du bei Windows eigentlich hinterlegen, da musst du nicht unbedingt Username + Password anpassen.

    Mal doof gefragt das anlegen von Dateien unter Linux funktioniert in den Pfaden einwandfrei?
    Geändert von florian0285 (17.05.17 um 11:14 Uhr)
    Matthäus 7:3 Was siehst du aber den Splitter in deines Bruders Auge, und wirst nicht gewahr des Balkens in deinem Auge?

  10. #10
    Registrierter Benutzer
    Registriert seit
    Jan 2017
    Beiträge
    29
    Code:
    dellffin:~ # ls -l /home
    total 28
    drwx------  4 root  root   4096 May 17 12:48 .Trash-0
    drwxr-xr-x 33 frank users  4096 May 17 12:53 frank
    drwxrwxrwx  2 root  root   4096 May 16 12:47 groups
    drwx------  2 root  root  16384 Apr 24 04:18 lost+found
    Der erste Eintrag rührt wohl daher daß ich einen User gelöscht habe und seinen home-account dann per Dolphin in den Papierkorb verfrachtet habe.

    Code:
    dellffin:~ # mount
    sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
    proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
    devtmpfs on /dev type devtmpfs (rw,nosuid,size=4025920k,nr_inodes=1006480,mode=755)
    securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
    tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
    devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
    tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)
    tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
    cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/usr/lib/systemd/systemd-cgroups-agent,name=systemd)
    pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
    cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
    cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
    cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
    cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
    cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
    cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
    cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
    cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
    cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
    cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
    /dev/sda7 on / type ext3 (rw,relatime,data=ordered)
    systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=25,pgrp=1,timeout=0,minproto=5,maxproto=5,direct)
    mqueue on /dev/mqueue type mqueue (rw,relatime)
    hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)                             
    debugfs on /sys/kernel/debug type debugfs (rw,relatime)                              
    /dev/sda8 on /home type ext3 (rw,nosuid,nodev,noexec,relatime,data=ordered,user)     
    fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
    /dev/sda5 on /home/frank/.mnt/daten type fuseblk (rw,nosuid,nodev,noexec,relatime,user_id=0,group_id=0,allow_other,blksize=4096,user)
    /dev/sda3 on /home/frank/.mnt/os type fuseblk (rw,nosuid,nodev,noexec,relatime,user_id=0,group_id=0,allow_other,blksize=4096,user)
    /dev/sda6 on /home/frank/.mnt/medien type fuseblk (rw,nosuid,nodev,noexec,relatime,user_id=0,group_id=0,allow_other,blksize=4096,user)
    tmpfs on /run/user/477 type tmpfs (rw,nosuid,nodev,relatime,size=806672k,mode=700,uid=477,gid=475)
    tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=806672k,mode=700,uid=1000,gid=100)
    gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=100)
    Die Partitionen sind ganz unten im Listing, /dev/sda 3, 5 und 6

    Mal doof gefragt das anlegen von Dateien unter Linux funktioniert in den Pfaden einwandfrei?
    Einwandfrei und nie Probleme. Selbst Thunderbird, Firefox und LibreOffice greifen auf die Pfade als Arbeitsverzeichnisse permanent und problemlos zu, Letzteres auch mit Makro-Funktionalitäten.

    Die entsprechenden Anmeldedaten kannst du bei Windows eigentlich hinterlegen, da musst du nicht unbedingt Username + Password anpassen.
    Nachdem es virtuell ist bin ich da zunächst nicht soo heikel. Bis ich die Win-Kommandozeilensyntax raushabe dauert es deutlich länger.
    Geändert von tryAga (17.05.17 um 13:05 Uhr)
    Dell Latitude 5420 Laptop - 4 x i5@2,5GHz - 8 GB RAM - 500 GB EvoPro SSD (Win7pro, SuSe Leap 42.2 mit KDE Plasma 5) - Intel HD Graphics 3000 GraKa

  11. #11
    Elefantenversteher Avatar von florian0285
    Registriert seit
    Jun 2016
    Beiträge
    1.047
    Setze bei den relevanten Shares

    Code:
    writeable = yes
    oder
    write list = userX userY
    Geändert von florian0285 (22.05.17 um 10:36 Uhr)
    Matthäus 7:3 Was siehst du aber den Splitter in deines Bruders Auge, und wirst nicht gewahr des Balkens in deinem Auge?

  12. #12
    Registrierter Benutzer
    Registriert seit
    Jan 2017
    Beiträge
    29
    Das bringt leider Beides Nichts.

    Habe im Win mit
    Code:
    net view \\arbeitsgruppe
    nachgesehen: Alle freigegebenen Ordner sind gelistet. Es scheint also nicht an der Netzwerkverbindung zu liegen, und Samba gibt die Orte nach wie vor in die Welt. Aber der Zugriff wird verweigert bis ich
    Code:
    service smb restart
    eingebe.

    Wo kann der Hänger sein?

    Es gibt auch keine deutlich zeitabhängiges Schema. Manchmal kann ich zwei Minuten zugreifen, manchmal nur 10 sek.

    Gibt es eigentlich einen Unterschied zwischen

    service [smb | nmb] [stop | start | restart] und

    [rcsmb | rcnmb] [stop | start | restart] ?
    Geändert von tryAga (19.05.17 um 13:34 Uhr)
    Dell Latitude 5420 Laptop - 4 x i5@2,5GHz - 8 GB RAM - 500 GB EvoPro SSD (Win7pro, SuSe Leap 42.2 mit KDE Plasma 5) - Intel HD Graphics 3000 GraKa

  13. #13
    Elefantenversteher Avatar von florian0285
    Registriert seit
    Jun 2016
    Beiträge
    1.047
    Funktioniert der Zugriff denn jetzt vollständig oder nur lesend?

    Ich würde mal eine andere VM aufsetzen oder ne LiveCD in der VMbbooten und es mal unabhängig von diesem Windows testen.

    Was mir noch einfällt, wenn du bei Win mal falsche Daten hinterlegt hast versucht Win mehrmals sich damit zu authentifiizieren. Bei ner AD hat das den Effekt, dass der User dann nach 3x falsch "eingeloggt" gesperrt wird. Vielleicht schaust du doch mal in diesen Credentials Manager und löscht die gespeicherten Daten und gibst sie neu ein.
    Matthäus 7:3 Was siehst du aber den Splitter in deines Bruders Auge, und wirst nicht gewahr des Balkens in deinem Auge?

  14. #14
    Registrierter Benutzer
    Registriert seit
    Jan 2017
    Beiträge
    29
    Funktioniert der Zugriff denn jetzt vollständig oder nur lesend?
    Nach smb und nmb restart zunächst vollständig, nach einer Weile dann nur lesend. Ab da ist über Netzlaufwerke aus Win keine Kommunikation mehr möglich, geöffnete Datenbanken streiken, über Explorer --> Netzwerk --> Arbeitsgruppe kann noch gelesen werden, sonst Fehler "fehlende Schreibrechte".

    Ich würde mal eine andere VM aufsetzen oder ne LiveCD in der VMbbooten und es mal unabhängig von diesem Windows testen.
    Laptop, Platte geht gegen Anschlag, und es ist meine Arbeitsumgebung (Baumpflegebetrieb). Kannst Du mir was Schlankes empfehlen das sich selber mit Samba leicht tut?

    Was mir noch einfällt, wenn du bei Win mal falsche Daten hinterlegt hast versucht Win mehrmals sich damit zu authentifiizieren. Bei ner AD hat das den Effekt, dass der User dann nach 3x falsch "eingeloggt" gesperrt wird. Vielleicht schaust du doch mal in diesen Credentials Manager und löscht die gespeicherten Daten und gibst sie neu ein.
    (1) Credentials Manager = Anmeldeinformationsverwaltung: Keine Einträge vorhanden.
    (2) "Bei ner AD ...": Mir ist das schon über den Weg gelaufen, habe für mich nur gespeichert daß eine "AD" eine Form von Anmeldeverwaltung ist und bei mir nicht vorliegt. Sorry, bin ganz frisch im Metier Linux, ist großer Lernaufwand. Oder muss ich die "AD" haben? Lös doch bitte die Abkürzung noch mal für mich auf, wenn ich nach "AD" im Netz suche... ...oder nochmal diverse Samba-Manuals durchstudiere bis ich draufstosse... ... Danke.
    (3) Wo finde ich denn in Linux eine Datei mit den zulässigen Nutzern?

    Ansonsten: Komme langsam weiter, was zunächst für mich meine Linux-Umgebung wieder brauchbarer macht (ich brauche ein paar Datenbanken und Programme von Windows im Alltag permanent), der aktuelle Zustand ist:

    - Ich hatte vorhin zuhause eine Stunde lang Vollzugriff ohne Absturz. Hatte mich sehr gefreut.
    - Bin dann ins Büro. Sofort ausprobiert. Nach < 1 Minute wieder nur Lesezugriff.
    - >sudo smb restart; sudo nmb restart --> seitdem, das ist nun 45 Minuten her, wieder keine Trennung.
    - positiv: immerhin geht es manchmal; negativ: nicht reproduzierbare Fehler sind noch schwerer einzugrenzen. Und ich möchte ehrlich gesagt nicht nur daß es funktioniert sondern auch wissen und verstehen wie und warum (also auch: es vorher nicht funktioniert hat).

    - Folgendes hatte ich in der smb.conf geändert:
    [global] --> username level = 9 # Anzahl Permutationen Ersetzung Klein- durch Großbuchstaben
    [daten-verzeichnis] --> browseable = Yes # eingefügt, browseable-Attribut war vorher gar nicht explizit vorhanden

    Status also: Da ist noch Arbeit für mich. Besonders wichtig: In dieser Konfiguration ist mein Rechner via Samba ungefähr so geschützt wie die Startseite von Google. Das geht auf Dauer gar nicht. Da werde ich nun der Reihe nach Parameter Richtung Sicherheit verändern und jeweils gucken wie es sich dann verhält. "browseable" würde ich eigentlich gerne auf "no" setzen... wir werden sehen.

    Sehr positiv: Daß Du Dich immer wieder unterstützend meldest und mir zur Seite stehst, das ist extrem motivierend.

    ####### Danke #######

    Frank
    Geändert von tryAga (19.05.17 um 17:14 Uhr)
    Dell Latitude 5420 Laptop - 4 x i5@2,5GHz - 8 GB RAM - 500 GB EvoPro SSD (Win7pro, SuSe Leap 42.2 mit KDE Plasma 5) - Intel HD Graphics 3000 GraKa

  15. #15
    Registrierter Benutzer
    Registriert seit
    Jan 2017
    Beiträge
    29
    Könnte es damit zu tun haben:

    Code:
    dellffin:~ # wbinfo -m
    failed to call wbcListTrusts: WBC_ERR_WINBIND_NOT_AVAILABLE
    Could not list trusted domains
    -- das ist aber auch mit AD verbunden ? --

    und das hier habe ich noch entdeckt, das scheint mir doch ein zentraler Baustein zu sein:

    Code:
    dellffin:~ # service nmb status
    ● nmb.service - Samba NMB Daemon
       Loaded: loaded (/usr/lib/systemd/system/nmb.service; enabled; vendor preset: disabled)
       Active: active (running) since Fri 2017-05-19 15:38:58 CEST; 2h 7min ago                                               
     Main PID: 3021 (nmbd)                                                                                                    
       Status: "nmbd: ready to serve connections..."                                                                          
        Tasks: 2 (limit: 512)
       CGroup: /system.slice/nmb.service
               ├─3021 /usr/sbin/nmbd -D
               └─3022 /usr/sbin/nmbd -D
    
    May 19 17:24:38 dellffin.mobilin nmbd[3021]:   Unable to find the Domain Master Browser name LEAPSAMBA<1b> for the workgroup LEAPSAMBA.
    May 19 17:24:38 dellffin.mobilin nmbd[3021]:   Unable to sync browse lists in this workgroup.
    May 19 17:39:47 dellffin.mobilin nmbd[3021]: [2017/05/19 17:39:47.372656,  0] ../source3/nmbd/nmbd_browsesync.c:354(find_domain_master_name_query_fail)
    May 19 17:39:47 dellffin.mobilin nmbd[3021]:   find_domain_master_name_query_fail:
    May 19 17:39:47 dellffin.mobilin nmbd[3021]:   Unable to find the Domain Master Browser name LEAPSAMBA<1b> for the workgroup LEAPSAMBA.
    May 19 17:39:47 dellffin.mobilin nmbd[3021]:   Unable to sync browse lists in this workgroup.
    May 19 17:39:47 dellffin.mobilin nmbd[3021]: [2017/05/19 17:39:47.372861,  0] ../source3/nmbd/nmbd_browsesync.c:354(find_domain_master_name_query_fail)
    May 19 17:39:47 dellffin.mobilin nmbd[3021]:   find_domain_master_name_query_fail:
    May 19 17:39:47 dellffin.mobilin nmbd[3021]:   Unable to find the Domain Master Browser name LEAPSAMBA<1b> for the workgroup LEAPSAMBA.
    May 19 17:39:47 dellffin.mobilin nmbd[3021]:   Unable to sync browse lists in this workgroup.
    Allerdings habe ich keine Idee wo und wie genau ich das behebe. In der smb.conf ist "domain master = No". Setze ich das auf "Yes" bricht die Verbindung sofort ab. Verlasse ich in YaST --> Samba mit "Ok" kommt ein Fenster "Beitritt zur Domäne LEAPSAMBA" - das scheitert stets mit der Fehlermeldung daß kein "DC" (wohl der Domänencontroller) gefunden werden kann.
    Fehlt vielleicht ein Baustein völlig?

    Allerdings: Trotzdem seit 1 3/4 h stabile Verbindung.
    Geändert von tryAga (19.05.17 um 18:19 Uhr)
    Dell Latitude 5420 Laptop - 4 x i5@2,5GHz - 8 GB RAM - 500 GB EvoPro SSD (Win7pro, SuSe Leap 42.2 mit KDE Plasma 5) - Intel HD Graphics 3000 GraKa

Ähnliche Themen

  1. Samba als PDC nicht erreichbar
    Von Lauchhammer im Forum Linux in heterogenen Netzen
    Antworten: 4
    Letzter Beitrag: 30.04.13, 16:11
  2. Nach grub-Update startet Win7 nicht mehr
    Von dertaliesin im Forum Linux Allgemein
    Antworten: 0
    Letzter Beitrag: 11.05.12, 19:41
  3. GRUB bootet Win7 nicht mehr!
    Von VadimH. im Forum System installieren und konfigurieren
    Antworten: 17
    Letzter Beitrag: 18.04.10, 18:53
  4. Samba Server nicht mehr sicht-/erreichbar
    Von mellowman im Forum Linux in heterogenen Netzen
    Antworten: 3
    Letzter Beitrag: 10.07.07, 09:02
  5. Samba nicht erreichbar.
    Von NeoR7 im Forum Linux als Server
    Antworten: 3
    Letzter Beitrag: 18.10.02, 13:30

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •