Anzeige:
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 15 von 17

Thema: Keine Verbindung zu Samba-Share nach Update von 42.2 nach 42.3

  1. #1
    Registrierter Benutzer
    Registriert seit
    Mar 2005
    Beiträge
    1.312

    Keine Verbindung zu Samba-Share nach Update von 42.2 nach 42.3

    Hallo zusammen,

    Ich habe seit ca. 7 Jahren ein Samba-Share auf meinem Server laufen, dass durch die verschiedenen Versionen von Suse hindurch gut funktioniert hat.
    Auch unter 42.2. Vorgestern habe ich nun auf 42.3 umgestellt:
    - Alle 42.2 Updates eingespielt
    - Repository URLs angepasst auf 42.3
    - zypper clean -a
    - zypper ref
    - zypper dup

    Das Update ist gut durch gelaufen und das System auch gut gebootet.
    NFS Zugriff und SH funktionieren auch wie gewohnt.

    Wenn ich mich jetzt aber von Windows aus auf das Samba-Share verbinden will behauptet Windows, dass user oder Passwort falsch seien und ich keinen Zugriff hätte.

    Ich habe auf dem Server daraufhin mit smbpasswd zunächst den user gelöscht, dann neu hinzugefügt, enabled und das Passwort auf den bisherigen Wert gesetzt.
    Dennoch bekomme ich in Windows beim Verbindungsversuch die Fehlermeldung "Passwort falsch".

    Geprüft habe ich /var/log/samba, aber da stehen keine Fehler zu Logins drin.

    Hat jemand mit der Umstellung auf 42.3 ähnliche Probleme gehabt und kann mir einen Tipp geben?
    Wo genau kann ich auf Serverseite herausfinden, was das Problem ist? Kann ih den Loglevel des smbd erhöhen? wo mache ich das?

    Danke und Gruß,
    Martin
    Server: i5-4430, 12GB, openSUSE 13.1
    Workstation: i7-960, 12GB, openSUSE 13.1

  2. #2
    Registrierter Benutzer
    Registriert seit
    Sep 2003
    Beiträge
    2.966
    Zitat Zitat von smartysmart34 Beitrag anzeigen
    Wo genau kann ich auf Serverseite herausfinden, was das Problem ist? Kann ih den Loglevel des smbd erhöhen? wo mache ich das?
    abschnitt: log level: https://www.samba.org/samba/docs/man...mb.conf.5.html

    ansonsten poste deine config [ global ]
    ....

  3. #3
    Registrierter Benutzer
    Registriert seit
    May 2001
    Ort
    Rülzheim
    Beiträge
    55
    Hallo,

    ich hatte Leap 42.3 komplett neu installiert, aber meine alte smb.conf übernommen.

    Diverse Spielereien mit der Firewall (smbclient ...) führten nicht zum Ziel bis ich auf die Idee kam, dass die User-Datenbank noch nicht eingerichtet war.

    Kontrolle mit: pdbedit -L

    User anlegen mit: smbpasswd -a <username> # Fügt den Benutzer <username> der Samba Datenbank hinzu und aktiviert diesen

    Grüße bmk

  4. #4
    Registrierter Benutzer
    Registriert seit
    Mar 2005
    Beiträge
    1.312
    Code:
    pdbedit -L
    annika:1003:Annika
    natalia:1001:Natalia Soltau
    martin:1000:Martin Soltau
    User sind also da.
    Passwörter hab ich auch nochmal neu gesetzt.

    Config (Es geht um das Fileshare ganz unten):

    Code:
    # smb.conf is the main Samba configuration file. You find a full commented
    # version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
    # samba-doc package is installed.
    [global]
            workgroup = WORKGROUP
            passdb backend = tdbsam
            printing = cups
            printcap name = cups
            printcap cache time = 750
            cups options = raw
            map to guest = Bad User
            include = /etc/samba/dhcp.conf
            logon path = \\%L\profiles\.msprofile
            logon home = \\%L\%U\.9xprofile
            logon drive = P:
            usershare allow guests = No
            add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
            domain logons = No
            domain master = No
            security = user
            wins support = No
            idmap gid = 10000-20000
            idmap uid = 10000-20000
    
    ## Share disabled by YaST
    # [homes]
    #       comment = Home Directories                                                                                                                                               
    #       valid users = %S, %D%w%S                                                                                                                                                 
    #       browseable = No                                                                                                                                                          
    #       read only = No                                                                                                                                                           
    #       inherit acls = Yes                                                                                                                                                       
                                                                                                                                                                                     
    ## Share disabled by YaST                                                                                                                                                        
    # [profiles]                                                                                                                                                                     
    #       comment = Network Profiles Service                                                                                                                                       
    #       path = %H                                                                                                                                                                
    #       read only = No                                                                                                                                                           
    #       store dos attributes = Yes                                                                                                                                               
    #       create mask = 0600                                                                                                                                                       
    #       directory mask = 0700                                                                                                                                                    
                                                                                                                                                                                     
    ## Share disabled by YaST                                                                                                                                                        
    # [users]                                                                                                                                                                        
    #       comment = All users                                                                                                                                                      
    #       path = /home                                                                                                                                                             
    #       read only = No                                                                                                                                                           
    #       inherit acls = Yes                                                                                                                                                       
    #       veto files = /aquota.user/groups/shares/                                                                                                                                 
    
    ## Share disabled by YaST
    # [groups]
    #       comment = All groups
    #       path = /home/groups
    #       read only = No
    #       inherit acls = Yes
    
    ## Share disabled by YaST
    # [printers]
    #       comment = All Printers
    #       path = /var/tmp
    #       printable = Yes
    #       create mask = 0600
    #       browseable = No
    
    ## Share disabled by YaST
    # [print$]
    #       comment = Printer Drivers
    #       path = /var/lib/samba/drivers
    #       write list = @ntadmin root
    #       force group = ntadmin
    #       create mask = 0664
    #       directory mask = 0775
    
    ## Share disabled by YaST
    # [netlogon]
    
    [serverdata]
            comment = serverdata
    #       inherit acls = Yes
            path = /mnt/local/fileshares/public
            read only = No
            guest ok = Yes
            browsable = Yes
            writable = Yes
    Server: i5-4430, 12GB, openSUSE 13.1
    Workstation: i7-960, 12GB, openSUSE 13.1

  5. #5
    Registrierter Benutzer
    Registriert seit
    May 2001
    Ort
    Rülzheim
    Beiträge
    55
    Hallo Martin,

    stimmen der Pfad und auch noch die Userrechte noch ?

    path = /mnt/local/fileshares/public
    Gruß bmk

  6. #6
    Registrierter Benutzer
    Registriert seit
    Mar 2005
    Beiträge
    1.312
    Der Pfad hat sich nicht geändert und in dem Fall gehört das Verzeichnis und alle Unterverzeichnisse dem User martin, mit dem ich mich auch von Windows aus verbinden will...
    Server: i5-4430, 12GB, openSUSE 13.1
    Workstation: i7-960, 12GB, openSUSE 13.1

  7. #7
    Registrierter Benutzer
    Registriert seit
    Sep 2003
    Beiträge
    2.966
    poste die logs, dann hast weisst du wo das problem ist...
    ansonsten koennen wir "nur" raten...


    log level = 3
    log file = /var/log/samba/log.%m
    ....

  8. #8
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    20.391
    Ansonsten lohnt es sich auch immer mal, direkt von der Konsole aus den Share zu mounten - da bekommt man ggf. auch hilfreiche Infos.

    Welche Windows-Version verwendest Du denn?
    Ich bin root - ich darf das.

  9. #9
    Registrierter Benutzer
    Registriert seit
    May 2001
    Ort
    Rülzheim
    Beiträge
    55
    Stimmen die Firewall-Einstellungen ?
    Zugriff bei abgeschalteter FW möglich ?
    Ansonsten: Logging einschalten und Log-Files untersuchen

    Gruß bmk

  10. #10
    Registrierter Benutzer
    Registriert seit
    Mar 2005
    Beiträge
    1.312
    Zitat Zitat von muell200 Beitrag anzeigen
    poste die logs, dann hast weisst du wo das problem ist...
    ansonsten koennen wir "nur" raten...
    sehe ich das richtig, dass diese Einträge in den [global] Abschnitt der smbd.conf kommen?

    Danke und Gruß,
    Martin
    Server: i5-4430, 12GB, openSUSE 13.1
    Workstation: i7-960, 12GB, openSUSE 13.1

  11. #11
    Registrierter Benutzer
    Registriert seit
    Mar 2005
    Beiträge
    1.312
    Zitat Zitat von marce Beitrag anzeigen
    Ansonsten lohnt es sich auch immer mal, direkt von der Konsole aus den Share zu mounten - da bekommt man ggf. auch hilfreiche Infos.

    Welche Windows-Version verwendest Du denn?
    Ich habe mich bisher (vor dem 42.3 update) erfolgreich von Windows 7 und Windows 10 auf das Share verbunden
    Server: i5-4430, 12GB, openSUSE 13.1
    Workstation: i7-960, 12GB, openSUSE 13.1

  12. #12
    Registrierter Benutzer
    Registriert seit
    Sep 2003
    Beiträge
    2.966
    Zitat Zitat von smartysmart34 Beitrag anzeigen
    sehe ich das richtig, dass diese Einträge in den [global] Abschnitt der smbd.conf kommen?
    ja und wie @marce schon geschrieben hat - welche windows version?
    ....

  13. #13
    Registrierter Benutzer
    Registriert seit
    Mar 2005
    Beiträge
    1.312
    Zitat Zitat von muell200 Beitrag anzeigen
    ja und wie @marce schon geschrieben hat - welche windows version?
    Siehe #11

    Gruß,
    Martin
    Server: i5-4430, 12GB, openSUSE 13.1
    Workstation: i7-960, 12GB, openSUSE 13.1

  14. #14
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Ort
    Sauerland
    Beiträge
    891

  15. #15
    Registrierter Benutzer
    Registriert seit
    Mar 2005
    Beiträge
    1.312
    Ich komme zwar wahrscheinlich erst morgen dazu, das auszuprobieren, aber das sieht ziemlich genau nach meinem Thema aus.... Vieln Dank dafür!
    Gruß,
    Martin
    Server: i5-4430, 12GB, openSUSE 13.1
    Workstation: i7-960, 12GB, openSUSE 13.1

Ähnliche Themen

  1. Suse 11.4 nach Samba Update keine Shares mehr
    Von Starfoxfs im Forum System installieren und konfigurieren
    Antworten: 14
    Letzter Beitrag: 25.11.11, 16:47
  2. Keine Verbindung nach aussen.
    Von Vasilli im Forum System installieren und konfigurieren
    Antworten: 2
    Letzter Beitrag: 06.02.06, 15:43
  3. Antworten: 1
    Letzter Beitrag: 05.08.05, 09:30
  4. Samba: nach Update keine Schreibrechte
    Von DiWoWo im Forum Linux in heterogenen Netzen
    Antworten: 3
    Letzter Beitrag: 19.08.04, 12:47
  5. nach update auf kde3.0.3 keine verbindung mit kppp mehr!
    Von DarkTron im Forum Anbindung an die Aussenwelt
    Antworten: 1
    Letzter Beitrag: 21.08.02, 19:03

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •