Anzeige:
Ergebnis 1 bis 8 von 8

Thema: Debian verschluckt nach Upgrade auf Strech smb: Freigaben

Hybrid-Darstellung

Vorheriger Beitrag Vorheriger Beitrag   Nächster Beitrag Nächster Beitrag
  1. #1
    Registrierter Benutzer
    Registriert seit
    Jul 2017
    Beiträge
    5

    Lightbulb [gelöst] - Debian verschluckt nach Upgrade auf Strech smb: Freigaben

    Hallo liebe Gemeinde,

    zunächst erstmal vielen Dank für die Aufnahme.
    Ich habe in Linux durchaus gesundes Halbwissen. Daher bitte ich, mir nachzusehen, dass ich hier nicht mit Fachbegriffen rumwerfe.
    Sofern irgendwelche Logs oder was benötigt werden, bitte ich um Info.

    Hier mein Problem:

    Bei mir stehen zwei Synology DiskStations, welche beide Netzwerkfreigaben im Heimnetz bereit stellen.

    ich habe nach dem Upgrade von Debian 8 auf Debian 9 nun das Problem, dass sich diese Freigaben in Nautilus weder in VirtualBox finden lassen, noch kann ich Dateianhänge z.B. in Thunderbird von der Freigabe suchen/anhängen.

    ich habe einige Virtuelle Maschinen auf einer der Freigaben und bis zum Upgrade gab es da keine Probleme, diese dann in VirtualBox einzubinden.

    Meien Vermutung ist, dass es mit der Namensauflösung zu tun hat, denn ich kann die smb: Freigben auch nur noch über die IP-Adresse einbinden, nicht mehr über den server-Namen.
    Aber auch wenn ich sie vorher in Nautilus öffne/einbinde, sind sie weder von Thunderbird noch von VirtualBox erreichbar und werden nicht angezeigt.

    Wahrscheinlich ist das wieder nur eine Lapalie, aber mir fällt nichts mehr ein...

    Danke schon mal für alle Tipps.
    Geändert von The Kick (09.11.17 um 20:26 Uhr) Grund: Problem gelöst, Anpassung des Titels

  2. #2
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    20.480
    Grundsätzlich fuktioniert es aber? Sprich Du kannst die Dinger mounten und darauf arbeiten?

    Wie sind die Freigaben denn eingebunden?
    Ich bin root - ich darf das.

  3. #3
    Registrierter Benutzer
    Registriert seit
    Jul 2017
    Beiträge
    5
    Hallo marce,

    also ich kann die smb: normal einbinden indem ich in Nautilus auf Andrere Orte klicke, dort bei "Server verbinden" folgendes eingebe: smb://server-ip-adresse/Ordnername dann werden die dinger eingebunden, ich kann Dateien offnen speichern etc. (s. Bild, rechter Bildschirm)

    Wenn ich aber versuche z.B. aus Firefox eine Datei an eine Email anzuhängen, wird genau dieselbe Freigabe gar nicht erst aufgeführt, selbst wenn ich auf "Andere Orte" klicke. (s. Bild 34-43 am Ende, linker Bildschirm)
    Bildschirmfoto von »2017-07-18 18-34-43«.png
    Angehängte Grafiken Angehängte Grafiken
    Geändert von The Kick (19.07.17 um 07:02 Uhr)

  4. #4
    Registrierter Benutzer Avatar von Schreibtroll
    Registriert seit
    Jan 2009
    Beiträge
    543
    Ist doch normal. Binde in fstab ein wenn sysVinit und sonst nfs. Ubu-Wiki hilft da gern.

    //192.168.178.26/Daten/ /home/trollii/NAS cifs uid=1000,gid=46,credentials=/home/trolli/auth.192.168.178.26 0 0
    Fritzchen möchte gern das auth anstelle dem alten fstab-Eintrag.... ~/NAS muss aber existieren! Also Ordner anlegen für den $USER.
    Mein Lieblingsbefehl: dd if=/dev/null of=/dev/bock bs=666

  5. #5
    Registrierter Benutzer
    Registriert seit
    Jul 2017
    Beiträge
    5
    Hmmpf....

    klappt nicht: Die Konsole will jedes Mal root@server-ip-adresse anmelden - auch wenn ich die uid und die gid mit meinem User einsetze.
    Ich werde aber daran noch etwas herumprobieren. Der Weg scheint mir jedenfalls der richtige.

  6. #6
    Registrierter Benutzer Avatar von Schreibtroll
    Registriert seit
    Jan 2009
    Beiträge
    543
    *grummel*
    Was läuft denn jetzt bei Dir? sysVinit/upstart oder systemd??

    Sofern erstes setze doch einfach mal meinen String auf Deine Daten angepasst in die fstab. Sofern zwotes... automount/systemd - Ubu-Wiki fragen. gid=046 ist netdev - in der Gruppe solltest Du schon sein...
    Mein Lieblingsbefehl: dd if=/dev/null of=/dev/bock bs=666

  7. #7
    Registrierter Benutzer
    Registriert seit
    Jul 2017
    Beiträge
    5
    Zitat Zitat von Schreibtroll Beitrag anzeigen
    *grummel*
    Was läuft denn jetzt bei Dir? sysVinit/upstart oder systemd??

    Sofern erstes setze doch einfach mal meinen String auf Deine Daten angepasst in die fstab. Sofern zwotes... automount/systemd - Ubu-Wiki fragen. gid=046 ist netdev - in der Gruppe solltest Du schon sein...
    *doofe-Frage-stell-ein*

    wie krieg ich raus was bei mir in der Maschine läuft?

    *doofe-Frage-stell-aus*

    Hab den Eintrag gemacht in fstab und da hat er beim Boot nach den Creds für root@... gefragt... Obwohl ich den User, uid und die Netzwerkadresseb geändert habe.

    Ok, dann muss ich mich wohl mit einem usermod aG in GID 046/netdev eintragen...

    hmmmm....
    netdev / 46 existiert, aber ich kann mich nicht hinzufügen:
    ein

    id

    nach

    sudo usermod -aG netdev $User

    erbrachte:

    Gruppen=1001($User),20(dialout),27(sudo),128(vboxu sers)

    Muss ich netdev noch irgenwie "einschalten"? Müsste doch eine Systemgruppe sein (gid<99)!?
    Geändert von The Kick (22.07.17 um 22:46 Uhr) Grund: Präzisierung

  8. #8
    Registrierter Benutzer
    Registriert seit
    Jul 2017
    Beiträge
    5

    Lightbulb [gelöst]

    So, nachdem ich wieder auf Debian 8 zurück gegangen bin und sich dort ähnliche Probleme einstellten, habe ich mir mal ein paar ruhige Minuten genommen und das Ganze mal komplett durchgedacht:
    Die Lösung dieser eigenlich zwei Probleme möchte ich nun nicht vorenthalten.

    1. Problem:
    smb-Freigaben ließen sich nicht unter dem Server-Namen ansprechen

    1. Lösung:
    die Server-Namen mit

    Code:
    $ sudo nano /etc/hosts
    in die hosts Datei einfügen - Beispiel:

    Code:
    192.168.XXX.XXX Server-Name
    192.168.YYY.YYY Server-Name-2
    wobei natürlich XXX und YYY durch die entsprechenden Zahlen zu ersetzen sind.



    2. Problem:
    Virtualbox hat die smb-Freigaben nicht mehr im Dateimanager aufgeführt, so dass ich die darauf liegenden .vbox Dateien nicht mehr einbinden konnte.

    2. Ursache:
    Virtualbox kann nicht (oder nicht mehr?) über gvfs auf smb-Freigaben zugreifen, da die notwendigen Credentials eingegeben werden müssten. Dies aber klappt nicht in gvfs da es ja nur ein virtuelle FileSystem ist.


    2. Lösung:
    Ich habe die betreffenden Freigaben automatisch eingebunden und die Verbindung über cifs gemacht.

    Dazu muss zunächst cifs-utils als Paket installiert werden:
    Code:
    $ sudo apt-get update
    $ sudo apt-get install cifs-utils
    Dann müssen wir die eine oder mehrere Freigaben in /etc/fstab eintragen:

    Code:
    $ sudo nano /etc/fstab
    Anschließend habe ich die Eintragung wie folgt vorgenommen und Zeilen wie diese hinzugefügt:
    Code:
    # SMB-Freigaben einbinden
    //192.168.xxx.yyy/NameDerFreigabe     /home/USERNAME/ORDNER1     cifs     noauto, users,credentials=/Pfad/Zur/.CredentialDatei     0     0
    Man beachte: der unter "ORDNER1" bezeichnete Ordner muss vorhanden sein. Ggfs. muss man ihn über die GUI (Nautius etc.) oder mit einem mkdir ORDNERNAME angelegt werden.

    WICHTIG!: Da ich nicht wollte, dass die Credentials in Klartext so ohne Weiteres ausgelesen werden könnten, habe ich eine CredentialDatei erstellt und diese in /home/ gelegt.
    Zudem habe ich ein . (Punkt) vor den Dateinamen gesetzt um diese zu verdecken. (Beispiel " .sbmcredentials " )

    In dieser Datei sollte lediglich folgendes stehen:

    Code:
    username=<benutzer>
    password=<passwort>
    domain=<domain>
    Außerdem empfiehlt sich ein

    Code:
    $ chmod 600 ~/.smbcredentials
    um die Datei nur dem eigenen User anzueignen.

    Nach einem Neustart werden dann die smb-Freigaben eingebunden. Nach dem Start von virtualbox sind dann auch alle darüber eingebundenen VMs ansprechbar.
    Geändert von The Kick (09.11.17 um 20:25 Uhr)

Ähnliche Themen

  1. nach neustart kein Zugriff mehr auf debian- Freigaben
    Von ka0t im Forum Linux als Server
    Antworten: 4
    Letzter Beitrag: 30.04.10, 14:05
  2. Debian: dev eintraege verschwunden nach dist-upgrade
    Von dvd666 im Forum System installieren und konfigurieren
    Antworten: 11
    Letzter Beitrag: 13.09.06, 17:44
  3. Debian Sid und Xmms fehler nach apt-get upgrade
    Von Chessmaster im Forum System installieren und konfigurieren
    Antworten: 6
    Letzter Beitrag: 24.07.04, 12:51
  4. debian upgrade nach dpkg -i --force-all
    Von Hotspott im Forum System installieren und konfigurieren
    Antworten: 0
    Letzter Beitrag: 03.05.04, 23:19
  5. debian: bootproblem nach dist-upgrade
    Von felix_do im Forum System installieren und konfigurieren
    Antworten: 1
    Letzter Beitrag: 15.01.04, 20:24

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •