Anzeige:
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 15 von 20

Thema: Unter Linux im WLAN schlechte Downloadrate

  1. #1
    Registrierter Benutzer
    Registriert seit
    Jun 2017
    Beiträge
    8

    Unter Linux im WLAN schlechte Downloadrate

    Wie oben beschrieben habe ich unter Linux und nur über WLAN eine schlechte Downloadrate von ca. 3 Mbit/s. Der Upload ist ok und liegt bei 10 Mbit/s. Alles bei einer 50000 Leitung und mehreren verschiedenen Linuxversionen egal ob am PC oder auf dem Raspberry Pi. Bei einer LAN-Verbindung funktioniert alles einwandfrei. Komischerweise habe ich dieses Problem unter Windows nicht.

  2. #2
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    20.522
    Sehr interessant. Sollte darin eine Frage versteckt sein - ich finde sie nicht. Sollten Informationen in dem Post versteckt sein - ich finde sie nicht.
    Ich bin root - ich darf das.

  3. #3
    Registrierter Benutzer
    Registriert seit
    Jun 2017
    Beiträge
    8
    Die Frage ist: Wie kriege ich eine schnellere WLAN-Verbindung unter Linux hin? Ok, war ein bisschen versteckt. Was brauchst du denn für Infos Marce?

  4. #4
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Ort
    Sauerland
    Beiträge
    937
    1. Was verstehst du unter " mehrere verschiedene Linuxversionen"
    2. Wie verbindest du dich mit Wlan bei raspi und PC? USB-Wlan-Stick? Derselbe oder verschiedene Sticks?
    Geändert von Sauerland1 (06.06.17 um 18:32 Uhr)

  5. #5
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    20.522
    ... und dann noch das übliche - welche Hardware, welche Treiber, welches OS, welche Konfiuration, wirklich _exakt_ vergleichbare Bedigungen (also gleicher Laptop, 1x mit Windows, 1x mit Limux. am gleichen Platz mit gleich viel anderen Geräten im WLAN, ...), Messungen nicht "fühlt sich langsam an" sondern ded. Test mit netio oder ähnlichem (nicht irgendwelche Speed-Test-Internetseiten), ...

    -> Belastbare Fakten, keine Prosa.
    Ich bin root - ich darf das.

  6. #6
    Registrierter Benutzer
    Registriert seit
    Jun 2017
    Beiträge
    8
    Ich hab an meinem PC Ubuntu und Linux Mint ausprobiert, am Raspberry3 Raspbian Pixel. WLAN hab ich im Raspberry und am PC on Board.

  7. #7
    Registrierter Benutzer Avatar von Schreibtroll
    Registriert seit
    Jan 2009
    Beiträge
    543
    ...immer noch Prosa
    Code:
    inxi -N
    im Terminal wäre aussagekräftiger. Und
    Code:
    iwconfig
    dazu. Bitte die ESSID "kaschieren"!
    Mein Lieblingsbefehl: dd if=/dev/null of=/dev/bock bs=666

  8. #8
    Registrierter Benutzer
    Registriert seit
    Jun 2017
    Beiträge
    8
    Habe nochmal den Raspberry ausprobiert, die 3Mbit/s im Download waren nicht ganz richtig geschildert es schwankt ganz ordentlich. Bis vorhin bin ich aber nicht über 8Mbit/s hinaus gekommen. Raspbian hab ich noch mal über Noobs neuinstalliert. Jetzt schwankt es zwischen 2Mbits/s und wenn ich Glück hab sogar 18 Mbits/s, meistens sind es aber weniger. Natürlich habe ich in einen Browser den Speedtest gemacht und hab da die Ergebnisse her. Auf meinem PC ist nach wie vor die Downloadrate schlecht.

    inxi -N ging auf dem Raspberry nicht, deshalb gebe ich mal die Daten von meinem alten PC.


    ...-MS-7800 ~ $ inxi -N
    Network: Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
    driver: r8169
    Card-2: IMC Networks Mediao 802.11n WLAN [Realtek RTL8191SU]
    driver: r8712u


    ....-MS-7800 ~ $ iwconfig
    lo no wireless extensions.

    wlx94dbc9e15513 IEEE 802.11bgn ESSID:"...." Nickname:"...."
    Mode:Managed Frequency:2.437 GHz Access Point: 78:94:B4:40:9F:92
    Bit Rate:72 Mb/s Sensitivity:0/0
    Retryff RTS thrff Fragment thrff
    Power Managementff
    Link Quality=98/100 Signal level=88/100 Noise level=0/100
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    enp1s0 no wireless extensions.

  9. #9
    Elefantenversteher Avatar von florian0285
    Registriert seit
    Jun 2016
    Beiträge
    1.047
    Installier dir iperf3

    Auf dem pi mit raspbian z. B.

    Code:
    apt update
    apt install iperf3
    Dann prüfe mit
    Code:
     iperf3 -c iperf.volia.net -R -P 4
    Und poste das Ergebnis.

    Bei mir kommt so ziemlich genau das was der Provider verspricht.

    Wenn du mit anderen Servern testen willst:

    https://iperf.fr/fr/iperf-servers.php
    Matthäus 7:3 Was siehst du aber den Splitter in deines Bruders Auge, und wirst nicht gewahr des Balkens in deinem Auge?

  10. #10
    Registrierter Benutzer
    Registriert seit
    Jun 2017
    Beiträge
    8
    Der Beitrag sollte gar nicht so lustig dargestellt werden, ihr könnt es aber bestimmt trotzdem erkennen. Versuchsweise hatte ich mal einen WLAN Stick ausprobiert. Hat auch nichts geändert.

  11. #11
    Registrierter Benutzer
    Registriert seit
    Jun 2017
    Beiträge
    8
    [ ID] Interval Transfer Bandwidth
    [ 4] 0.00-1.00 sec 210 KBytes 1.72 Mbits/sec
    [ 6] 0.00-1.00 sec 142 KBytes 1.16 Mbits/sec
    [ 8] 0.00-1.00 sec 208 KBytes 1.70 Mbits/sec
    [ 10] 0.00-1.00 sec 42.2 KBytes 346 Kbits/sec
    [SUM] 0.00-1.00 sec 602 KBytes 4.93 Mbits/sec
    - - - - - - - - - - - - - - - - - - - - - - - - -
    [ 4] 1.00-2.00 sec 159 KBytes 1.30 Mbits/sec
    [ 6] 1.00-2.00 sec 42.2 KBytes 346 Kbits/sec
    [ 8] 1.00-2.00 sec 8.44 KBytes 69.1 Kbits/sec
    [ 10] 1.00-2.00 sec 57.7 KBytes 472 Kbits/sec
    [SUM] 1.00-2.00 sec 267 KBytes 2.19 Mbits/sec
    - - - - - - - - - - - - - - - - - - - - - - - - -
    [ 4] 2.00-3.00 sec 12.7 KBytes 104 Kbits/sec
    [ 6] 2.00-3.00 sec 78.8 KBytes 645 Kbits/sec
    [ 8] 2.00-3.00 sec 0.00 Bytes 0.00 bits/sec
    [ 10] 2.00-3.00 sec 97.0 KBytes 795 Kbits/sec
    [SUM] 2.00-3.00 sec 188 KBytes 1.54 Mbits/sec
    - - - - - - - - - - - - - - - - - - - - - - - - -
    [ 4] 3.00-4.00 sec 64.7 KBytes 530 Kbits/sec
    [ 6] 3.00-4.00 sec 8.44 KBytes 69.1 Kbits/sec
    [ 8] 3.00-4.00 sec 16.9 KBytes 138 Kbits/sec
    [ 10] 3.00-4.00 sec 53.4 KBytes 438 Kbits/sec
    [SUM] 3.00-4.00 sec 143 KBytes 1.18 Mbits/sec
    - - - - - - - - - - - - - - - - - - - - - - - - -
    [ 4] 4.00-5.00 sec 236 KBytes 1.94 Mbits/sec
    [ 6] 4.00-5.00 sec 186 KBytes 1.53 Mbits/sec
    [ 8] 4.00-5.00 sec 294 KBytes 2.41 Mbits/sec
    [ 10] 4.00-5.00 sec 90.0 KBytes 737 Kbits/sec
    [SUM] 4.00-5.00 sec 806 KBytes 6.60 Mbits/sec
    - - - - - - - - - - - - - - - - - - - - - - - - -
    [ 4] 5.00-6.00 sec 158 KBytes 1.29 Mbits/sec
    [ 6] 5.00-6.00 sec 97.0 KBytes 795 Kbits/sec
    [ 8] 5.00-6.00 sec 107 KBytes 879 Kbits/sec
    [ 10] 5.00-6.00 sec 50.6 KBytes 415 Kbits/sec
    [SUM] 5.00-6.00 sec 412 KBytes 3.38 Mbits/sec
    - - - - - - - - - - - - - - - - - - - - - - - - -
    [ 4] 6.00-7.00 sec 75.9 KBytes 622 Kbits/sec
    [ 6] 6.00-7.00 sec 66.1 KBytes 541 Kbits/sec
    [ 8] 6.00-7.00 sec 28.1 KBytes 230 Kbits/sec
    [ 10] 6.00-7.00 sec 15.5 KBytes 127 Kbits/sec
    [SUM] 6.00-7.00 sec 186 KBytes 1.52 Mbits/sec
    - - - - - - - - - - - - - - - - - - - - - - - - -
    [ 4] 7.00-8.00 sec 0.00 Bytes 0.00 bits/sec
    [ 6] 7.00-8.00 sec 8.44 KBytes 69.1 Kbits/sec
    [ 8] 7.00-8.00 sec 32.3 KBytes 265 Kbits/sec
    [ 10] 7.00-8.00 sec 191 KBytes 1.57 Mbits/sec
    [SUM] 7.00-8.00 sec 232 KBytes 1.90 Mbits/sec
    - - - - - - - - - - - - - - - - - - - - - - - - -
    [ 4] 8.00-9.00 sec 212 KBytes 1.74 Mbits/sec
    [ 6] 8.00-9.00 sec 201 KBytes 1.65 Mbits/sec
    [ 8] 8.00-9.00 sec 145 KBytes 1.19 Mbits/sec
    [ 10] 8.00-9.00 sec 94.2 KBytes 772 Kbits/sec
    [SUM] 8.00-9.00 sec 652 KBytes 5.35 Mbits/sec
    iperf3: error - control socket has closed unexpectedly
    pi@raspberrypi:~ $

  12. #12
    Newbie and practicing Avatar von Newbie314
    Registriert seit
    Mar 2007
    Beiträge
    7.620
    Zitat Zitat von emtipp Beitrag anzeigen
    Der Beitrag sollte gar nicht so lustig dargestellt werden
    Nimm Code Tags, siehe meine Signatur.
    Bei Konsolenausgaben / Fehlermeldungen bitte immer Code Tags verwenden: [code] -Text- [/code]
    "Überzeugungen sind gefährlichere Feinde der Wahrheit als Lügen" (H. Lesch)

  13. #13
    Elefantenversteher Avatar von florian0285
    Registriert seit
    Jun 2016
    Beiträge
    1.047
    Mach das jetzt mal von Laptop zum pi.

    Also am Lappi iperf installieren ggf. Firewall abschalten und dann mit dem Parameter "-s" starten.
    Also:
    Code:
    iperf3 -s
    Und am anderen Ding den selben befehl nur eben den hostnamen mit der IP tauschen.

    Natürlich beide ins selbe Wlan verbinden.
    Wenn möglich auch mal mit unterschiedlichen Sticks probieren.
    Matthäus 7:3 Was siehst du aber den Splitter in deines Bruders Auge, und wirst nicht gewahr des Balkens in deinem Auge?

  14. #14
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    20.522
    Stark schwankende WLAN-Duchsatzraten bei gleichen Gegebenheiten - sieht ein wenig danach aus, als ob bei Dir "das WLAN" verschmutzt ist - sprich der gewählte Kanal überladen.

    Wohnst Du in einem 1-Familien-Haus alleine mitten in einer Waldlichtung oder hast Du vom Hochhauskomplex um Dich herum noch 2000 anderen WLANs in der Auswahlliste? Mach mal eine Analyse (gibt's nette Smartphone-Apps, die das sogar hübsch darstellen), was bei Dir so los ist und sich Dir den Kanal und Frequenzbereich aus, der am saubersten ist (Bzw. stell manuell die Werte ein, die Windows verwendet). Sollte das alles nicht das bringen, was Du Dir erwartest bleibt Dir nur, auf Kabel umzusteigen.
    Geändert von marce (07.06.17 um 07:23 Uhr)
    Ich bin root - ich darf das.

  15. #15
    Elefantenversteher Avatar von florian0285
    Registriert seit
    Jun 2016
    Beiträge
    1.047
    Dagegen würde die korrekte Funktion mit Windows sprechen.

    Theoretisch sollte der Noise-Level auch darauf hinweisen. Den hab ich jedoch noch nie in Aktion gesehen...

    Der genannte Stick soll hin und wieder instabil sein, der integrierte vom Pi wäre eigentlich einwandfrei.

    Ich würde die Verbindung wie gesagt intern nochmal mit iperf prüfen. Bei Windows auch nochmal voneinander unabhängige Speedtests machen.

    Wenn möglich die Hardware tauschen (Stick und Router) beim Router ggf einen zweiten einfach anklemmen.

    Die Verbindungsoptionen prüfen. Also mal Verschlüsselung & Co ausschalten, dann Stufenweise einschalten bzw Umschalten.

    Teste auch mal stark unterschiedliche Distributionen mit ner Live-CD. Fedora, Debian, Ubuntu, Suse z. B.
    Matthäus 7:3 Was siehst du aber den Splitter in deines Bruders Auge, und wirst nicht gewahr des Balkens in deinem Auge?

Ähnliche Themen

  1. Antworten: 4
    Letzter Beitrag: 18.09.08, 21:25
  2. Antworten: 10
    Letzter Beitrag: 26.03.05, 12:08
  3. Mikro hat unter Linux schlechte Qualität
    Von brainstorm2k3 im Forum Musik
    Antworten: 4
    Letzter Beitrag: 22.03.05, 11:27
  4. Antworten: 2
    Letzter Beitrag: 26.12.00, 06:09
  5. Schlechte DSL-Downloadrate mit LINUX Firewall?
    Von im Forum Anbindung an die Aussenwelt
    Antworten: 0
    Letzter Beitrag: 19.12.00, 23:07

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •