Ergebnis 1 bis 6 von 6

Thema: apt-get verhält sich äußerst seltsam

  1. #1
    Registrierter Benutzer
    Registriert seit
    Oct 2016
    Beiträge
    78

    apt-get verhält sich äußerst seltsam

    Wenn ich versuche, irgendwas mit apt-get zu installieren, versucht er sich mit einer CD-Rom zu verbinden oder sonstigen Blödsinn. Ich habe Debian ohne GUI installiert. Wenn ich außerdem irgendwas mit sudo eingebe, sagt er, dass er den Befehl sudo nicht finde. Was zum...?! Wenn ich zum Beispiel "apt-get install vim" eingab, wollte er von mir, dass ich die Installations-CD von Debian einlege. Dies tat ich und das Programm konnte ich dann auch installieren. Aber wenn ich "apt-get update" ausführe sagt er,d ass es nichts zu aktualisieren gibt. Und wenn ich dann versuche irgendwelche essentiellen Standardprogramme runterzuladen.

    Wenn ich beispielsweise folgendes tue: "apt-get install g++"

    Code:
    Paketlisten werden gelesen...
    Abhängigkeitsbaum wird aufgebaut....
    Statusinformationen werden eingelesen....
    gcc-4.9-base ist schon die neueste Version.
    libgcc1 ist schon die neueste Version.
    zlib1g ist schon die neueste Version.
    dpkg ist schon die neueste Version.
    libpam0g ist schon die neueste Version.
    libsemanage-common ist schon die neueste Version.
    libsemanage1 ist schon die neueste Version.
    libapt-pkg4.12 ist schon die neueste Version.
    gpgv ist schon die neueste Version.
    debian-archive-keyring ist schon die neueste Version.
    gnupg ist schon die neueste Version.
    liblocale-gettext-perl ist schon die neueste Version.
    libpython2.7-stdlib ist schon die neueste Version.
    libpython2.7-stdlib wurde als manuell installiert festgelegt.
    python ist schon die neueste Version.
    apt-listchanges ist schon die neueste Version.
    libmagic1 ist schon die neueste Version.
    libmagic1 wurde als manuell installiert festgelegt.
    libgpm2 ist schon die neueste Version.
    libgpm2 wurde als manuell installiert festgelegt.
    libsigc++-2.0-0c2a ist schon die neueste Version.
    libcwidget3 ist schon die neueste Version.
    libcwidget3 wurde als manuell installiert festgelegt.
    libgpg-error0 ist schon die neueste Version.
    libgcrypt20 ist schon die neueste Version.
    perl-modules ist schon die neueste Version.
    libgdbm3 ist schon die neueste Version.
    perl ist schon die neueste Version.
    libio-string-perl ist schon die neueste Version.
    libio-string-perl wurde als manuell installiert festgelegt.
    libparse-debianchangelog-perl ist schon die neueste Version.
    libparse-debianchangelog-perl wurde als manuell installiert festgelegt.
    exim4-config ist schon die neueste Version.
    libgmp10 ist schon die neueste Version.
    libhogweed2 ist schon die neueste Version.
    libgnutls-deb0-28 ist schon die neueste Version.
    exim4-daemon-light ist schon die neueste Version.
    libsigsegv2 ist schon die neueste Version.
    libsigsegv2 wurde als manuell installiert festgelegt.
    libgeoip1 ist schon die neueste Version.
    libgeoip1 wurde als manuell installiert festgelegt.
    libgssapi-krb5-2 ist schon die neueste Version.
    libgssapi-krb5-2 wurde als manuell installiert festgelegt.
    libisccfg90 ist schon die neueste Version.
    libisccfg90 wurde als manuell installiert festgelegt.
    geoip-database ist schon die neueste Version.
    geoip-database wurde als manuell installiert festgelegt.
    sgml-base ist schon die neueste Version.
    sgml-base wurde als manuell installiert festgelegt.
    libcap-ng0 ist schon die neueste Version.
    libcap-ng0 wurde als manuell installiert festgelegt.
    libslang2 ist schon die neueste Version.
    e2fsprogs ist schon die neueste Version.
    libpng12-0 ist schon die neueste Version.
    libpng12-0 wurde als manuell installiert festgelegt.
    gcc-4.8-base ist schon die neueste Version.
    gettext-base ist schon die neueste Version.
    libgnutls-openssl27 ist schon die neueste Version.
    grep ist schon die neueste Version.
    groff-base ist schon die neueste Version.
    gzip ist schon die neueste Version.
    libisccfg-export90 ist schon die neueste Version.
    libglib2.0-0 ist schon die neueste Version.
    libglib2.0-0 wurde als manuell installiert festgelegt.
    iputils-ping ist schon die neueste Version.
    libgc1c2 ist schon die neueste Version.
    libgc1c2 wurde als manuell installiert festgelegt.
    liblogging-stdlog0 ist schon die neueste Version.
    liblognorm1 ist schon die neueste Version.
    logrotate ist schon die neueste Version.
    manpages ist schon die neueste Version.
    libgtk2.0-common ist schon die neueste Version.
    libgtk2.0-common wurde als manuell installiert festgelegt.
    fontconfig-config ist schon die neueste Version.
    fontconfig-config wurde als manuell installiert festgelegt.
    libfontconfig1 ist schon die neueste Version.
    libfontconfig1 wurde als manuell installiert festgelegt.
    libjpeg62-turbo ist schon die neueste Version.
    libjpeg62-turbo wurde als manuell installiert festgelegt.
    libjbig0 ist schon die neueste Version.
    libjbig0 wurde als manuell installiert festgelegt.
    libgdk-pixbuf2.0-common ist schon die neueste Version.
    libgdk-pixbuf2.0-common wurde als manuell installiert festgelegt.
    libgdk-pixbuf2.0-0 ist schon die neueste Version.
    libgdk-pixbuf2.0-0 wurde als manuell installiert festgelegt.
    fontconfig ist schon die neueste Version.
    fontconfig wurde als manuell installiert festgelegt.
    libpango-1.0-0 ist schon die neueste Version.
    libpango-1.0-0 wurde als manuell installiert festgelegt.
    libgraphite2-3 ist schon die neueste Version.
    libgraphite2-3 wurde als manuell installiert festgelegt.
    libpangoft2-1.0-0 ist schon die neueste Version.
    libpangoft2-1.0-0 wurde als manuell installiert festgelegt.
    libpangocairo-1.0-0 ist schon die neueste Version.
    libpangocairo-1.0-0 wurde als manuell installiert festgelegt.
    libxdamage1 ist schon die neueste Version.
    libxdamage1 wurde als manuell installiert festgelegt.
    libgtk2.0-0 ist schon die neueste Version.
    libgtk2.0-0 wurde als manuell installiert festgelegt.
    pinentry-gtk2 ist schon die neueste Version.
    pinentry-gtk2 wurde als manuell installiert festgelegt.
    gnupg-agent ist schon die neueste Version.
    gnupg-agent wurde als manuell installiert festgelegt.
    libcurl3-gnutls ist schon die neueste Version.
    libcurl3-gnutls wurde als manuell installiert festgelegt.
    gnupg2 ist schon die neueste Version.
    gnupg2 wurde als manuell installiert festgelegt.
    libgpgme11 ist schon die neueste Version.
    libgpgme11 wurde als manuell installiert festgelegt.
    libgtk2.0-bin ist schon die neueste Version.
    libgtk2.0-bin wurde als manuell installiert festgelegt.
    python-pkg-resources ist schon die neueste Version.
    python-pkg-resources wurde als manuell installiert festgelegt.
    python-reportbug ist schon die neueste Version.
    python-pygments ist schon die neueste Version.
    python-pygments wurde als manuell installiert festgelegt.
    libpaper1 ist schon die neueste Version.
    libpaper1 wurde als manuell installiert festgelegt.
    reportbug ist schon die neueste Version.
    rsyslog ist schon die neueste Version.
    login ist schon die neueste Version.
    libfile-listing-perl ist schon die neueste Version.
    libfile-listing-perl wurde als manuell installiert festgelegt.
    libhtml-tagset-perl ist schon die neueste Version.
    libhtml-tagset-perl wurde als manuell installiert festgelegt.
    libhttp-message-perl ist schon die neueste Version.
    libhttp-message-perl wurde als manuell installiert festgelegt.
    libhttp-negotiate-perl ist schon die neueste Version.
    libhttp-negotiate-perl wurde als manuell installiert festgelegt.
    wget ist schon die neueste Version.
    keyboard-configuration ist schon die neueste Version.
    libnl-genl-3-200 ist schon die neueste Version.
    libnl-genl-3-200 wurde als manuell installiert festgelegt.
    grub-common ist schon die neueste Version.
    grub2-common ist schon die neueste Version.
    grub2-common wurde als manuell installiert festgelegt.
    grub-pc-bin ist schon die neueste Version.
    grub-pc-bin wurde als manuell installiert festgelegt.
    grub-pc ist schon die neueste Version.
    linux-image-3.16.0-4-686-pae ist schon die neueste Version.
    linux-image-3.16.0-4-686-pae wurde als manuell installiert festgelegt.
    linux-image-686-pae ist schon die neueste Version.
    libcloog-isl4 ist schon die neueste Version.
    libcloog-isl4 wurde als manuell installiert festgelegt.
    wireless-regdb ist schon die neueste Version.
    wireless-regdb wurde als manuell installiert festgelegt.
    librsvg2-2 ist schon die neueste Version.
    librsvg2-2 wurde als manuell installiert festgelegt.
    librsvg2-common ist schon die neueste Version.
    librsvg2-common wurde als manuell installiert festgelegt.
    libglapi-mesa ist schon die neueste Version.
    libglapi-mesa wurde als manuell installiert festgelegt.
    libgbm1 ist schon die neueste Version.
    libgbm1 wurde als manuell installiert festgelegt.
    libegl1-mesa ist schon die neueste Version.
    libegl1-mesa wurde als manuell installiert festgelegt.
    libxcb-glx0 ist schon die neueste Version.
    libxcb-glx0 wurde als manuell installiert festgelegt.
    libgl1-mesa-glx ist schon die neueste Version.
    libgl1-mesa-glx wurde als manuell installiert festgelegt.
    xserver-xorg-core ist schon die neueste Version.
    xserver-xorg-core wurde als manuell installiert festgelegt.
    xserver-xorg-video-r128 ist schon die neueste Version.
    xserver-xorg-video-r128 wurde als manuell installiert festgelegt.
    xserver-xorg-video-mach64 ist schon die neueste Version.
    xserver-xorg-video-mach64 wurde als manuell installiert festgelegt.
    xserver-xorg-video-radeon ist schon die neueste Version.
    xserver-xorg-video-radeon wurde als manuell installiert festgelegt.
    xserver-xorg-video-ati ist schon die neueste Version.
    xserver-xorg-video-ati wurde als manuell installiert festgelegt.
    xserver-xorg-video-cirrus ist schon die neueste Version.
    xserver-xorg-video-cirrus wurde als manuell installiert festgelegt.
    xserver-xorg-video-fbdev ist schon die neueste Version.
    xserver-xorg-video-fbdev wurde als manuell installiert festgelegt.
    xserver-xorg-video-intel ist schon die neueste Version.
    xserver-xorg-video-intel wurde als manuell installiert festgelegt.
    xserver-xorg-video-mga ist schon die neueste Version.
    xserver-xorg-video-mga wurde als manuell installiert festgelegt.
    xserver-xorg-video-modesetting ist schon die neueste Version.
    xserver-xorg-video-modesetting wurde als manuell installiert festgelegt.
    xserver-xorg-video-neomagic ist schon die neueste Version.
    xserver-xorg-video-neomagic wurde als manuell installiert festgelegt.
    xserver-xorg-video-nouveau ist schon die neueste Version.
    xserver-xorg-video-nouveau wurde als manuell installiert festgelegt.
    xserver-xorg-video-openchrome ist schon die neueste Version.
    xserver-xorg-video-openchrome wurde als manuell installiert festgelegt.
    xserver-xorg-video-savage ist schon die neueste Version.
    xserver-xorg-video-savage wurde als manuell installiert festgelegt.
    xserver-xorg-video-siliconmotion ist schon die neueste Version.
    xserver-xorg-video-siliconmotion wurde als manuell installiert festgelegt.
    xserver-xorg-video-sisusb ist schon die neueste Version.
    xserver-xorg-video-sisusb wurde als manuell installiert festgelegt.
    xserver-xorg-video-tdfx ist schon die neueste Version.
    xserver-xorg-video-tdfx wurde als manuell installiert festgelegt.
    xserver-xorg-video-trident ist schon die neueste Version.
    xserver-xorg-video-trident wurde als manuell installiert festgelegt.
    xserver-xorg-video-vesa ist schon die neueste Version.
    xserver-xorg-video-vesa wurde als manuell installiert festgelegt.
    xserver-xorg-video-vmware ist schon die neueste Version.
    xserver-xorg-video-vmware wurde als manuell installiert festgelegt.
    xserver-xorg-video-all ist schon die neueste Version.
    xserver-xorg-video-all wurde als manuell installiert festgelegt.
    xserver-xorg-input-evdev ist schon die neueste Version.
    xserver-xorg-input-evdev wurde als manuell installiert festgelegt.
    xserver-xorg-input-mouse ist schon die neueste Version.
    xserver-xorg-input-mouse wurde als manuell installiert festgelegt.
    xserver-xorg-input-vmmouse ist schon die neueste Version.
    xserver-xorg-input-vmmouse wurde als manuell installiert festgelegt.
    xserver-xorg-input-synaptics ist schon die neueste Version.
    xserver-xorg-input-synaptics wurde als manuell installiert festgelegt.
    xserver-xorg-input-all ist schon die neueste Version.
    xserver-xorg-input-all wurde als manuell installiert festgelegt.
    xserver-xorg ist schon die neueste Version.
    xserver-xorg wurde als manuell installiert festgelegt.
    libgl1-mesa-dri ist schon die neueste Version.
    libgl1-mesa-dri wurde als manuell installiert festgelegt.
    libglu1-mesa ist schon die neueste Version.
    libglu1-mesa wurde als manuell installiert festgelegt.
    xfonts-encodings ist schon die neueste Version.
    xfonts-encodings wurde als manuell installiert festgelegt.
    libxxf86dga1 ist schon die neueste Version.
    libxxf86dga1 wurde als manuell installiert festgelegt.
    xorg-docs-core ist schon die neueste Version.
    xorg-docs-core wurde als manuell installiert festgelegt.
    xorg ist schon die neueste Version.
    xorg wurde als manuell installiert festgelegt.
    libglib2.0-data ist schon die neueste Version.
    libglib2.0-data wurde als manuell installiert festgelegt.
    Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
    Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
    Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
    nicht erstellt wurden oder Incoming noch nicht verlassen haben.
    Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:
    
    Die folgenden Pakete haben unerfüllte Abhängigkeiten:
     grub-efi-ia32 : Kollidiert mit: grub-legacy aber 0.97-70 soll installiert werden
                     Kollidiert mit: grub-pc aber 2.02~beta2-22+deb8u1 soll installiert werden
     grub-pc : Kollidiert mit: grub-efi-ia32 aber 2.02~beta2-22+deb8u1 soll installiert werden
               Kollidiert mit: grub-legacy aber 0.97-70 soll installiert werden
     grub2-common : Kollidiert mit: grub-legacy aber 0.97-70 soll installiert werden

  2. #2
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    20.146
    Poste mal Deine sources.list

    (Alternativ: http://debiananwenderhandbuch.de/sources.list.html lesen)
    Ich bin root - ich darf das.

  3. #3
    Organisiertes Chaos
    Registriert seit
    Jul 2011
    Ort
    OWL
    Beiträge
    314
    Erkundige dich doch einfach mal über su (statt sudo, ist ja kein Ubuntu oder dessen Abkömmling[e]) und der Datei sources.list unter /etc/apt. Hilfreiches lässt sich auch auf https://www.debian.org/ und http://debiananwenderhandbuch.de/ finden.

  4. #4
    Registrierter Benutzer
    Registriert seit
    Oct 2016
    Beiträge
    78
    Ich kann euch garnicht sagen wie sehr ich euch liebe. Habe nun den ftp Server von Debian hinzugefügt und nun zieht er sich alles mögliche aus dem Netz. Ich liebe euch. Ihr seid die Besten. Danke!

  5. #5
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    20.146
    Auch an Dich der Hinweis:
    * Grundlagen der verwendeten Distribution lernen
    * Doku lesen
    Ich bin root - ich darf das.

  6. #6
    Registrierter Benutzer
    Registriert seit
    Oct 2016
    Beiträge
    78
    Mit einer Installation mit grafischer Oberfläche hatte ich diese Probleme nie. Wollte aber Linux und Rechnersysteme allgemein grundlegender erlernen, weswegen ich Debian nur textuell installiert habe und bin so schon auf die ersten Hürden gestoßen. Du hast auf jeden Fall recht, ich muß auch mal gepflegt ein Buch in die Hand nehmen bzw. elektronisch nachlesen anstatt mit meinen Halbwissen loszulegen, werde ich ab jetzt alles mal gründlicher machen

Ähnliche Themen

  1. dd verhält sich seltsam
    Von elsefi im Forum Anwendungen Allgemein, Software
    Antworten: 4
    Letzter Beitrag: 30.07.10, 00:54
  2. ET: Maus verhält sich seltsam
    Von phnord im Forum Spielen Allgemein
    Antworten: 20
    Letzter Beitrag: 18.05.05, 07:37
  3. Festplatte verhält sich seltsam
    Von thenktor im Forum stationäre Hardware
    Antworten: 3
    Letzter Beitrag: 18.08.04, 23:06
  4. Xserver verhält sich seltsam
    Von Robi-Wan im Forum X-Konfiguration
    Antworten: 2
    Letzter Beitrag: 20.03.04, 06:34
  5. Äußerst Seltsam
    Von (sic)maggot im Forum Spielen Allgemein
    Antworten: 9
    Letzter Beitrag: 28.11.01, 18:47

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •