Anzeige:
Ergebnis 1 bis 12 von 12

Thema: VMWarePlayer Startet nicht mehr

  1. #1
    Registrierter Benutzer
    Registriert seit
    Oct 2011
    Beiträge
    94

    VMWarePlayer Startet nicht mehr

    Servus

    VMware Workstation 12.5.2 Player startet nicht mehr, Fehlermeldung gcc 6.2.0 wurde nicht gefunden

    gcc_vmware.png

    gcc6-vmware.png

    Code:
    /usr/bin/gcc-6
    gcc-vmware2.png


    vmware-start.png

    Code:
    2017-03-01T09:49:46.935+01:00| vthread-4| I125: Log for VMware Workstation pid=6769 version=12.5.2 build=build-4638234 option=Release
    2017-03-01T09:49:46.935+01:00| vthread-4| I125: The process is 64-bit.
    2017-03-01T09:49:46.935+01:00| vthread-4| I125: Host codepage=UTF-8 encoding=UTF-8
    2017-03-01T09:49:46.935+01:00| vthread-4| I125: Host is Linux 4.10.1-041001-generic Linux Mint 18.1 Serena
    2017-03-01T09:49:46.935+01:00| vthread-4| I125: DictionaryLoad: Cannot open file "/usr/lib/vmware/settings": Datei oder Verzeichnis nicht gefunden.
    2017-03-01T09:49:46.935+01:00| vthread-4| I125: PREF Optional preferences file not found at /usr/lib/vmware/settings. Using default values.
    2017-03-01T09:49:46.935+01:00| vthread-4| I125: DictionaryLoad: Cannot open file "/root/.vmware/config": Datei oder Verzeichnis nicht gefunden.
    2017-03-01T09:49:46.935+01:00| vthread-4| I125: PREF Optional preferences file not found at /root/.vmware/config. Using default values.
    2017-03-01T09:49:46.935+01:00| vthread-4| I125: PREF Unable to check permissions for preferences file.
    2017-03-01T09:49:46.935+01:00| vthread-4| I125: DictionaryLoad: Cannot open file "/root/.vmware/preferences": Datei oder Verzeichnis nicht gefunden.
    2017-03-01T09:49:46.935+01:00| vthread-4| I125: PREF Failed to load user preferences.
    2017-03-01T09:49:46.960+01:00| vthread-4| W115: Logging to /tmp/vmware-root/vmware-6769.log
    2017-03-01T09:49:46.976+01:00| vthread-4| I125: Obtaining info using the running kernel.
    2017-03-01T09:49:46.976+01:00| vthread-4| I125: Created new pathsHash.
    2017-03-01T09:49:46.976+01:00| vthread-4| I125: Setting header path for 4.10.1-041001-generic to "/lib/modules/4.10.1-041001-generic/build/include".
    2017-03-01T09:49:46.976+01:00| vthread-4| I125: Validating path "/lib/modules/4.10.1-041001-generic/build/include" for kernel release "4.10.1-041001-generic".
    2017-03-01T09:49:46.976+01:00| vthread-4| I125: Failed to find /lib/modules/4.10.1-041001-generic/build/include/linux/version.h
    2017-03-01T09:49:46.976+01:00| vthread-4| I125: /lib/modules/4.10.1-041001-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
    2017-03-01T09:49:46.976+01:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
    2017-03-01T09:49:46.979+01:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.10.1-041001-generic".
    2017-03-01T09:49:46.979+01:00| vthread-4| I125: The header path "/lib/modules/4.10.1-041001-generic/build/include" for the kernel "4.10.1-041001-generic" is valid.  Whoohoo!
    2017-03-01T09:49:47.076+01:00| vthread-4| I125: found symbol version file /lib/modules/4.10.1-041001-generic/build/Module.symvers
    2017-03-01T09:49:47.076+01:00| vthread-4| I125: Reading symbol versions from /lib/modules/4.10.1-041001-generic/build/Module.symvers.
    2017-03-01T09:49:47.087+01:00| vthread-4| I125: Read 20996 symbol versions
    2017-03-01T09:49:47.087+01:00| vthread-4| I125: Reading in info for the vmmon module.
    2017-03-01T09:49:47.087+01:00| vthread-4| I125: Reading in info for the vmnet module.
    2017-03-01T09:49:47.087+01:00| vthread-4| I125: Reading in info for the vmblock module.
    2017-03-01T09:49:47.087+01:00| vthread-4| I125: Reading in info for the vmci module.
    2017-03-01T09:49:47.087+01:00| vthread-4| I125: Reading in info for the vsock module.
    2017-03-01T09:49:47.087+01:00| vthread-4| I125: Setting vsock to depend on vmci.
    2017-03-01T09:49:47.087+01:00| vthread-4| I125: Invoking modinfo on "vmmon".
    2017-03-01T09:49:47.088+01:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
    2017-03-01T09:49:47.088+01:00| vthread-4| I125: Invoking modinfo on "vmnet".
    2017-03-01T09:49:47.089+01:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
    2017-03-01T09:49:47.089+01:00| vthread-4| I125: Invoking modinfo on "vmblock".
    2017-03-01T09:49:47.089+01:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
    2017-03-01T09:49:47.089+01:00| vthread-4| I125: Invoking modinfo on "vmci".
    2017-03-01T09:49:47.090+01:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
    2017-03-01T09:49:47.090+01:00| vthread-4| I125: Invoking modinfo on "vsock".
    2017-03-01T09:49:47.091+01:00| vthread-4| I125: "/sbin/modinfo" exited with status 0.
    2017-03-01T09:49:47.098+01:00| vthread-4| I125: to be installed: vmmon status: 0
    2017-03-01T09:49:47.098+01:00| vthread-4| I125: to be installed: vmnet status: 0
    2017-03-01T09:49:47.442+01:00| vthread-4| I125: Obtaining info using the running kernel.
    2017-03-01T09:49:47.442+01:00| vthread-4| I125: Setting header path for 4.10.1-041001-generic to "/lib/modules/4.10.1-041001-generic/build/include".
    2017-03-01T09:49:47.442+01:00| vthread-4| I125: Validating path "/lib/modules/4.10.1-041001-generic/build/include" for kernel release "4.10.1-041001-generic".
    2017-03-01T09:49:47.442+01:00| vthread-4| I125: Failed to find /lib/modules/4.10.1-041001-generic/build/include/linux/version.h
    2017-03-01T09:49:47.442+01:00| vthread-4| I125: /lib/modules/4.10.1-041001-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
    2017-03-01T09:49:47.442+01:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
    2017-03-01T09:49:47.445+01:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.10.1-041001-generic".
    2017-03-01T09:49:47.445+01:00| vthread-4| I125: The header path "/lib/modules/4.10.1-041001-generic/build/include" for the kernel "4.10.1-041001-generic" is valid.  Whoohoo!
    2017-03-01T09:49:47.541+01:00| vthread-4| I125: found symbol version file /lib/modules/4.10.1-041001-generic/build/Module.symvers
    2017-03-01T09:49:47.541+01:00| vthread-4| I125: Reading symbol versions from /lib/modules/4.10.1-041001-generic/build/Module.symvers.
    2017-03-01T09:49:47.552+01:00| vthread-4| I125: Read 20996 symbol versions
    2017-03-01T09:49:47.552+01:00| vthread-4| I125: Kernel header path retrieved from FileEntry: /lib/modules/4.10.1-041001-generic/build/include
    2017-03-01T09:49:47.552+01:00| vthread-4| I125: Update kernel header path to /lib/modules/4.10.1-041001-generic/build/include
    2017-03-01T09:49:47.552+01:00| vthread-4| I125: Validating path "/lib/modules/4.10.1-041001-generic/build/include" for kernel release "4.10.1-041001-generic".
    2017-03-01T09:49:47.552+01:00| vthread-4| I125: Failed to find /lib/modules/4.10.1-041001-generic/build/include/linux/version.h
    2017-03-01T09:49:47.552+01:00| vthread-4| I125: /lib/modules/4.10.1-041001-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
    2017-03-01T09:49:47.552+01:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
    2017-03-01T09:49:47.556+01:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.10.1-041001-generic".
    2017-03-01T09:49:47.556+01:00| vthread-4| I125: The header path "/lib/modules/4.10.1-041001-generic/build/include" for the kernel "4.10.1-041001-generic" is valid.  Whoohoo!
    2017-03-01T09:49:47.556+01:00| vthread-4| I125: Found compiler at "/usr/bin/gcc"
    2017-03-01T09:49:47.557+01:00| vthread-4| I125: Got gcc version "5.4.1".
    2017-03-01T09:49:47.557+01:00| vthread-4| I125: GCC major version 5 does not match Kernel GCC major version 6.
    2017-03-01T09:49:47.557+01:00| vthread-4| I125: The GCC compiler "/usr/bin/gcc" cannot be used for the target kernel.
    2017-03-01T09:49:47.557+01:00| vthread-4| I125: No usable gcc found.  Can't find a valid compiler despite our best efforts.
    2017-03-01T09:49:47.557+01:00| vthread-4| I125: User supplied gcc at "" is not executable.
    2017-03-01T09:49:47.558+01:00| vthread-4| I125: Trying to find a suitable PBM set for kernel "4.10.1-041001-generic".
    2017-03-01T09:49:47.558+01:00| vthread-4| I125: No matching PBM set was found for kernel "4.10.1-041001-generic".
    2017-03-01T09:52:16.786+01:00| vthread-4| I125: Using user supplied compiler "/usr/bin/gcc-6".
    2017-03-01T09:52:16.788+01:00| vthread-4| I125: Got gcc version "6.2.0".
    2017-03-01T09:52:16.788+01:00| vthread-4| I125: The GCC version matches the kernel GCC minor version like a glove.
    2017-03-01T09:53:38.514+01:00| vthread-4| I125: The GCC version matches the kernel GCC minor version like a glove.
    2017-03-01T09:53:38.514+01:00| vthread-4| I125: Validating path "/lib/modules/4.10.1-041001-generic/build/include" for kernel release "4.10.1-041001-generic".
    2017-03-01T09:53:38.514+01:00| vthread-4| I125: Failed to find /lib/modules/4.10.1-041001-generic/build/include/linux/version.h
    2017-03-01T09:53:38.514+01:00| vthread-4| I125: /lib/modules/4.10.1-041001-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
    2017-03-01T09:53:38.514+01:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
    2017-03-01T09:53:38.518+01:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.10.1-041001-generic".
    2017-03-01T09:53:38.518+01:00| vthread-4| I125: The header path "/lib/modules/4.10.1-041001-generic/build/include" for the kernel "4.10.1-041001-generic" is valid.  Whoohoo!
    2017-03-01T09:53:38.518+01:00| vthread-4| I125: Using temp dir "/tmp".
    2017-03-01T09:53:38.519+01:00| vthread-4| I125: Obtaining info using the running kernel.
    2017-03-01T09:53:38.519+01:00| vthread-4| I125: Setting header path for 4.10.1-041001-generic to "/lib/modules/4.10.1-041001-generic/build/include".
    2017-03-01T09:53:38.519+01:00| vthread-4| I125: Validating path "/lib/modules/4.10.1-041001-generic/build/include" for kernel release "4.10.1-041001-generic".
    2017-03-01T09:53:38.519+01:00| vthread-4| I125: Failed to find /lib/modules/4.10.1-041001-generic/build/include/linux/version.h
    2017-03-01T09:53:38.519+01:00| vthread-4| I125: /lib/modules/4.10.1-041001-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
    2017-03-01T09:53:38.519+01:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
    2017-03-01T09:53:38.522+01:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.10.1-041001-generic".
    2017-03-01T09:53:38.522+01:00| vthread-4| I125: The header path "/lib/modules/4.10.1-041001-generic/build/include" for the kernel "4.10.1-041001-generic" is valid.  Whoohoo!
    2017-03-01T09:53:38.619+01:00| vthread-4| I125: found symbol version file /lib/modules/4.10.1-041001-generic/build/Module.symvers
    2017-03-01T09:53:38.619+01:00| vthread-4| I125: Reading symbol versions from /lib/modules/4.10.1-041001-generic/build/Module.symvers.
    2017-03-01T09:53:38.631+01:00| vthread-4| I125: Read 20996 symbol versions
    2017-03-01T09:53:38.631+01:00| vthread-4| I125: Invoking modinfo on "vmmon".
    2017-03-01T09:53:38.633+01:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
    2017-03-01T09:53:38.633+01:00| vthread-4| I125: Invoking modinfo on "vmnet".
    2017-03-01T09:53:38.634+01:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
    2017-03-01T09:53:38.942+01:00| vthread-4| I125: Setting destination path for vmmon to "/lib/modules/4.10.1-041001-generic/misc/vmmon.ko".
    2017-03-01T09:53:38.942+01:00| vthread-4| I125: Extracting the vmmon source from "/usr/lib/vmware/modules/source/vmmon.tar".
    2017-03-01T09:53:38.946+01:00| vthread-4| I125: Successfully extracted the vmmon source.
    2017-03-01T09:53:38.946+01:00| vthread-4| I125: Building module with command "/usr/bin/make -j8 -C /tmp/modconfig-aehHax/vmmon-only auto-build HEADER_DIR=/lib/modules/4.10.1-041001-generic/build/include CC=/usr/bin/gcc-6 IS_GCC_3=no"
    2017-03-01T09:53:39.753+01:00| vthread-4| W115: Failed to build vmmon.  Failed to execute the build command.
    2017-03-01T09:53:39.755+01:00| vthread-4| I125: Setting destination path for vmnet to "/lib/modules/4.10.1-041001-generic/misc/vmnet.ko".
    2017-03-01T09:53:39.755+01:00| vthread-4| I125: Extracting the vmnet source from "/usr/lib/vmware/modules/source/vmnet.tar".
    2017-03-01T09:53:39.758+01:00| vthread-4| I125: Successfully extracted the vmnet source.
    2017-03-01T09:53:39.758+01:00| vthread-4| I125: Building module with command "/usr/bin/make -j8 -C /tmp/modconfig-aehHax/vmnet-only auto-build HEADER_DIR=/lib/modules/4.10.1-041001-generic/build/include CC=/usr/bin/gcc-6 IS_GCC_3=no"
    2017-03-01T09:53:40.566+01:00| vthread-4| W115: Failed to build vmnet.  Failed to execute the build command.
    2017-03-01T09:54:05.498+01:00| vthread-4| I125: The GCC version matches the kernel GCC minor version like a glove.
    2017-03-01T09:54:05.499+01:00| vthread-4| I125: Validating path "/lib/modules/4.10.1-041001-generic/build/include" for kernel release "4.10.1-041001-generic".
    2017-03-01T09:54:05.499+01:00| vthread-4| I125: Failed to find /lib/modules/4.10.1-041001-generic/build/include/linux/version.h
    2017-03-01T09:54:05.499+01:00| vthread-4| I125: /lib/modules/4.10.1-041001-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
    2017-03-01T09:54:05.499+01:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
    2017-03-01T09:54:05.502+01:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.10.1-041001-generic".
    2017-03-01T09:54:05.502+01:00| vthread-4| I125: The header path "/lib/modules/4.10.1-041001-generic/build/include" for the kernel "4.10.1-041001-generic" is valid.  Whoohoo!
    2017-03-01T09:54:05.502+01:00| vthread-4| I125: Using temp dir "/tmp".
    2017-03-01T09:54:05.503+01:00| vthread-4| I125: Obtaining info using the running kernel.
    2017-03-01T09:54:05.503+01:00| vthread-4| I125: Setting header path for 4.10.1-041001-generic to "/lib/modules/4.10.1-041001-generic/build/include".
    2017-03-01T09:54:05.503+01:00| vthread-4| I125: Validating path "/lib/modules/4.10.1-041001-generic/build/include" for kernel release "4.10.1-041001-generic".
    2017-03-01T09:54:05.503+01:00| vthread-4| I125: Failed to find /lib/modules/4.10.1-041001-generic/build/include/linux/version.h
    2017-03-01T09:54:05.503+01:00| vthread-4| I125: /lib/modules/4.10.1-041001-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
    2017-03-01T09:54:05.503+01:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
    2017-03-01T09:54:05.507+01:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.10.1-041001-generic".
    2017-03-01T09:54:05.507+01:00| vthread-4| I125: The header path "/lib/modules/4.10.1-041001-generic/build/include" for the kernel "4.10.1-041001-generic" is valid.  Whoohoo!
    2017-03-01T09:54:05.603+01:00| vthread-4| I125: found symbol version file /lib/modules/4.10.1-041001-generic/build/Module.symvers
    2017-03-01T09:54:05.603+01:00| vthread-4| I125: Reading symbol versions from /lib/modules/4.10.1-041001-generic/build/Module.symvers.
    2017-03-01T09:54:05.616+01:00| vthread-4| I125: Read 20996 symbol versions
    2017-03-01T09:54:05.616+01:00| vthread-4| I125: Invoking modinfo on "vmmon".
    2017-03-01T09:54:05.618+01:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
    2017-03-01T09:54:05.618+01:00| vthread-4| I125: Invoking modinfo on "vmnet".
    2017-03-01T09:54:05.619+01:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
    2017-03-01T09:54:05.894+01:00| vthread-4| I125: Setting destination path for vmmon to "/lib/modules/4.10.1-041001-generic/misc/vmmon.ko".
    2017-03-01T09:54:05.894+01:00| vthread-4| I125: Extracting the vmmon source from "/usr/lib/vmware/modules/source/vmmon.tar".
    2017-03-01T09:54:05.898+01:00| vthread-4| I125: Successfully extracted the vmmon source.
    2017-03-01T09:54:05.898+01:00| vthread-4| I125: Building module with command "/usr/bin/make -j8 -C /tmp/modconfig-t0cFOj/vmmon-only auto-build HEADER_DIR=/lib/modules/4.10.1-041001-generic/build/include CC=/usr/bin/gcc-6 IS_GCC_3=no"
    2017-03-01T09:54:06.575+01:00| vthread-4| W115: Failed to build vmmon.  Failed to execute the build command.
    2017-03-01T09:54:06.576+01:00| vthread-4| I125: Setting destination path for vmnet to "/lib/modules/4.10.1-041001-generic/misc/vmnet.ko".
    2017-03-01T09:54:06.577+01:00| vthread-4| I125: Extracting the vmnet source from "/usr/lib/vmware/modules/source/vmnet.tar".
    2017-03-01T09:54:06.580+01:00| vthread-4| I125: Successfully extracted the vmnet source.
    2017-03-01T09:54:06.580+01:00| vthread-4| I125: Building module with command "/usr/bin/make -j8 -C /tmp/modconfig-t0cFOj/vmnet-only auto-build HEADER_DIR=/lib/modules/4.10.1-041001-generic/build/include CC=/usr/bin/gcc-6 IS_GCC_3=no"
    2017-03-01T09:54:07.349+01:00| vthread-4| W115: Failed to build vmnet.  Failed to execute the build command.
    Code:
    gcc --version
    gcc (Ubuntu 5.4.1-2ubuntu1~16.04) 5.4.1 20160904
    Copyright (C) 2015 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions.  There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
    Code:
    apt-get install gcc-6
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.       
    Statusinformationen werden eingelesen.... Fertig
    »gcc-6« ist bereits die neuste Version (6.2.0-3ubuntu11~16.04).
    gcc-6 wurde als manuell installiert festgelegt.
    0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

    gcc_synaptic.png

    Kann es sein daß der VMWareplayer noch nicht mit dem 4.10er Kernel kann?

    Mint 18.1 Mate 64.

    Gruß
    Andi
    Geändert von Andi123 (01.03.17 um 09:59 Uhr)
    Desktop Tuxedo, ASRock H170M Pro4, i7-7700K, 32 GB RAM, Mint 18.2 Mate 64, Mint 17.3 XFCE 64, Windows 10 Pro 64.
    HP Pavilion dv7-1289eg Core 2 Duo P8600 2x 2.40GHz, NVIDIA GeForce 9600M GT 512MB, 8GB RAM, Mint 18.2 Mate 64

  2. #2
    Registrierter Benutzer Avatar von towo2099
    Registriert seit
    Feb 2002
    Ort
    Pößneck
    Beiträge
    4.408
    VMware funktioniert ungepatcht weder mit kernel 4.9 noch mit 4.10. Der Patch für Kernel 4.9 reicht aber aus, um dann auch gegen 4.10 zu bauen.
    Signatur nach Diktat Spazieren gegangen ;)

  3. #3
    Registrierter Benutzer
    Registriert seit
    Oct 2011
    Beiträge
    94
    @ towo2099

    danke für deine Antwort.

    Leider stehe ich etwas auf dem Schlauch, wie kann ich was patchen
    Desktop Tuxedo, ASRock H170M Pro4, i7-7700K, 32 GB RAM, Mint 18.2 Mate 64, Mint 17.3 XFCE 64, Windows 10 Pro 64.
    HP Pavilion dv7-1289eg Core 2 Duo P8600 2x 2.40GHz, NVIDIA GeForce 9600M GT 512MB, 8GB RAM, Mint 18.2 Mate 64

  4. #4
    Elefantenversteher Avatar von florian0285
    Registriert seit
    Jun 2016
    Beiträge
    1.047
    Nur mal so als Anhalt:

    http://www.linux-praxis.de/lpic2/lpi201/2.201.3.html

    Ist schon etwas veraltet, aber dürfte in groben Zügen deine Frage beantworten.
    Matthäus 7:3 Was siehst du aber den Splitter in deines Bruders Auge, und wirst nicht gewahr des Balkens in deinem Auge?

  5. #5
    Registrierter Benutzer Avatar von towo2099
    Registriert seit
    Feb 2002
    Ort
    Pößneck
    Beiträge
    4.408
    Nuja, Thema verfehlt, 6 setzen!
    Hier muß nicht der Kernel gepatcht werden, sondern die VMware Module Sourcen.
    Signatur nach Diktat Spazieren gegangen ;)

  6. #6
    Elefantenversteher Avatar von florian0285
    Registriert seit
    Jun 2016
    Beiträge
    1.047
    Zitat Zitat von towo2099 Beitrag anzeigen
    Nuja, Thema verfehlt, 6 setzen!
    Hier muß nicht der Kernel gepatcht werden, sondern die VMware Module Sourcen.
    Muss ich nicht verstehen. Kernel-Module sind Bestandteile des Kernels, die zur Laufzeit nachgeladen/entladen werden können.

    Der Link beantwortet die Frage "in groben Zügen". Das Prinzip des Patchen ist "in groben Zügen" das gleiche und was letztendlich als Modul im Kernel landet und was "hardcoded" sein soll entscheiden (mit Außnahme von ggf. proprietären Bestandteilen) die Konfig.

    Der Link beantwortet nicht direkt was der TE für VMWare mit Kernel 4.10 genau patchen muss, bringt ihm aber das Verständnis näher was getan werden muss.

    Deshalb die Antwort "in groben Zügen" = Note 1
    Die Antwort auf die eigentliche Frage = Note 3
    Bei gleicher Gewichtung beider Noten = Gesamtnote 2

    "Nur mal so als Anhalt" und "in groben Zügen" sollte nicht gleich als totalitäre Antwort auf alle Fragen mit 42 gleichgesetzt werden.

    Davon abgesehen sollte er wohl auch aus anderen Gründen nen anderen Kernel ausprobieren
    Matthäus 7:3 Was siehst du aber den Splitter in deines Bruders Auge, und wirst nicht gewahr des Balkens in deinem Auge?

  7. #7
    Mod. FAQ/Howto/Emulation
    Registriert seit
    Sep 2000
    Beiträge
    17.051
    Flori, sieh es ein, dein Link ist absolut nutzlos. Wenn du das nie gemacht hast bei VMWARE, dann sag lieber gar nichts dazu.

    @Andi123: Du suchst eher so was. Darin ist ein Script verlinkt, das macht das ganze für dich.

    http://rglinuxtech.com/?p=1914

    So was findet man einfach per Google mit "vmware 4.10".

  8. #8
    Mod. FAQ/Howto/Emulation
    Registriert seit
    Sep 2000
    Beiträge
    17.051
    Nachtrag: Bei VMWARE ist man mit einem aktuellen Kernel meistens schlecht bedient. Aktualitätsfanatiker sind halt nicht deren Kundenkreis. Sprich: VMWARE und aktuelles Kernelrepo passen nicht zusammen.

  9. #9
    Elefantenversteher Avatar von florian0285
    Registriert seit
    Jun 2016
    Beiträge
    1.047
    Zitat Zitat von stefan.becker Beitrag anzeigen
    Flori, sieh es ein, dein Link ist absolut nutzlos.
    Nein da bin ich zu doof zu....

    in deinem Link zu dem Script wird im Script gepatched

    .... code...
    patch -p0) < vmwkp4.9.patch
    .... viel mehr code ....
    in meinem Link wird gepatched bzw. es erklärt

    .... erklärender Text ....
    zcat patch-2.4.15.gz | patch -p0
    .... weiterer erklärender Text .....
    Sind wohl zwei unterschiedliche "patch -p0" und "patch -p0" Befehle

    und Kernel-Module sind natürlich nicht Bestandteil des Kernels

    Ich gebs auf... ich habs nicht kapiert
    Matthäus 7:3 Was siehst du aber den Splitter in deines Bruders Auge, und wirst nicht gewahr des Balkens in deinem Auge?

  10. #10
    Mod. FAQ/Howto/Emulation
    Registriert seit
    Sep 2000
    Beiträge
    17.051
    Was bitteschön soll an der Erklärung des Wort Patches hilfreich sein?

    Du verwirrst mit deinem Link jeden Anfänger, der gar nicht rafft, warum es geht.

  11. #11
    Elefantenversteher Avatar von florian0285
    Registriert seit
    Jun 2016
    Beiträge
    1.047
    Die Verwirrung war doch schon spätestens hier vorhanden:

    Zitat Zitat von towo2099 Beitrag anzeigen
    VMware ...Der Patch ... Kernel ...bauen.
    Siehe Reaktion:
    Zitat Zitat von Andi123 Beitrag anzeigen
    @ towo2099
    wie kann ich was patchen
    Zitat Zitat von stefan.becker Beitrag anzeigen
    Dieser Link beinhaltet u. a.
    In vmnet-only/userif.c, around line 113, change
    #if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0)
    retval = get_user_pages(addr, 1, 1, 0, &page, NULL);
    ... usw...
    Englisch... cryptischer Code.... noch verwirrender....

    Zitat Zitat von stefan.becker Beitrag anzeigen
    Was bitteschön soll an der Erklärung des Wort Patches hilfreich sein?

    Du verwirrst mit deinem Link jeden Anfänger, der gar nicht rafft, warum es geht.
    In dem Link wird nicht nur "das Wort" erklärt. Ob das für nen Anfänger geeignet ist... keine Ahnung... es wird aber erkärt, dass Patches sowas wie Updates für den Code sind und man diese einspielen kann/muss und dann den Kernel und die Module neu kompilieren usw. Das auch noch schön auf deutsch. Auch wenn er das nicht gleich 1:1 umsetzen kann weiß er doch so im "groben" was da (von anderen) gemacht werden muss und warum das bei seinem Kernel vermutlich noch nicht läuft.

    Aber in diesem Sinne... gute Nacht und Gruß an die EULA
    Matthäus 7:3 Was siehst du aber den Splitter in deines Bruders Auge, und wirst nicht gewahr des Balkens in deinem Auge?

  12. #12
    Registrierter Benutzer
    Registriert seit
    Oct 2011
    Beiträge
    94
    Danke für eure Antworten.

    Die neue VMWarePlayer Version 12.5.4 funktioniert auch mit Kernel 4.10.
    Desktop Tuxedo, ASRock H170M Pro4, i7-7700K, 32 GB RAM, Mint 18.2 Mate 64, Mint 17.3 XFCE 64, Windows 10 Pro 64.
    HP Pavilion dv7-1289eg Core 2 Duo P8600 2x 2.40GHz, NVIDIA GeForce 9600M GT 512MB, 8GB RAM, Mint 18.2 Mate 64

Ähnliche Themen

  1. Firefox startet nicht (das hatte ich seit 50 Jahren nicht mehr)
    Von Dono im Forum Anwendungen Allgemein, Software
    Antworten: 3
    Letzter Beitrag: 21.10.16, 21:07
  2. VmWarePlayer --- VM von NTFS nicht startbar?
    Von Bronks im Forum Virtuelle Maschinen und Emulatoren
    Antworten: 2
    Letzter Beitrag: 21.08.08, 15:09
  3. vmwareplayer mit Partitonszugrifftroubles
    Von eternity2002 im Forum Virtuelle Maschinen und Emulatoren
    Antworten: 4
    Letzter Beitrag: 02.01.06, 22:54
  4. Suse 9.2 startet nicht mehr nachdem DVDBrenner nicht erkannt wurde
    Von VenomousAnimal im Forum System installieren und konfigurieren
    Antworten: 18
    Letzter Beitrag: 24.01.05, 10:09
  5. Pc startet nicht mehr
    Von Nikkita im Forum stationäre Hardware
    Antworten: 9
    Letzter Beitrag: 12.04.03, 16:38

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •