Ergebnis 1 bis 7 von 7

Thema: php.ini wird scheinbar ignoriert

  1. #1
    Registrierter Benutzer
    Registriert seit
    Mar 2012
    Beiträge
    5

    Question php.ini wird scheinbar ignoriert

    Hallo,

    ich bin gerade am Verzweifeln, da meine php.ini (PHP 5.2.2 - ganz frisch installiert; V 5.2.1 machte die gleichen Probleme) scheinbar ignoriert wird.

    Diese liegt in /etc/, d.h. so wie es eigentlich sein sollte. phpinfo() zeigt mir auch den Pfad korrekt an.

    Nur wenn ich die post_max_size auf meinetwegen "20M" ändere, wirkt sich das überhaupt nicht aus - es wird immer der default-Wert von "8M" hergenommen und angezeigt. Browsercache wurde auch geleert und der Apache neu gestartet.

    Das einzige, das sich getan hat war, dass die phpinfo() nun PHP Version 5.2.2 anzeigt.

    Hat jemand eine Idee, woran es liegen könnte? Berechtigungsproblem? Im Error-Log des Apache kann ich leider nur sehen, dass der Server mit dem PHP Modul neu gestartet worden ist. Kennt vielleicht jemand ein anderes Logfile mit aussagekräftigeren Informationen für mich?

    Danke schonmal für Eure Mühe!!!!!

    P.s: Läuft unter Linux und die Installation erfolgte als root-Benutzer; es wurde die php.ini-recommended als Basis nach /etc/ kopiert
    Geändert von Marco74 (21.03.12 um 14:01 Uhr)

  2. #2
    Registrierter Benutzer
    Registriert seit
    Mar 2012
    Beiträge
    5
    Mir ist gerade aufgefallen, dass über die Konsole mit /php/bin/php -c /etc/php.ini -i | grep 'post' alles korrekt angezeigt wird. D.h. er scheint via Konsole auf eine andere Konfigurationsdatei als über den Apache zuzugreifen. Hat einer eine Idee, woran das liegen könnte?
    Geändert von Marco74 (21.03.12 um 14:33 Uhr)

  3. #3
    Shell-User Avatar von zyrusthc
    Registriert seit
    Jan 2004
    Ort
    http://www.thale.de
    Beiträge
    6.322
    Was meint den:
    find / -name php.ini
    ?

    Greeez Oli
    Notebook: Lenovo Z570 CoreI7
    Workstation: Core2Quad Q6700 - ASUS P5WDG2-WS Pro - 8800GT - 4GB-DDR2/800 - 4x500GB=RAID1 - 120GB SSD - Innovatek Wakü - 27Widescreen/AcerTFT
    Server: IBM X345 + Netfinity 5000

    http://zyrusthc-linux.no-ip.org

  4. #4
    Registrierter Benutzer
    Registriert seit
    Mar 2012
    Beiträge
    5
    Hi Oli,

    der sagt nur korrekt

    /etc/php.ini

    D.h. es ist die definitiv die einzige Datei mit dem Namen auf dem System.

    In der phpinfo wird mir auch
    PHP-Code:
    Configuration File (php.iniPath     /etc/php.ini 
    korrekt ausgegeben.

    Es schaut für mich eher so aus, als ob er auf Default-Werte zurückgreift und er meine Datei aus irgendeinem Grund einfach nicht auslesen möchte. Zumindest via Apache - die Konsole scheint soweit zu funktionieren. Wenn ich dort jedoch den expliziten Pfad zur php.ini nicht mit angeben, zeigt auch
    PHP-Code:
    php -i|grep 'post' 
    falsche Werte an.

    Bin mit meinem Latein leider am Ende.

  5. #5
    Registrierter Benutzer
    Registriert seit
    Mar 2012
    Beiträge
    5
    So langsam kommt Licht ins Dunkle. Ich hab die Ausgabe von phpinfo gerade mit der von einem anderen Server verglichen. Und zwar ist
    PHP-Code:
    Loaded Configuration File     (none
    natürlich genau der Fehler.

    Wie bekomm ich es denn hin, dass die config-Datei geladen und nicht ignoriert wird? Gibts doch ned...

    Danke für die Hilfe!!!

  6. #6
    Registrierter Benutzer
    Registriert seit
    Mar 2012
    Beiträge
    5
    Oh man... ich bin so doof... Wenn man natürlich als den Dateinamen im Config-File-Path "/etc/php.ini" mit angibt, dann kann es auch nicht klappen... Da gehört natürlich nur "/etc" rein. Ich mach Feierabend und buche am besten erstmal 4 Wochen Urlaub in der Karibik

    Schönen Abend Euch noch^^

  7. #7
    Shell-User Avatar von zyrusthc
    Registriert seit
    Jan 2004
    Ort
    http://www.thale.de
    Beiträge
    6.322
    Wollte es gerade schreiben Path != File.

    Greeez Oli
    Notebook: Lenovo Z570 CoreI7
    Workstation: Core2Quad Q6700 - ASUS P5WDG2-WS Pro - 8800GT - 4GB-DDR2/800 - 4x500GB=RAID1 - 120GB SSD - Innovatek Wakü - 27Widescreen/AcerTFT
    Server: IBM X345 + Netfinity 5000

    http://zyrusthc-linux.no-ip.org

Ähnliche Themen

  1. apache2 ignoriert einträge in php.ini
    Von BigMack im Forum Linux als Server
    Antworten: 8
    Letzter Beitrag: 13.11.09, 18:19
  2. DD - ZIelfestplatte hat fehlerhaften Sektor
    Von dnaxx im Forum stationäre Hardware
    Antworten: 7
    Letzter Beitrag: 07.06.09, 12:13
  3. make depend && make // make[1]: *** [unicode] Fehler
    Von hmstr im Forum Emulatoren für Spiele
    Antworten: 3
    Letzter Beitrag: 31.10.07, 20:20
  4. php.ini wird ignoriert (apache 2.2.3 + php 5.1.2)
    Von dbr im Forum Linux als Server
    Antworten: 7
    Letzter Beitrag: 13.02.07, 06:07
  5. Krename compilieren
    Von AnHu im Forum Kompilieren von Kernel und Sourcen
    Antworten: 2
    Letzter Beitrag: 29.09.04, 19:23

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •