Anzeige:
Ergebnis 1 bis 5 von 5

Thema: CVS - Login schlägt fehl

  1. #1
    Registrierter Benutzer
    Registriert seit
    Jan 2006
    Ort
    Dresden
    Beiträge
    324

    CVS - Login schlägt fehl

    Hi!

    ich habe einen cvs-server nach diesem Tutorial aufgesetzt.

    Nun komm ich bis zum login, welcher leider fehlschlägt.

    Code:
    cvs -d :pserver:unicate@localhost:/cvsrepo login
    Logging in to :pserver:unicate@localhost:2401/cvsrepo
    CVS password: 
    cvs login: authorization failed: server localhost rejected access to /cvsrepo for user unicate
    PW ist sicher richtig, habe auch andere versucht...

    die passwd im CVSROOT ist vorhanden und hat folgenden inhalt:
    Code:
    unicate:XXXXXX:cvsd
    wobei ich jetzt das verschlüsselte pw rausgenommen habe.

    rechte für das gesamte root-dir: cvsd:cvsd
    SystemAuth=no
    ist auch nicht mehr kommentiert.
    /* no comment */

  2. #2
    Registrierter Benutzer
    Registriert seit
    Jun 2004
    Beiträge
    1.366
    Zitat Zitat von Unicate Beitrag anzeigen
    rechte für das gesamte root-dir: cvsd:cvsd
    Und für das /cvsrepo ?

  3. #3
    Registrierter Benutzer
    Registriert seit
    Jan 2006
    Ort
    Dresden
    Beiträge
    324
    Hier gab/gibt es nun ein Problem.
    Da ich das cvsrepo nicht in /var/lib/cvsd/cvsrepo habben möchte, sondern auf einer usbplatte habe ich cvsrepo einen symlink dahin gegeben. Ich hatte gestern noch ein wenig herumprobiert und habe festgestellt, wenn ich statt dem symlink ein normales verzeichnis erstelle, dann kann ich mich auch einloggen.

    Wie kann ich denn das Standartverzeichnis ändern?
    /* no comment */

  4. #4
    Registrierter Benutzer
    Registriert seit
    Jan 2006
    Ort
    Dresden
    Beiträge
    324
    Nach ein wenig suchen hatte ich diesen Artikel gefunden.

    Das habe ich gleich probiert, das heisst:
    Code:
    sudo apt-get purge cvsd
    sudo apt-get install cvsd #/cvsrepo angegeben
    sudo mkdir /media/space/cvsrepo
    sudo groupadd cvsusers
    sudo addgroup unicate cvsusers
    sudo cvs -d /media/space/cvsrepo init
    sudo chown -R cvsd:cvsusers /media/space/cvsrepo
    sudo cvsd-passwd /media/space/cvsrepo +unicate
    sudo vim /media/space/cvsrepo/CVSROOT/config # uncommenting SystemAuth=no
    Nun funktioniert wieder gar nichts mehr. kein login von nirgens.
    Was mach ich falsch?
    Geändert von Unicate (14.02.09 um 04:10 Uhr)
    /* no comment */

  5. #5
    Registrierter Benutzer
    Registriert seit
    Jun 2004
    Beiträge
    1.366
    Poste mal /etc/cvsd/cvsd.conf.

Ähnliche Themen

  1. root login per ssh schlägt fehl
    Von martin2002 im Forum Linux als Server
    Antworten: 22
    Letzter Beitrag: 04.05.07, 16:02
  2. Login schlägt fehl bei VSFTPD
    Von root_tux_linux im Forum Linux als Server
    Antworten: 4
    Letzter Beitrag: 02.03.05, 19:06
  3. Einführung in das Concurrent Versions System (CVS)
    Von stokedfish im Forum Tipps und Tricks
    Antworten: 3
    Letzter Beitrag: 15.08.04, 14:30
  4. Mandrake Cooker Problem
    Von Mephilio im Forum System installieren und konfigurieren
    Antworten: 2
    Letzter Beitrag: 27.02.04, 16:19
  5. mldonkey installieren (compilieren!)
    Von DrainDZ im Forum Kompilieren von Kernel und Sourcen
    Antworten: 5
    Letzter Beitrag: 30.04.03, 13:25

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •