Anzeige:
Ergebnis 1 bis 1 von 1

Thema: Zuerst lesen, dann posten!

  1. #1
    Moderator/Kaffeemann Avatar von Columbo0815
    Registriert seit
    Oct 2001
    Beiträge
    2.607

    Exclamation Zuerst lesen, dann posten!

    Hier ensteht nach und nach eine FAQ. Auch hier bitte ich um eure Mithilfe. Ihr könnt mir eure Beiträge per PN schicken, ich werde sie mit Autorenangabe (bei Bedarf auch anonym) posten. Dieser Beitrag bleibt aus Übersichtlichkeitsgründen geschlossen.

    An dieser Stelle vielen Dank an yusuf75, welcher mir den größten Teil der FAQ hat zukommen lassen. Diese habe ich 1:1 übernommen und bisher lediglich leicht in der Formatierung geändert. Dankeschön!

    Wie ich Fragen stelle
    Du hast ein Problem. Wir sollen es lösen. Tun wir gerne, aber bitte hilf uns dabei dir zu helfen. Folgende Angaben sollten (auch wenn ihr vielleicht denkt, dass es nicht erforderlich ist) immer dabei sein:

    - Distribution
    - Soundkarte (Hersteller, Chipsatz, On-/Offboard)
    - Treiber (Alsa, OSS, Kernelinterne)
    - Kernelversion

    Weiterhin solltet ihr euer Problem so beschreiben, dass es dritte (wir) verstehen können. Wir können keine Gedanken lesen. Bitte gib an, was du bereits versucht hast um dein Problem zu beheben. Versucht auch den Betreff so zu wählen, das dort schon klar ist was gemeint ist. Ein Betreff wie "Sound dud net!!!1!!!!" wird von mir unkommentiert geändert.

    Sollten das Problem zB durch unsere Hilfe gelöst sein bzw. wenn sich das Problem auf andere Weise gelöst hat, wäre es freundlich wenn ihr ein kurzes Statement abgebt. Bei den vielen Beiträgen mit genau 1 Antwort verliert man die Lust zu helfen.

    FAQ's
    Ich bekomme nur einen Sound gleichzeitig.
    -> Installiere dir einen Soundserver (artsd, esd)

    Ich kann keine CDs anhören. Unter Windows klappt das auch ohne Audiokabel!
    -> Entweder du nimmst ein Audiokabel oder du stellst zB xmms ensprechend ein. Aus Performancegründen empfehle ich (auch unter Windows) das Audiokabel.

    Ich kann keine Audio-CDs mounten!
    -> Das geht nicht. Audio-CDs haben kein Dateisystem, deswegen kann man diese nicht mounten.

    Erste Hilfe bei Soundproblemem für Linux-Newbies

    1. Sound geht in XMMS und Mplayer aber es sind keine Systemsounds in KDE zu hören, oder einige Programme melden, dass die Soundkarte von einem anderen Programm belegt ist.
    Normalerweise solltest du nun prüfen, welcher Soundtreiber aktiv ist, welche Treiber Version du verwendest.Es müssten Dateien geändert und Befehle in die Konsole getippt werden. Aber du bist ein Linux-Einsteiger und hast keine Ahnung wie das geht. Deswegen probier zuerst

    Lösung a)
    Hardware-Mixing wird von deinem Treiber unter Linux nicht unterstützt oder deine Karte ist falsch eingestellt. Du brauchst vorerst einen Soundserver.
    Aktiviere Arts unter KDE mit:
    Kontrollzentrum->Sounds&Multimedia->Soundserver->Soundsystem aktivieren.
    Wähle unter dem Reiter Hardware OSS,Open Sound System mit "Threads" oder Alsa. Hier musst du probieren mit welcher Einstellung es geht.

    Falls du nun Systemsound hörst geht der Sound meist in Xmms und/oder mplayer nicht. Deshalb musst du in beiden Tools das Output plugin ändern

    Xmms:
    Ändere unter Xmms das Outplut - Plugin :
    Preferences/Outplugin/Arts

    Mplayer:
    Preferences/Audio und dann arts wählen

    Mit dieser Methode wirst du 90% der Fälle kaum Schwierigkeiten haben. Jedoch wirst du in Realplayer oder in anderen Programme wie wine usw. keine Sounds hören, weil die sich mit arts nicht vertragen.

    Dir ist das egal, weil du findest den realplayer eh schlecht. Wahrscheinlich fragst du dich was z.B wine ist. Dann passt bei dir alles.


    2. Wie bekomme ich heraus welche Soundtreiber und welche Soundkarte ich verwende ?(Hier im Forum werde ich immer danach gefragt)

    Lösung a)
    Wähle im KDE: Infozentrum/Sound
    Die erste Zeile Sound Driver: XXXXXXX
    zeigt die Treiber Version an.
    Audio Device: xxxxxxxxxxxxxxxxxxxx
    zeigt die verwendete Soundkarte an

    Lösung b)
    Das Infozentrum im KDE zeigt gar nichts an.
    Öffne eine Konsole mit ALT+F2 und dann tip "konsole" ein, oder Klicke Konsole im KDE-Menü an.
    Tippe nun in die Konsole
    lsmod
    ein.

    Ich kann mit der Ausgabe nichts anfangen. Was soll das ?
    Du nicht, aber andere hier im Forum. Paste die Ausgabe hier im Forum bei deinem nächsten Soundproblem.
    Die Ausgabe zeigt uns welcher Treiber bei dir gerade Aktiv ist. Möglicherweise ist die Soundkarte nicht richtig vom Setup-Tool deiner Distribution richtig konfiguriert worden, oder es werden die falschen Treiber verwendet.

    3. Ich lese dauernd was von Alsa,OSS und Kernel-Treiber. Was ist das? Gibts denn keine Treiber von Herstellern?

    Doch. Aber nicht alle Soundkarten Hersteller bieten Treiber an. Das beste ist, du schaust auf der Webseite nach ob für deine Soundkarte, Treiber vom Hersteller zum Download angeboten werden

    4. Juhu es gibt Treiber für meine Soundkarte, aber wo ist Setup.exe??

    Es gibt keine .exe Dateien in Linux. Das ist eine lange Geschichte. Deswegen schau nach ob auf der Seite eine Anleitung existiert. Oder benutz die Suchfunktion des Forums. Falls es Treiber gibt, hat die hier bestimmt schon jemand im Einsatz, oder es hatten schon andere Probleme mit den Treibern.

    5. Es gibt leider keine offiziellen Treiber vom Hersteller

    Es gibt verschiedne Möglichkeiten deine Soundkarte zum laufen zu bringen.
    Deine erste Anlaufstelle sollte Alsa sein.
    Schau am besten in dieser Matrix
    nach ob deine Karte von Alsa unterstützt wird.

    6. Juhu meine Karte wird von Alsa unterstützt . Aber was soll ich tun?

    Jetzt wird es knifflig. Variante 1)

    Schau nach ob Alsa bei dir Installiert ist. Vergeliche die Installierte Version mit der Aktuellen Version auf der Alsa-Homepage.
    Falls der Versions-unterschied zu hoch ist besorg dir die passenden rpm's von den ftp-servern deiner Ditribution.
    Lösche die alte Versionen und installiere die neuen Versionen.
    Öffne eine Konsole und werde Root mit

    su

    Tippe nun

    depmod -a

    ein. Damit das System weiss, welche neuen Treiber zur Verfügung stehen.

    Führe nun am besten das Konfigurationstool deiner Distribution aus. Möglicherweise erkennt das Konfigurationstool nun die Soundkarte und es geht alles.

    Ich hab nun Alsa drauf, aber Sound geht immer noch nicht. Was soll ich tun?

    Probiere es zuerst auf eigene Faust. Zu jeder Soundkarte die oben in der Soundcard-Matrix angezeigt wird, existiert auch eine (englische) Beschreibung.

    Klicke auf Details und folge der Anleitung.


    Es geht immer noch nicht.??? Hiiiiilfeeeeee

    Ok. Du bist Linux-Einsteiger. Poste dein Problem hier , aber so, das dir die anderen auch wirklich helfen können:

    Man kann dir nur helfen wenn folgende Informationen vorliegen :

    * Welche Soundkarte ist bei dir im Einsatz (Punkt 2)
    * Poste die Ausgabe von lsmod ( auch Punkt 2 )

    Schlussworte:
    Ich kann jedem User nur empfehlen bei Problemen auch den IRC-Channel #linuxforen.de zu besuchen (Server: irc.linuxforen.de). Dort bekommt ihr oft gute Stichworte bzw. eine Lösung. Ich bin dort auch regelmäßig anzutreffen.
    Geändert von Columbo0815 (26.01.05 um 20:51 Uhr)
    Wie ist dein Name, Edler ? Columbo0815
    Hast du einen Farb-Bildschirm [J/N] ? N
    Vorgeschichte [J/N] ? N
    Erklärungen [J/N] ? N
    In Ebene 22 mit Amulett Wein aus Österreich getrunken

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •